Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/десятичные суммы преобразовать в дату и время - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » десятичные суммы преобразовать в дату и время (Формулы/Formulas)
десятичные суммы преобразовать в дату и время
andreichsb Дата: Суббота, 16.03.2019, 12:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Подскажите пожалуйста что делаю не так?
Имеются два значения:
в ячейке J3 имею значение 150319 которое нужно преобразовать в дату 15.03.19 для чего в ячейку J5 ставлю формулу =ДАТА(ЛЕВСИМВ(J3;4);ПСТР(J3;5;2);ПРАВСИМВ(J3;2))
но на выходе почему то имею дату 19.07.04

со временем вообще не могу понять, нашел только как часы и минуты получить из десятичного. В ячейке B3 имею значение 174855.00
нужно из него получить время в виде 17:45:55 (без тысячных)
как сделать, подскажите пожалуйста?
 
Ответить
СообщениеЗдравствуйте. Подскажите пожалуйста что делаю не так?
Имеются два значения:
в ячейке J3 имею значение 150319 которое нужно преобразовать в дату 15.03.19 для чего в ячейку J5 ставлю формулу =ДАТА(ЛЕВСИМВ(J3;4);ПСТР(J3;5;2);ПРАВСИМВ(J3;2))
но на выходе почему то имею дату 19.07.04

со временем вообще не могу понять, нашел только как часы и минуты получить из десятичного. В ячейке B3 имею значение 174855.00
нужно из него получить время в виде 17:45:55 (без тысячных)
как сделать, подскажите пожалуйста?

Автор - andreichsb
Дата добавления - 16.03.2019 в 12:37
bmv98rus Дата: Суббота, 16.03.2019, 12:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
Код
=--TEXT(J3;"00\/00\/00")

и формат даты соответвенно
Для времени и для случая когда десятичный разделитель ",", а не "."
Код
=--TEXT(SUBSTITUTE(B3;".";MID(1/2;2;1));"00\:00\:00")

А если с точкой все ок, то и просто
Код
=--TEXT(B3;"00\:00\:00")


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
Код
=--TEXT(J3;"00\/00\/00")

и формат даты соответвенно
Для времени и для случая когда десятичный разделитель ",", а не "."
Код
=--TEXT(SUBSTITUTE(B3;".";MID(1/2;2;1));"00\:00\:00")

А если с точкой все ок, то и просто
Код
=--TEXT(B3;"00\:00\:00")

Автор - bmv98rus
Дата добавления - 16.03.2019 в 12:49
andreichsb Дата: Суббота, 16.03.2019, 13:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
=--TEXT(J3;"00\/00\/00")

работает только в таком виде
[vba]
Код
=ТЕКСТ(J3;"00\.00\.00")
[/vba]

со временем ваши варианты выдают ошибку нераспознанного текста, если
[vba]
Код
=ТЕКСТ(B3;"00\:00\:00")
[/vba]
то просто транслирует число 174855.00 в ячейку с формулой
 
Ответить
Сообщение
=--TEXT(J3;"00\/00\/00")

работает только в таком виде
[vba]
Код
=ТЕКСТ(J3;"00\.00\.00")
[/vba]

со временем ваши варианты выдают ошибку нераспознанного текста, если
[vba]
Код
=ТЕКСТ(B3;"00\:00\:00")
[/vba]
то просто транслирует число 174855.00 в ячейку с формулой

Автор - andreichsb
Дата добавления - 16.03.2019 в 13:38
bmv98rus Дата: Суббота, 16.03.2019, 13:44 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
andreichsb, вот чтоб таких вопросов не возникало в правилах есть пункт о файле примере.
Код
=ТЕКСТ(J3;"00\.00\.00")
-выдаст текст а не дату, и не просто так писал
и формат даты соответвенно

174855.00 - скорее всего у вас не число , а текст


Замечательный медведь, процентов на 20.
 
Ответить
Сообщениеandreichsb, вот чтоб таких вопросов не возникало в правилах есть пункт о файле примере.
Код
=ТЕКСТ(J3;"00\.00\.00")
-выдаст текст а не дату, и не просто так писал
и формат даты соответвенно

174855.00 - скорее всего у вас не число , а текст

Автор - bmv98rus
Дата добавления - 16.03.2019 в 13:44
andreichsb Дата: Суббота, 16.03.2019, 13:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
=--TEXT(J3;"00\/00\/00")

выдает ошибку
в примере
К сообщению приложен файл: 4919130.xlsx(9.2 Kb)
 
Ответить
Сообщение
=--TEXT(J3;"00\/00\/00")

выдает ошибку
в примере

Автор - andreichsb
Дата добавления - 16.03.2019 в 13:54
bmv98rus Дата: Суббота, 16.03.2019, 14:11 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
А так?
К сообщению приложен файл: Copy_of_726.xlsx(9.8 Kb)


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеА так?

Автор - bmv98rus
Дата добавления - 16.03.2019 в 14:11
andreichsb Дата: Суббота, 16.03.2019, 14:27 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
так да, все фурычит
 
Ответить
Сообщениетак да, все фурычит

Автор - andreichsb
Дата добавления - 16.03.2019 в 14:27
_Boroda_ Дата: Суббота, 16.03.2019, 23:08 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
bmv98rus, что за безобразие? В первом посте формула без тегов, а ты отвечаешь
andreichsb, исправляйтесь


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеbmv98rus, что за безобразие? В первом посте формула без тегов, а ты отвечаешь
andreichsb, исправляйтесь

Автор - _Boroda_
Дата добавления - 16.03.2019 в 23:08
bmv98rus Дата: Воскресенье, 17.03.2019, 00:16 | Сообщение № 9
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
В первом посте формула без тегов
так я на русском её за формулу не воспринимаю. :-) Сорян. Правда не обратил внимание.


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
В первом посте формула без тегов
так я на русском её за формулу не воспринимаю. :-) Сорян. Правда не обратил внимание.

Автор - bmv98rus
Дата добавления - 17.03.2019 в 00:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » десятичные суммы преобразовать в дату и время (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!