Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества уникальных значений в диапазоне дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений в диапазоне дат (Формулы/Formulas)
Подсчет количества уникальных значений в диапазоне дат
aartimovich Дата: Суббота, 23.03.2019, 18:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Никак не могу подсчитать количество уникальных значений в определенную дату с условием. Помогите пожалуйста.
На листе 1 - Уникальное значение/дата/статус
На листе 2 - дата

Нужно посчитать - сколько уникальных значений имеется в диапазоне дат со статусом= Закрыт.
Файл с примером прилагаю.

Спасибо.
К сообщению приложен файл: 5033213.xlsx(12.0 Kb)
 
Ответить
СообщениеНикак не могу подсчитать количество уникальных значений в определенную дату с условием. Помогите пожалуйста.
На листе 1 - Уникальное значение/дата/статус
На листе 2 - дата

Нужно посчитать - сколько уникальных значений имеется в диапазоне дат со статусом= Закрыт.
Файл с примером прилагаю.

Спасибо.

Автор - aartimovich
Дата добавления - 23.03.2019 в 18:35
krosav4ig Дата: Суббота, 23.03.2019, 19:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2035
Репутация: 847 ±
Замечаний: 0% ±

Excel 2007,2010,2013
сводная не устроит?
К сообщению приложен файл: 1849573.xlsx(17.3 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениесводная не устроит?

Автор - krosav4ig
Дата добавления - 23.03.2019 в 19:45
lebensvoll Дата: Суббота, 23.03.2019, 20:55 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 889
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010
aartimovich, попробуйте эту формулу
Код
=СУММПРОИЗВ(--(Лист1!$D$2:$D$24="Закрыт");--(Лист1!$C$2:$C$24=H$1))


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениеaartimovich, попробуйте эту формулу
Код
=СУММПРОИЗВ(--(Лист1!$D$2:$D$24="Закрыт");--(Лист1!$C$2:$C$24=H$1))

Автор - lebensvoll
Дата добавления - 23.03.2019 в 20:55
Pelena Дата: Суббота, 23.03.2019, 21:06 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13883
Репутация: 3044 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
А если при создании сводной поставить флажок Добавить таблицу в модель данных, то можно задать операцию Число различных значений, то есть как раз количество уникальных


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА если при создании сводной поставить флажок Добавить таблицу в модель данных, то можно задать операцию Число различных значений, то есть как раз количество уникальных

Автор - Pelena
Дата добавления - 23.03.2019 в 21:06
Светлый Дата: Воскресенье, 24.03.2019, 00:37 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 261 ±
Замечаний: 0% ±

Excel 2010
Вот ещё массивная (Ctrl+Shift+Enter) формула:
Код
=СУММ((ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24))*(Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВот ещё массивная (Ctrl+Shift+Enter) формула:
Код
=СУММ((ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24))*(Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24))

Автор - Светлый
Дата добавления - 24.03.2019 в 00:37
aartimovich Дата: Вторник, 26.03.2019, 12:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем спасибо. Больше всего мне понравилось решение Светлого)
Можете ли дополнить в формулу массива проверку еще 1 го условия?

ТЗ :На листе 1 - Уникальное значение/дата/товар/статус
На листе 2 - дата

Нужно посчитать - сколько уникальных значений имеется в диапазоне дат со статусом= Закрыт и товаром=Банан.
Файл с примером прилагаю.
К сообщению приложен файл: 8552774.xlsx(12.6 Kb)
 
Ответить
СообщениеВсем спасибо. Больше всего мне понравилось решение Светлого)
Можете ли дополнить в формулу массива проверку еще 1 го условия?

ТЗ :На листе 1 - Уникальное значение/дата/товар/статус
На листе 2 - дата

Нужно посчитать - сколько уникальных значений имеется в диапазоне дат со статусом= Закрыт и товаром=Банан.
Файл с примером прилагаю.

Автор - aartimovich
Дата добавления - 26.03.2019 в 12:49
aartimovich Дата: Вторник, 26.03.2019, 16:22 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Светлый, помогите пожалуйста.
 
Ответить
СообщениеСветлый, помогите пожалуйста.

Автор - aartimovich
Дата добавления - 26.03.2019 в 16:22
_Boroda_ Дата: Вторник, 26.03.2019, 16:36 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Просто добавьте в формулу еще одно условие
Код
...ЕСЛИ((Лист1!$E1:$E24="Закрыт")*(G1=Лист1!$C1:$C24)*(Лист1!$D1:$D24="Банан")...


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПросто добавьте в формулу еще одно условие
Код
...ЕСЛИ((Лист1!$E1:$E24="Закрыт")*(G1=Лист1!$C1:$C24)*(Лист1!$D1:$D24="Банан")...

Автор - _Boroda_
Дата добавления - 26.03.2019 в 16:36
aartimovich Дата: Вторник, 26.03.2019, 18:08 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
...ЕСЛИ((Лист1!$E1:$E24="Закрыт")*(G1=Лист1!$C1:$C24)*(Лист1!$D1:$D24="Банан")...

после какого момента добавлять?
Можете вставить в формулу?
Код
=СУММ((ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24))*(Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24))
 
Ответить
Сообщение
...ЕСЛИ((Лист1!$E1:$E24="Закрыт")*(G1=Лист1!$C1:$C24)*(Лист1!$D1:$D24="Банан")...

после какого момента добавлять?
Можете вставить в формулу?
Код
=СУММ((ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24))*(Лист1!$D1:$D24="Закрыт")*(G1=Лист1!$C1:$C24))

Автор - aartimovich
Дата добавления - 26.03.2019 в 18:08
Светлый Дата: Вторник, 26.03.2019, 20:33 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1015
Репутация: 261 ±
Замечаний: 0% ±

Excel 2010
Вот так:
Код
=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24="Банан")*(Лист1!$E1:$E24="Закрыт")*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24)))
Код
=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24=$E3)*(Лист1!$E1:$E24=$F3)*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24)))
aartimovich, оформите свою формулу тегом fx.
К сообщению приложен файл: 8552774-1.xlsx(12.9 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 26.03.2019, 20:40
 
Ответить
СообщениеВот так:
Код
=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24="Банан")*(Лист1!$E1:$E24="Закрыт")*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24)))
Код
=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ(Лист1!$B1:$B24;ЕСЛИ((Лист1!$D1:$D24=$E3)*(Лист1!$E1:$E24=$F3)*(G1=Лист1!$C1:$C24);Лист1!$B1:$B24););)=СТРОКА(1:24)))
aartimovich, оформите свою формулу тегом fx.

Автор - Светлый
Дата добавления - 26.03.2019 в 20:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества уникальных значений в диапазоне дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!