Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывод да, если ровно 1 нечетная цифра в конце ряда - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывод да, если ровно 1 нечетная цифра в конце ряда (Формулы/Formulas)
вывод да, если ровно 1 нечетная цифра в конце ряда
Artemon Дата: Воскресенье, 24.03.2019, 22:25 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер.
Нужна небольшая формула
допустим есть ряд чисел в ячейке 212211221
нужно, чтобы формула смотрела сколько нечетных цифр в ячейке в конце и если в ячейке ровно 1(тоесть слева от последней нечетной цифры была четная) нечетная цифра в конце выводилось слово ДА
помогите пожалуйста


Сообщение отредактировал Artemon - Воскресенье, 24.03.2019, 22:46
 
Ответить
СообщениеДобрый вечер.
Нужна небольшая формула
допустим есть ряд чисел в ячейке 212211221
нужно, чтобы формула смотрела сколько нечетных цифр в ячейке в конце и если в ячейке ровно 1(тоесть слева от последней нечетной цифры была четная) нечетная цифра в конце выводилось слово ДА
помогите пожалуйста

Автор - Artemon
Дата добавления - 24.03.2019 в 22:25
bmv98rus Дата: Воскресенье, 24.03.2019, 22:49 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2057
Репутация: 333 ±
Замечаний: 20% ±

Excel 2013/2016
Artemon, если я правильно понимаю, то только 2 и 1 у вас и нужно просто определить последние 21, то тогда просто
Код
=if(right(a1;2)="21";"ДА")

Или там иные цифры могут быть и нужно определить именно последнюю по порядку нечетную и ее анализировать?


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеArtemon, если я правильно понимаю, то только 2 и 1 у вас и нужно просто определить последние 21, то тогда просто
Код
=if(right(a1;2)="21";"ДА")

Или там иные цифры могут быть и нужно определить именно последнюю по порядку нечетную и ее анализировать?

Автор - bmv98rus
Дата добавления - 24.03.2019 в 22:49
Karataev Дата: Воскресенье, 24.03.2019, 22:51 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1318
Репутация: 518 ±
Замечаний: 0% ±

Excel
Код
=ЕСЛИ(ЕНЕЧЁТ(ПРАВСИМВ(A1;1));ЕСЛИ(ЕНЕЧЁТ(ПСТР(A1;ДЛСТР(A1)-1;1));"Нет";"Да");"Нет")


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕНЕЧЁТ(ПРАВСИМВ(A1;1));ЕСЛИ(ЕНЕЧЁТ(ПСТР(A1;ДЛСТР(A1)-1;1));"Нет";"Да");"Нет")

Автор - Karataev
Дата добавления - 24.03.2019 в 22:51
Artemon Дата: Воскресенье, 24.03.2019, 22:52 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, да могут быть именно 2 и1, спасибо, сам не догадался до такого!
 
Ответить
Сообщениеbmv98rus, да могут быть именно 2 и1, спасибо, сам не догадался до такого!

Автор - Artemon
Дата добавления - 24.03.2019 в 22:52
_Boroda_ Дата: Воскресенье, 24.03.2019, 22:56 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для любого количества любых цифр
Код
=ЕСЛИ(ЕНЕЧЁТ(A1)*ЕЧЁТН(A1/10);"да";"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля любого количества любых цифр
Код
=ЕСЛИ(ЕНЕЧЁТ(A1)*ЕЧЁТН(A1/10);"да";"")

Автор - _Boroda_
Дата добавления - 24.03.2019 в 22:56
Artemon Дата: Воскресенье, 24.03.2019, 22:59 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, эта тоже пригодится, спасибо
Karataev, вам тоже спасибо!
 
Ответить
Сообщение_Boroda_, эта тоже пригодится, спасибо
Karataev, вам тоже спасибо!

Автор - Artemon
Дата добавления - 24.03.2019 в 22:59
bmv98rus Дата: Воскресенье, 24.03.2019, 23:00 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 2057
Репутация: 333 ±
Замечаний: 20% ±

Excel 2013/2016
Karataev,
Код
ПСТР(A1;ДЛСТР(A1)-1;1)
проще
Код
LEFT(RIGHT(A1;2);1))


Для любого количества любых цифр

Так уж и для любого? Ж-) . Для любого в пределах 999999999999999


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Воскресенье, 24.03.2019, 23:05
 
Ответить
СообщениеKarataev,
Код
ПСТР(A1;ДЛСТР(A1)-1;1)
проще
Код
LEFT(RIGHT(A1;2);1))


Для любого количества любых цифр

Так уж и для любого? Ж-) . Для любого в пределах 999999999999999

Автор - bmv98rus
Дата добавления - 24.03.2019 в 23:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывод да, если ровно 1 нечетная цифра в конце ряда (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!