Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечение искомого буквенного и числового значенияиз текста - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение искомого буквенного и числового значенияиз текста (Формулы/Formulas)
Извлечение искомого буквенного и числового значенияиз текста
Lis Дата: Вторник, 26.03.2019, 11:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!Помогите правильно прописать формулу.Мне нужно из текста извлечь только артикул.Он может быть один, может несколько.Пример во вложении.Спасибо.
К сообщению приложен файл: 4991480.xlsx(9.3 Kb)
 
Ответить
СообщениеДобрый день!Помогите правильно прописать формулу.Мне нужно из текста извлечь только артикул.Он может быть один, может несколько.Пример во вложении.Спасибо.

Автор - Lis
Дата добавления - 26.03.2019 в 11:01
sboy Дата: Вторник, 26.03.2019, 15:43 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Маловато вариантов для такого рода задач.
Для примера
[vba]
Код
Function Lis(t As String) As String
    With CreateObject("VBScript.RegExp")
        .Global = True
        .Pattern = "[А-Я]{2}-\d{8}"
        If .test(t) Then
            For i = 0 To .Execute(t).Count - 1
                Lis = Lis & .Execute(t)(i) & " "
            Next
        End If
    End With
End Function
[/vba]
К сообщению приложен файл: Lis.xlsm(15.5 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Маловато вариантов для такого рода задач.
Для примера
[vba]
Код
Function Lis(t As String) As String
    With CreateObject("VBScript.RegExp")
        .Global = True
        .Pattern = "[А-Я]{2}-\d{8}"
        If .test(t) Then
            For i = 0 To .Execute(t).Count - 1
                Lis = Lis & .Execute(t)(i) & " "
            Next
        End If
    End With
End Function
[/vba]

Автор - sboy
Дата добавления - 26.03.2019 в 15:43
Lis Дата: Среда, 27.03.2019, 11:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, Спасибо вам огромное!!!Это то, что нужно!!!
 
Ответить
Сообщениеsboy, Спасибо вам огромное!!!Это то, что нужно!!!

Автор - Lis
Дата добавления - 27.03.2019 в 11:04
Светлый Дата: Среда, 27.03.2019, 13:31 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1152
Репутация: 292 ±
Замечаний: 0% ±

Excel 2010
Если надо формулами, то в E2 копируем формулу:
Код
=ЕСЛИОШИБКА(ПСТР($A2;ПОИСК("Ф?-*";$A2;ПОИСК(D2;0&$A2));11);"  ")
и протягиваем вправо и вниз. Каждый артикул будет в своей ячейке.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕсли надо формулами, то в E2 копируем формулу:
Код
=ЕСЛИОШИБКА(ПСТР($A2;ПОИСК("Ф?-*";$A2;ПОИСК(D2;0&$A2));11);"  ")
и протягиваем вправо и вниз. Каждый артикул будет в своей ячейке.

Автор - Светлый
Дата добавления - 27.03.2019 в 13:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение искомого буквенного и числового значенияиз текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!