Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка объектов по датам проведения мероприятий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка объектов по датам проведения мероприятий (Формулы/Formulas)
Сортировка объектов по датам проведения мероприятий
buka77 Дата: Четверг, 28.03.2019, 15:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 6 ±
Замечаний: 0% ±

Excel 2010
Суть вопроса такова. Есть график проведения мероприятий по объектам, составленный в хронологическом порядке по датам. Можно ли составить вторую таблицу, в которой будут собраны все объекты в строку с одинаковыми датами, не прибегая к использованию УФ. В примере, я думаю, будет всё более понятно.
К сообщению приложен файл: 01.xlsx(36.0 Kb)
 
Ответить
СообщениеСуть вопроса такова. Есть график проведения мероприятий по объектам, составленный в хронологическом порядке по датам. Можно ли составить вторую таблицу, в которой будут собраны все объекты в строку с одинаковыми датами, не прибегая к использованию УФ. В примере, я думаю, будет всё более понятно.

Автор - buka77
Дата добавления - 28.03.2019 в 15:02
_Boroda_ Дата: Четверг, 28.03.2019, 15:26 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(C$6>=СЧЁТЕСЛИ(Отв.!$B:$B;$A8);"";ИНДЕКС(Отв.!$A$4:$A$122;ПОИСКПОЗ($A8;Отв.!$B$4:$B$122;0)+C$6))

И для запятых
Код
=ЕСЛИ(E8="";"";",")
К сообщению приложен файл: 01_1.xlsx(38.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(C$6>=СЧЁТЕСЛИ(Отв.!$B:$B;$A8);"";ИНДЕКС(Отв.!$A$4:$A$122;ПОИСКПОЗ($A8;Отв.!$B$4:$B$122;0)+C$6))

И для запятых
Код
=ЕСЛИ(E8="";"";",")

Автор - _Boroda_
Дата добавления - 28.03.2019 в 15:26
buka77 Дата: Четверг, 28.03.2019, 15:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 6 ±
Замечаний: 0% ±

Excel 2010
Да. Спасибо. Именно то. А можно всю информацию в одну ячейку закинуть напротив каждой даты или это уже никак?
 
Ответить
СообщениеДа. Спасибо. Именно то. А можно всю информацию в одну ячейку закинуть напротив каждой даты или это уже никак?

Автор - buka77
Дата добавления - 28.03.2019 в 15:54
_Boroda_ Дата: Четверг, 28.03.2019, 16:02 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно допстолбец
Код
=A4&ЕСЛИ(B4=B5;","&G5;"")
и потом ВПР
Или перебором 11 условий, но это непофеншуйно
К сообщению приложен файл: 01_2.xlsx(41.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно допстолбец
Код
=A4&ЕСЛИ(B4=B5;","&G5;"")
и потом ВПР
Или перебором 11 условий, но это непофеншуйно

Автор - _Boroda_
Дата добавления - 28.03.2019 в 16:02
buka77 Дата: Четверг, 28.03.2019, 16:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 6 ±
Замечаний: 0% ±

Excel 2010
Интересный вариант. Спасибо.
 
Ответить
СообщениеИнтересный вариант. Спасибо.

Автор - buka77
Дата добавления - 28.03.2019 в 16:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка объектов по датам проведения мероприятий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!