Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложить только + или - числа и вывести то где число больше.. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложить только + или - числа и вывести то где число больше.. (Формулы/Formulas)
Сложить только + или - числа и вывести то где число больше..
stalber Дата: Суббота, 30.03.2019, 13:41 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, подскажите пожалуйста.

Имеется 3 ячейки(диапазон), в них бывают как положительные так и отрицательные числа.

Эти формулы, не подойдут:
Код
=СУММЕСЛИ(диапазон;">0")  
=СУММЕСЛИ(диапазон;"<0")

так как их две, а мне нужна одна формула, в одну ячейку, которая будет показывать сумму из 3-ёх чисел самых наибольших или сумму самых наименьших чисел, что из них больше от нуля то и выводится.

Например 3 числа:
-10
5
-15
Формула выведет число: -25

Ещё пример 3 числа:
10
20
-29
Формула выведет число: 30
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста.

Имеется 3 ячейки(диапазон), в них бывают как положительные так и отрицательные числа.

Эти формулы, не подойдут:
Код
=СУММЕСЛИ(диапазон;">0")  
=СУММЕСЛИ(диапазон;"<0")

так как их две, а мне нужна одна формула, в одну ячейку, которая будет показывать сумму из 3-ёх чисел самых наибольших или сумму самых наименьших чисел, что из них больше от нуля то и выводится.

Например 3 числа:
-10
5
-15
Формула выведет число: -25

Ещё пример 3 числа:
10
20
-29
Формула выведет число: 30

Автор - stalber
Дата добавления - 30.03.2019 в 13:41
skais Дата: Суббота, 30.03.2019, 14:39 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 173
Репутация: 23 ±
Замечаний: 60% ±

Excel 2010
Код
=ЕСЛИ(СУММЕСЛИ(A1:A3;">0")>=ABS(СУММЕСЛИ(A1:A3;"<0"));СУММЕСЛИ(A1:A3;">0");СУММЕСЛИ(A1:A3;"<0"))


Сообщение отредактировал skais - Суббота, 30.03.2019, 14:39
 
Ответить
Сообщение
Код
=ЕСЛИ(СУММЕСЛИ(A1:A3;">0")>=ABS(СУММЕСЛИ(A1:A3;"<0"));СУММЕСЛИ(A1:A3;">0");СУММЕСЛИ(A1:A3;"<0"))

Автор - skais
Дата добавления - 30.03.2019 в 14:39
_Boroda_ Дата: Суббота, 30.03.2019, 15:50 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
stalber, условие какое-то непонятное - если всего ячейки три, то три наибольших - это все три ячейки, независимо от того, больше нуля они или меньше. То же самое и про три наименьших. Разнится будет только последовательность - у наибольших будет 5, -10, -15, а у наименьших - -15, -10, 5
Если числа -99, 1, 2, то выводится -99, так? Ведь несмотря на то, что положительных чисел два, расстояние от нуля до -99 больше, чем до 3
И что выводить, если 1, 2, -3?

Варианты формулы (разница в случае равенства "+" и "-")
Код
=СУММЕСЛИ(A1:A3;ЕСЛИ(СУММ(A1:A3)>0;">0";"<0"))

Код
=СУММЕСЛИ(A1:A3;ЕСЛИ(СУММ(A1:A3)<0;"<0";">0"))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеstalber, условие какое-то непонятное - если всего ячейки три, то три наибольших - это все три ячейки, независимо от того, больше нуля они или меньше. То же самое и про три наименьших. Разнится будет только последовательность - у наибольших будет 5, -10, -15, а у наименьших - -15, -10, 5
Если числа -99, 1, 2, то выводится -99, так? Ведь несмотря на то, что положительных чисел два, расстояние от нуля до -99 больше, чем до 3
И что выводить, если 1, 2, -3?

Варианты формулы (разница в случае равенства "+" и "-")
Код
=СУММЕСЛИ(A1:A3;ЕСЛИ(СУММ(A1:A3)>0;">0";"<0"))

Код
=СУММЕСЛИ(A1:A3;ЕСЛИ(СУММ(A1:A3)<0;"<0";">0"))

Автор - _Boroda_
Дата добавления - 30.03.2019 в 15:50
Светлый Дата: Суббота, 30.03.2019, 17:17 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1112
Репутация: 283 ±
Замечаний: 0% ±

Excel 2010
Или так:
Код
=СУММЕСЛИ(A1:A3;ТЕКСТ(СУММ(A1:A3);">;<")&0)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИли так:
Код
=СУММЕСЛИ(A1:A3;ТЕКСТ(СУММ(A1:A3);">;<")&0)

Автор - Светлый
Дата добавления - 30.03.2019 в 17:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложить только + или - числа и вывести то где число больше.. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!