Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения из интервалов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из интервалов
Выбор значения из интервалов
mkotik Дата: Понедельник, 01.04.2019, 17:56 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер Уважаемые Знатоки!
В столбце A и B заданы минимальные и максимальные значения интервалов. В столбце C - необходимые значения, которые надо вывести в "зеленую" ячейку по значению из "жёлтой". Строк в таблице более 1млн. Как формулой это получить?
Заранее благодарен.
К сообщению приложен файл: 6462021.xlsx(8.5 Kb)
 
Ответить
СообщениеДобрый вечер Уважаемые Знатоки!
В столбце A и B заданы минимальные и максимальные значения интервалов. В столбце C - необходимые значения, которые надо вывести в "зеленую" ячейку по значению из "жёлтой". Строк в таблице более 1млн. Как формулой это получить?
Заранее благодарен.

Автор - mkotik
Дата добавления - 01.04.2019 в 17:56
mkotik Дата: Понедельник, 01.04.2019, 18:00 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Прошу модераторов тему перенести в Вопросы по Excel
 
Ответить
СообщениеПрошу модераторов тему перенести в Вопросы по Excel

Автор - mkotik
Дата добавления - 01.04.2019 в 18:00
_Boroda_ Дата: Понедельник, 01.04.2019, 19:02 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14864
Репутация: 5881 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(C:C;ПОИСКПОЗ(E2;A1:A99;-1))

Можно поизвращаться с СУММЕСЛИ, СУММПРОИЗВ, ПРОСМОТР, ...
Но думаю, что ИНДЕКС/ПОИСКПОЗ будет быстрее
Да, это если принцип реальной таблицы действительно такой же, как в примере - по убыванию
К сообщению приложен файл: 6462021_1.xlsx(8.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(C:C;ПОИСКПОЗ(E2;A1:A99;-1))

Можно поизвращаться с СУММЕСЛИ, СУММПРОИЗВ, ПРОСМОТР, ...
Но думаю, что ИНДЕКС/ПОИСКПОЗ будет быстрее
Да, это если принцип реальной таблицы действительно такой же, как в примере - по убыванию

Автор - _Boroda_
Дата добавления - 01.04.2019 в 19:02
mkotik Дата: Понедельник, 01.04.2019, 21:46 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Александр, Огромное спасибо!
Вы как всегда подсказываете интересные решения...
А я мучался с СУММЕСЛИ hands
 
Ответить
СообщениеАлександр, Огромное спасибо!
Вы как всегда подсказываете интересные решения...
А я мучался с СУММЕСЛИ hands

Автор - mkotik
Дата добавления - 01.04.2019 в 21:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из интервалов
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!