Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вытянуть итоговое значение по месяцам из сложной сводной таб - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытянуть итоговое значение по месяцам из сложной сводной таб (Формулы/Formulas)
Вытянуть итоговое значение по месяцам из сложной сводной таб
TurboRadost Дата: Вторник, 02.04.2019, 10:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, друзья.
помогите решить задачку.
1. есть сводная таблица (к сожалению прислать ее не могу, пример создать тоже будет сложно) из которой нужно вытянуть значение "общий итог" по месяцам. [img][/img]
2. при использовании формулы
Код
=ИНДЕКС(B39:B826;ПОИСКПОЗ("Общий итог";A39:A881;0))
все работает отлично, но когда раскрывается столбец с классификацией значение, которое мне нужно находится вне диапазона :(
[img][/url][/img]
3. функцию получить.данные.сводной.таблицы применить не получается. таблица может увеличиваться вниз и в ширь.

в каком направлении копать, с какой стороны правильно заходить к этой задаче?


Сообщение отредактировал TurboRadost - Вторник, 02.04.2019, 10:56
 
Ответить
СообщениеДобрый день, друзья.
помогите решить задачку.
1. есть сводная таблица (к сожалению прислать ее не могу, пример создать тоже будет сложно) из которой нужно вытянуть значение "общий итог" по месяцам. [img][/img]
2. при использовании формулы
Код
=ИНДЕКС(B39:B826;ПОИСКПОЗ("Общий итог";A39:A881;0))
все работает отлично, но когда раскрывается столбец с классификацией значение, которое мне нужно находится вне диапазона :(
[img][/url][/img]
3. функцию получить.данные.сводной.таблицы применить не получается. таблица может увеличиваться вниз и в ширь.

в каком направлении копать, с какой стороны правильно заходить к этой задаче?

Автор - TurboRadost
Дата добавления - 02.04.2019 в 10:54
_Boroda_ Дата: Вторник, 02.04.2019, 10:57 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
1. Тогда только общие рекомендации
2. А если не 881, а 9999?
3. Размер таблицы не влияет на функцию получить.данные.сводной.таблицы


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение1. Тогда только общие рекомендации
2. А если не 881, а 9999?
3. Размер таблицы не влияет на функцию получить.данные.сводной.таблицы

Автор - _Boroda_
Дата добавления - 02.04.2019 в 10:57
TurboRadost Дата: Вторник, 02.04.2019, 11:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
. А если не 881, а 9999?

значение, которое нужно уходит в другой столбец. при раскрытии столбца группа добавляется еще один столбец и значение перескакивает со стоkбца B в C
 
Ответить
Сообщение
. А если не 881, а 9999?

значение, которое нужно уходит в другой столбец. при раскрытии столбца группа добавляется еще один столбец и значение перескакивает со стоkбца B в C

Автор - TurboRadost
Дата добавления - 02.04.2019 в 11:38
_Boroda_ Дата: Вторник, 02.04.2019, 11:51 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Это решаемо. Например, с помощью второго ПОИСКПОЗ
Код
=ИНДЕКС(B39:C9999;ПОИСКПОЗ("Общий итог";A39:A9999;);поискпоз("2018, январь";B40:C40;))


Но по-любому гораздо лучше использовать п.3


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЭто решаемо. Например, с помощью второго ПОИСКПОЗ
Код
=ИНДЕКС(B39:C9999;ПОИСКПОЗ("Общий итог";A39:A9999;);поискпоз("2018, январь";B40:C40;))


Но по-любому гораздо лучше использовать п.3

Автор - _Boroda_
Дата добавления - 02.04.2019 в 11:51
TurboRadost Дата: Вторник, 02.04.2019, 12:06 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо.
так же мне помогла галка
[img][/img]
но это
Код
=ИНДЕКС(B39:C9999;ПОИСКПОЗ("Общий итог";A39:A9999;);поискпоз("2018, январь";B40:C40;))

на много привлекательнее, т.к. применений больше.
 
Ответить
Сообщениеспасибо.
так же мне помогла галка
[img][/img]
но это
Код
=ИНДЕКС(B39:C9999;ПОИСКПОЗ("Общий итог";A39:A9999;);поискпоз("2018, январь";B40:C40;))

на много привлекательнее, т.к. применений больше.

Автор - TurboRadost
Дата добавления - 02.04.2019 в 12:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытянуть итоговое значение по месяцам из сложной сводной таб (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!