Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Умножение по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Умножение по условию (Формулы/Formulas)
Умножение по условию
evgeni1990 Дата: Четверг, 04.04.2019, 14:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго дня!
Прошу подсказать по следующей задаче.
Имеется таблица, данные в которой должны умножаться на процент по условию, и дальше прибавлять следующие значение.
Свой вариант в примере указал, возможно ли упростить формулу используя массивы.
К сообщению приложен файл: 4844124.xlsx(9.8 Kb)


Сообщение отредактировал evgeni1990 - Четверг, 04.04.2019, 14:28
 
Ответить
СообщениеДоброго дня!
Прошу подсказать по следующей задаче.
Имеется таблица, данные в которой должны умножаться на процент по условию, и дальше прибавлять следующие значение.
Свой вариант в примере указал, возможно ли упростить формулу используя массивы.

Автор - evgeni1990
Дата добавления - 04.04.2019 в 14:24
китин Дата: Четверг, 04.04.2019, 14:31 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5598
Репутация: 891 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а так не прокатит?
Код
=СУММПРОИЗВ($C12:$F12;ТРАНСП($C$4:$C$7))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа так не прокатит?
Код
=СУММПРОИЗВ($C12:$F12;ТРАНСП($C$4:$C$7))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 04.04.2019 в 14:31
_Boroda_ Дата: Четверг, 04.04.2019, 14:33 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15218
Репутация: 5981 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(C12:F12;ТРАНСП(C$4:C$7))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Опередил :)
Тогда еще
Код
=СУММ(C12:F12*ТРАНСП(C$4:C$7))

И немассивная
Код
=МУМНОЖ(--C12:F12;C$4:C$7)
К сообщению приложен файл: 4844124_1.xlsx(10.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(C12:F12;ТРАНСП(C$4:C$7))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Опередил :)
Тогда еще
Код
=СУММ(C12:F12*ТРАНСП(C$4:C$7))

И немассивная
Код
=МУМНОЖ(--C12:F12;C$4:C$7)

Автор - _Boroda_
Дата добавления - 04.04.2019 в 14:33
evgeni1990 Дата: Четверг, 04.04.2019, 15:25 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, все варианты подходят.
 
Ответить
СообщениеСпасибо, все варианты подходят.

Автор - evgeni1990
Дата добавления - 04.04.2019 в 15:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Умножение по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!