Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление не меняющихся значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление не меняющихся значений (Формулы/Formulas)
Удаление не меняющихся значений
Ed-ti Дата: Суббота, 13.04.2019, 16:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Подскажите пожалуйста каким образом можно избавиться от значений которые не изменяются (удаление дубликатов не подходит). Вкратце опишу суть задачи - есть последовательность из нескольких тысяч значений. Значения могут меняться, а могут не меняться на протяжении какого-то времени (пример: 70;71;71;71;72;71;70;70;70;71.......,нужно получить такую последовательность - 70;71;72;71;70;71.......) Более развёрнутый пример в приложенном файле.
К сообщению приложен файл: 0048924.xlsx(26.1 Kb)
 
Ответить
СообщениеДобрый день! Подскажите пожалуйста каким образом можно избавиться от значений которые не изменяются (удаление дубликатов не подходит). Вкратце опишу суть задачи - есть последовательность из нескольких тысяч значений. Значения могут меняться, а могут не меняться на протяжении какого-то времени (пример: 70;71;71;71;72;71;70;70;70;71.......,нужно получить такую последовательность - 70;71;72;71;70;71.......) Более развёрнутый пример в приложенном файле.

Автор - Ed-ti
Дата добавления - 13.04.2019 в 16:27
Pelena Дата: Суббота, 13.04.2019, 16:43 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13883
Репутация: 3044 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ИНДЕКС($C$2:$C$269;НАИМЕНЬШИЙ(ЕСЛИ($C$2:$C$269<>$C$3:$C$270;СТРОКА($C$2:$C$269)-1);СТРОКА(J1)))

Если на больших объёмах будет тормозить, то можно полегче с доп. столбцом (вариант в файле)
К сообщению приложен файл: 6429735.xlsx(31.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ИНДЕКС($C$2:$C$269;НАИМЕНЬШИЙ(ЕСЛИ($C$2:$C$269<>$C$3:$C$270;СТРОКА($C$2:$C$269)-1);СТРОКА(J1)))

Если на больших объёмах будет тормозить, то можно полегче с доп. столбцом (вариант в файле)

Автор - Pelena
Дата добавления - 13.04.2019 в 16:43
_Boroda_ Дата: Суббота, 13.04.2019, 16:50 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14916
Репутация: 5900 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно Условным форматированием с последующим фильтром. Или формулой рядом
Код
=C1<>C2

Можно формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(E$1:E$999;СТРОКА()));"")
с допстолбцом
Код
=ЕСЛИ(C1<>C2;СТРОКА())

Можно сразу формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(C$1:C$998<>C$2:C$999;СТРОКА($1:$998));СТРОКА()));"")

Зависит от того, сколько записей в первоначальном диапазоне и статичен ли он или значения добавляются
К сообщению приложен файл: 0048924_1.xlsx(33.4 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно Условным форматированием с последующим фильтром. Или формулой рядом
Код
=C1<>C2

Можно формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(E$1:E$999;СТРОКА()));"")
с допстолбцом
Код
=ЕСЛИ(C1<>C2;СТРОКА())

Можно сразу формулой массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(C$1:C$998<>C$2:C$999;СТРОКА($1:$998));СТРОКА()));"")

Зависит от того, сколько записей в первоначальном диапазоне и статичен ли он или значения добавляются

Автор - _Boroda_
Дата добавления - 13.04.2019 в 16:50
Ed-ti Дата: Суббота, 13.04.2019, 17:26 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное спасибо за помощь!!!
 
Ответить
СообщениеОгромное спасибо за помощь!!!

Автор - Ed-ti
Дата добавления - 13.04.2019 в 17:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление не меняющихся значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!