Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести нижнюю ячейку, если в сосед. по строке ячейке чис >0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести нижнюю ячейку, если в сосед. по строке ячейке чис >0 (Формулы/Formulas)
Вывести нижнюю ячейку, если в сосед. по строке ячейке чис >0
stalber Дата: Понедельник, 29.04.2019, 14:33 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день, подскажите пожалуйста 2 формулы.

Первая задача:
Если в строке, а именно в нижней ячейке D число больше 0, то вывести из этой строки ячейку B самую нижнюю.
Есть такая формула (справа в G4 в эксель файле) но она не подходит, так как если в нижней ячейке D есть 0, то он всё равно выведет ячейку B
То есть, если бы в 37 и 38 строке в столбце D были 0, то мне нужно было бы увидеть ячейку B35, так как в D36 D37 D38 стоят 0

Вторая задача:
Если в нижней ячейке D число больше 0, то выводим в ячейке G9 число 0.
Если например у нас в ячейках D36 D37 D38 стоят 0, то необходимо B38 минус B35, итого 38 - 35 = 3 (в ячейке G9 будет число 3)
К сообщению приложен файл: vopros_29042019.xlsx(9.9 Kb)
 
Ответить
СообщениеДобрый день, подскажите пожалуйста 2 формулы.

Первая задача:
Если в строке, а именно в нижней ячейке D число больше 0, то вывести из этой строки ячейку B самую нижнюю.
Есть такая формула (справа в G4 в эксель файле) но она не подходит, так как если в нижней ячейке D есть 0, то он всё равно выведет ячейку B
То есть, если бы в 37 и 38 строке в столбце D были 0, то мне нужно было бы увидеть ячейку B35, так как в D36 D37 D38 стоят 0

Вторая задача:
Если в нижней ячейке D число больше 0, то выводим в ячейке G9 число 0.
Если например у нас в ячейках D36 D37 D38 стоят 0, то необходимо B38 минус B35, итого 38 - 35 = 3 (в ячейке G9 будет число 3)

Автор - stalber
Дата добавления - 29.04.2019 в 14:33
sboy Дата: Понедельник, 29.04.2019, 14:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2498
Репутация: 699 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Есть такая формула

В ней диапазон проверки >0 стоит для столбца В, а Вам надо D
для второй
Код
=ИНДЕКС(B2:B999;СЧЁТЗ(B2:B999))-G6
К сообщению приложен файл: 2980662.xlsx(10.4 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Есть такая формула

В ней диапазон проверки >0 стоит для столбца В, а Вам надо D
для второй
Код
=ИНДЕКС(B2:B999;СЧЁТЗ(B2:B999))-G6

Автор - sboy
Дата добавления - 29.04.2019 в 14:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести нижнюю ячейку, если в сосед. по строке ячейке чис >0 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!