Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечь число из ячейки с текстом и вставить в другую ячейку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь число из ячейки с текстом и вставить в другую ячейку (Формулы/Formulas)
Извлечь число из ячейки с текстом и вставить в другую ячейку
abche Дата: Среда, 08.05.2019, 11:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Привет, ГУРУ Excel!!!
Необходимо извлечь числа из ячеек R6C3-R66C2 и вставить их в соответствующие ячейки R6C5-R66C5. Если числа нет - вставить "0". (Вкладка "раздел 3")
Пытался вставить аналогичную формулу из похожей темы, не получается..
К сообщению приложен файл: __20.03.18-_3.xls(59.5 Kb)
 
Ответить
СообщениеПривет, ГУРУ Excel!!!
Необходимо извлечь числа из ячеек R6C3-R66C2 и вставить их в соответствующие ячейки R6C5-R66C5. Если числа нет - вставить "0". (Вкладка "раздел 3")
Пытался вставить аналогичную формулу из похожей темы, не получается..

Автор - abche
Дата добавления - 08.05.2019 в 11:05
Che79 Дата: Среда, 08.05.2019, 11:13 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
abche, здравствуйте. Почитайте, посмотрите тут


Делай нормально и будет нормально!
 
Ответить
Сообщениеabche, здравствуйте. Почитайте, посмотрите тут

Автор - Che79
Дата добавления - 08.05.2019 в 11:13
Pelena Дата: Среда, 08.05.2019, 11:26 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14329
Репутация: 3132 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
abche, если немного подкорректировать Вашу формулу
Код
=1*ПСТР(C6;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(1*ПСТР(C6;СТРОКА($1:$500);1));0);СЧЁТ(1*ПСТР(C6;СТРОКА($1:$500);1)))

вводить как формулу массива

UPD. Забыла про 0, если нет числа
Код
=ЕСЛИОШИБКА(1*ПСТР(C6;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(1*ПСТР(C6;СТРОКА($1:$500);1));0);СЧЁТ(1*ПСТР(C6;СТРОКА($1:$500);1)));0)
К сообщению приложен файл: _20.03.18-3.xls(66.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеabche, если немного подкорректировать Вашу формулу
Код
=1*ПСТР(C6;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(1*ПСТР(C6;СТРОКА($1:$500);1));0);СЧЁТ(1*ПСТР(C6;СТРОКА($1:$500);1)))

вводить как формулу массива

UPD. Забыла про 0, если нет числа
Код
=ЕСЛИОШИБКА(1*ПСТР(C6;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(1*ПСТР(C6;СТРОКА($1:$500);1));0);СЧЁТ(1*ПСТР(C6;СТРОКА($1:$500);1)));0)

Автор - Pelena
Дата добавления - 08.05.2019 в 11:26
abche Дата: Среда, 08.05.2019, 12:35 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, первая формула работает, вторая - нет. Ввожу как формулу массива.
 
Ответить
СообщениеPelena, первая формула работает, вторая - нет. Ввожу как формулу массива.

Автор - abche
Дата добавления - 08.05.2019 в 12:35
Che79 Дата: Среда, 08.05.2019, 12:40 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
abche, вариант по ссылке из сообщения #2
Код
=--ЕСЛИОШИБКА(RegExpExtract(C6;$E$5);)
Макросы должны быть разрешены
К сообщению приложен файл: _20.03.18-3_.xls(73.0 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеabche, вариант по ссылке из сообщения #2
Код
=--ЕСЛИОШИБКА(RegExpExtract(C6;$E$5);)
Макросы должны быть разрешены

Автор - Che79
Дата добавления - 08.05.2019 в 12:40
Nic70y Дата: Среда, 08.05.2019, 12:47 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5527
Репутация: 1203 ±
Замечаний: 0% ±

ru13;10;03
под данный пример
Код
=ЕСЛИОШИБКА(--ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(C6;ПОИСК(" п.м.";C6)-1);" ";"              ");15);)
К сообщению приложен файл: 1095094.xls(61.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениепод данный пример
Код
=ЕСЛИОШИБКА(--ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(C6;ПОИСК(" п.м.";C6)-1);" ";"              ");15);)

Автор - Nic70y
Дата добавления - 08.05.2019 в 12:47
abche Дата: Среда, 08.05.2019, 12:56 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, Идеально работает!
Благодарю!!!
 
Ответить
СообщениеNic70y, Идеально работает!
Благодарю!!!

Автор - abche
Дата добавления - 08.05.2019 в 12:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь число из ячейки с текстом и вставить в другую ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!