Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Название листа подтянуть формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Название листа подтянуть формулой (Формулы/Formulas)
Название листа подтянуть формулой
Ярик Дата: Среда, 08.05.2019, 22:34 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 128
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Подскажите пожалуйста как получить ссылку на лист формулой
У меня есть выпадающий список "С3"(название листов и выпадающий список одинаковые), мне нужно чтобы при выборе фрукта из выпадающего списка автоматом подтягивались данные из листа под таким же наименованием)
например выбраны "бананы" данные должны браться из листа "бананы"
помогите пожалуйста
К сообщению приложен файл: 0636281.xlsb(12.1 Kb)


753123
 
Ответить
СообщениеПодскажите пожалуйста как получить ссылку на лист формулой
У меня есть выпадающий список "С3"(название листов и выпадающий список одинаковые), мне нужно чтобы при выборе фрукта из выпадающего списка автоматом подтягивались данные из листа под таким же наименованием)
например выбраны "бананы" данные должны браться из листа "бананы"
помогите пожалуйста

Автор - Ярик
Дата добавления - 08.05.2019 в 22:34
Che79 Дата: Среда, 08.05.2019, 23:03 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
И Вам здравствуйте. Не совсем понятно, что нужно, т.к. в примере данные только на листе "Мандарины"... Может , так?
Код
=ДВССЫЛ("'"&C3&"'!B2")


Делай нормально и будет нормально!
 
Ответить
СообщениеИ Вам здравствуйте. Не совсем понятно, что нужно, т.к. в примере данные только на листе "Мандарины"... Может , так?
Код
=ДВССЫЛ("'"&C3&"'!B2")

Автор - Che79
Дата добавления - 08.05.2019 в 23:03
bmv98rus Дата: Среда, 08.05.2019, 23:08 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 426 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=INDIRECT("'"&C3&"'!B2")

Вот только не Название листа подтянуть формулой , а использовать в ссылке имя листа из ячейки.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=INDIRECT("'"&C3&"'!B2")

Вот только не Название листа подтянуть формулой , а использовать в ссылке имя листа из ячейки.

Автор - bmv98rus
Дата добавления - 08.05.2019 в 23:08
Ярик Дата: Среда, 08.05.2019, 23:43 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 128
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, bmv98rus, спасибо за помощь, но что-то не так посмотрите файл "лист2" формулы с функцией ДВССЫЛ залиты жёлтым цветом но почему то не работает, в ячейках серым цветом формула работает но без ссылки на лист в чем может быть причина?
К сообщению приложен файл: 4243274.xlsb(13.7 Kb)


753123
 
Ответить
СообщениеChe79, bmv98rus, спасибо за помощь, но что-то не так посмотрите файл "лист2" формулы с функцией ДВССЫЛ залиты жёлтым цветом но почему то не работает, в ячейках серым цветом формула работает но без ссылки на лист в чем может быть причина?

Автор - Ярик
Дата добавления - 08.05.2019 в 23:43
Che79 Дата: Среда, 08.05.2019, 23:52 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
Ярик, в формулу особенно не вникал. Так хотите?
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&$D$6&"'!$B$2:$B$8");АГРЕГАТ(15;6;(СТРОКА(ДВССЫЛ("'"&$D$6&"'!$B$2:$B$8"))-1)/(ДВССЫЛ("'"&$D$6&"'!$a$2:$a$8")=$F$6);СТРОКА(A1)));"")
К сообщению приложен файл: 4243274_1.xlsb(13.7 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЯрик, в формулу особенно не вникал. Так хотите?
Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&$D$6&"'!$B$2:$B$8");АГРЕГАТ(15;6;(СТРОКА(ДВССЫЛ("'"&$D$6&"'!$B$2:$B$8"))-1)/(ДВССЫЛ("'"&$D$6&"'!$a$2:$a$8")=$F$6);СТРОКА(A1)));"")

Автор - Che79
Дата добавления - 08.05.2019 в 23:52
Ярик Дата: Четверг, 09.05.2019, 00:00 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 128
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, спасибо за помощь еще раз


753123
 
Ответить
СообщениеChe79, спасибо за помощь еще раз

Автор - Ярик
Дата добавления - 09.05.2019 в 00:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Название листа подтянуть формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!