Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма наибольших 5 ячеек в строке расположенных произвольно - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма наибольших 5 ячеек в строке расположенных произвольно (Формулы/Formulas)
Сумма наибольших 5 ячеек в строке расположенных произвольно
K700 Дата: Воскресенье, 12.05.2019, 16:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Сумма наибольших 5 ячеек в строке расположенных произвольно, пример ячейки А2, А6, А9, А17, А18, А21, А33, то есть не массив
 
Ответить
СообщениеСумма наибольших 5 ячеек в строке расположенных произвольно, пример ячейки А2, А6, А9, А17, А18, А21, А33, то есть не массив

Автор - K700
Дата добавления - 12.05.2019 в 16:37
bmv98rus Дата: Воскресенье, 12.05.2019, 17:01 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2165
Репутация: 368 ±
Замечаний: 20% ±

Excel 2013/2016
K700, Исходя из Вашего названия и описания сумма наибольших 5 ячеек равна сумме а9, а10, а15, а17, а21 . Про строку я молчу.
Почему не массив? Очень даже массив . А если будут значения 9,8,8,7,7,7,6,5. то что суммировать?


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеK700, Исходя из Вашего названия и описания сумма наибольших 5 ячеек равна сумме а9, а10, а15, а17, а21 . Про строку я молчу.
Почему не массив? Очень даже массив . А если будут значения 9,8,8,7,7,7,6,5. то что суммировать?

Автор - bmv98rus
Дата добавления - 12.05.2019 в 17:01
K700 Дата: Воскресенье, 12.05.2019, 17:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Исходя из Вашего названия и описания сумма наибольших 5 ячеек равна сумме а9, а10, а15, а17, а21 . Про строку я молчу.
Почему не массив? Очень даже массив . А если будут значения 9,8,8,7,7,7,6,5. то что суммировать?


Попробовал сделать так
Код
=СУММ(НАИБОЛЬШИЙ(H6:K6:N6:Q6:T6:W6:Z6:AC6:AF6:AI6;{1;2;3;4;5}))
вроде считает верно

А если будут значения 9,8,8,7,7,7,6,5. теоретически нужно что бы считало 9+8+8+7+7 и не важно какие 2-е семёрки из 3-х будут посчитаны
 
Ответить
Сообщение
Исходя из Вашего названия и описания сумма наибольших 5 ячеек равна сумме а9, а10, а15, а17, а21 . Про строку я молчу.
Почему не массив? Очень даже массив . А если будут значения 9,8,8,7,7,7,6,5. то что суммировать?


Попробовал сделать так
Код
=СУММ(НАИБОЛЬШИЙ(H6:K6:N6:Q6:T6:W6:Z6:AC6:AF6:AI6;{1;2;3;4;5}))
вроде считает верно

А если будут значения 9,8,8,7,7,7,6,5. теоретически нужно что бы считало 9+8+8+7+7 и не важно какие 2-е семёрки из 3-х будут посчитаны

Автор - K700
Дата добавления - 12.05.2019 в 17:06
bmv98rus Дата: Воскресенье, 12.05.2019, 17:45 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 2165
Репутация: 368 ±
Замечаний: 20% ±

Excel 2013/2016
вроде считает верно
ошибаетесь или вам повезло и в регионах H6:K6;N6:Q6;T6:W6;Z6:AC6;AF6:AI6 кроме как в крайних ячейках нет данных.

Код
=SUM(IFERROR(LARGE(INDEX(6:6;N(INDEX(ROW(A1:A10)*6+2;)));{1;2;3;4;5});))


формулу свою , пусть даже неверную, оформите корректно.


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Воскресенье, 12.05.2019, 17:46
 
Ответить
Сообщение
вроде считает верно
ошибаетесь или вам повезло и в регионах H6:K6;N6:Q6;T6:W6;Z6:AC6;AF6:AI6 кроме как в крайних ячейках нет данных.

Код
=SUM(IFERROR(LARGE(INDEX(6:6;N(INDEX(ROW(A1:A10)*6+2;)));{1;2;3;4;5});))


формулу свою , пусть даже неверную, оформите корректно.

Автор - bmv98rus
Дата добавления - 12.05.2019 в 17:45
MCH Дата: Вторник, 14.05.2019, 07:55 | Сообщение № 5
Группа: Админы
Ранг: Старожил
Сообщений: 1906
Репутация: 713 ±
Замечаний: ±

Код
=СУММ(НАИБОЛЬШИЙ(ВЫБОР({1;2;3;4;5;6;7};A2;A6;A9;A17;A18;A21;A33);{1;2;3;4;5}))
 
Ответить
Сообщение
Код
=СУММ(НАИБОЛЬШИЙ(ВЫБОР({1;2;3;4;5;6;7};A2;A6;A9;A17;A18;A21;A33);{1;2;3;4;5}))

Автор - MCH
Дата добавления - 14.05.2019 в 07:55
AlexM Дата: Вторник, 14.05.2019, 08:14 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3835
Репутация: 967 ±
Замечаний: 0% ±

Excel 2003
[offtop]Из-за отсутствия файла в теме, она бесполезна для начинающих Excelистов.
Хоть бы кто-нибудь приложил файл, тем самым исправил нарушение правил форума ТС



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение[offtop]Из-за отсутствия файла в теме, она бесполезна для начинающих Excelистов.
Хоть бы кто-нибудь приложил файл, тем самым исправил нарушение правил форума ТС

Автор - AlexM
Дата добавления - 14.05.2019 в 08:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма наибольших 5 ячеек в строке расположенных произвольно (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!