Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Текст в функции - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Текст в функции (Формулы/Formulas)
Текст в функции
AleksFin Дата: Среда, 15.05.2019, 15:50 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 89
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день

Пытаюсь функцией ВПР найти и вставить текст, но почему то выдает неправильное значение текста, подставляет не тот текст который ищу.

Посмотрите пожалуйста! Где я ошибся в формуле?

На листе 1, в ячейке E3 стоит формула ВПР. По ней она обращается на лист 2 в колонку E, и подставить соответствующее фамилии подразделение.
К сообщению приложен файл: 888.xlsx(9.6 Kb)
 
Ответить
СообщениеДобрый день

Пытаюсь функцией ВПР найти и вставить текст, но почему то выдает неправильное значение текста, подставляет не тот текст который ищу.

Посмотрите пожалуйста! Где я ошибся в формуле?

На листе 1, в ячейке E3 стоит формула ВПР. По ней она обращается на лист 2 в колонку E, и подставить соответствующее фамилии подразделение.

Автор - AleksFin
Дата добавления - 15.05.2019 в 15:50
_Boroda_ Дата: Среда, 15.05.2019, 15:53 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15578
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ВПР(C3;Лист2!D$3:E$5;2;0)

Вы же ищете фамилию, они у Вас в столбце D, а таблица поиска в ВПР почему-то начинается с С
И не забывайте про закрепление диапазонов (это значки $), когда Вы протянете свою формулу вниз, у Вас цифры в Лист2!C3:E5 поползут (станет не 3-5, а 4-6, потом 5-8). Нужно закрепить их долларом
К сообщению приложен файл: 888_1.xlsx(9.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ВПР(C3;Лист2!D$3:E$5;2;0)

Вы же ищете фамилию, они у Вас в столбце D, а таблица поиска в ВПР почему-то начинается с С
И не забывайте про закрепление диапазонов (это значки $), когда Вы протянете свою формулу вниз, у Вас цифры в Лист2!C3:E5 поползут (станет не 3-5, а 4-6, потом 5-8). Нужно закрепить их долларом

Автор - _Boroda_
Дата добавления - 15.05.2019 в 15:53
AleksFin Дата: Среда, 15.05.2019, 15:56 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 89
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, блин, часа два мучился, поседеть успел уже. Спасибо Вам большое.
 
Ответить
Сообщение_Boroda_, блин, часа два мучился, поседеть успел уже. Спасибо Вам большое.

Автор - AleksFin
Дата добавления - 15.05.2019 в 15:56
krosav4ig Дата: Среда, 15.05.2019, 16:01 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2148
Репутация: 893 ±
Замечаний: 0% ±

Excel 2007,2010,2013
немного изврата...
Код
=ВПР(C3;ИНДЕКС(Лист2!$C$3:$E$5;Ч(ИНДЕКС(--Лист2!$B$3:$B$5;0));Ч(ИНДЕКС({2;1;3};0)));3;0)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениенемного изврата...
Код
=ВПР(C3;ИНДЕКС(Лист2!$C$3:$E$5;Ч(ИНДЕКС(--Лист2!$B$3:$B$5;0));Ч(ИНДЕКС({2;1;3};0)));3;0)

Автор - krosav4ig
Дата добавления - 15.05.2019 в 16:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Текст в функции (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!