Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить значение массива, если X и Y попадают в диапазон - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить значение массива, если X и Y попадают в диапазон (Формулы/Formulas)
Определить значение массива, если X и Y попадают в диапазон
Gesper Дата: Среда, 29.05.2019, 13:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Помогите пожалуйста с формулой. Задача такая:

Нужно определить значение G если X и Y попадают в диапазоны.
Х=115,5 попадает в диапазон от 111 до 120
Y=231,6 попадает в диапазон от 231 до 250
G= пересечение X и Y т.е должно быть 0,74

Как прописать поиск G? Может быть определять номер строки если выполняется условие с Y и номер столбца если с Х?

см. вложение
К сообщению приложен файл: 7402228.xlsx(9.4 Kb)


Сообщение отредактировал Gesper - Среда, 29.05.2019, 13:33
 
Ответить
СообщениеДобрый день!

Помогите пожалуйста с формулой. Задача такая:

Нужно определить значение G если X и Y попадают в диапазоны.
Х=115,5 попадает в диапазон от 111 до 120
Y=231,6 попадает в диапазон от 231 до 250
G= пересечение X и Y т.е должно быть 0,74

Как прописать поиск G? Может быть определять номер строки если выполняется условие с Y и номер столбца если с Х?

см. вложение

Автор - Gesper
Дата добавления - 29.05.2019 в 13:30
_Boroda_ Дата: Среда, 29.05.2019, 13:31 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, конкретнее обозначьте проблему

И куда попадает Х=110,5?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, конкретнее обозначьте проблему

И куда попадает Х=110,5?

Автор - _Boroda_
Дата добавления - 29.05.2019 в 13:31
Gesper Дата: Среда, 29.05.2019, 13:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, конкретнее обозначьте проблему

И куда попадает Х=110,5?


Название темы исправил.
Х=110,5 попадает в диапазон от 101 до 110 (в файле выделил желтым цветом)
Если проще сделать что 110,5 попадает в диапазон уже 111, то не критично.


Сообщение отредактировал Gesper - Среда, 29.05.2019, 13:39
 
Ответить
Сообщение
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума, конкретнее обозначьте проблему

И куда попадает Х=110,5?


Название темы исправил.
Х=110,5 попадает в диапазон от 101 до 110 (в файле выделил желтым цветом)
Если проще сделать что 110,5 попадает в диапазон уже 111, то не критично.

Автор - Gesper
Дата добавления - 29.05.2019 в 13:35
bmv98rus Дата: Среда, 29.05.2019, 13:40 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2734
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
И куда попадает Х=110,5?

на линию :)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
И куда попадает Х=110,5?

на линию :)

Автор - bmv98rus
Дата добавления - 29.05.2019 в 13:40
_Boroda_ Дата: Среда, 29.05.2019, 13:40 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6079 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Это второй вариант
Код
=ИНДЕКС(D4:F9;1-СУММПРОИЗВ(-(C13>=C4:C9));1-СУММПРОИЗВ(-(B13>=D3:F3)))

Это первый
Код
=ИНДЕКС(D4:F9;ПОИСКПОЗ(C13;B4:B9);ПОИСКПОЗ(B13;D2:F2))
К сообщению приложен файл: 7402228_1.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Это второй вариант
Код
=ИНДЕКС(D4:F9;1-СУММПРОИЗВ(-(C13>=C4:C9));1-СУММПРОИЗВ(-(B13>=D3:F3)))

Это первый
Код
=ИНДЕКС(D4:F9;ПОИСКПОЗ(C13;B4:B9);ПОИСКПОЗ(B13;D2:F2))

Автор - _Boroda_
Дата добавления - 29.05.2019 в 13:40
bmv98rus Дата: Среда, 29.05.2019, 13:41 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2734
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=INDEX(D4:F9;MATCH(C13;B4:B9);MATCH(B13;D2:F2))


[p.s.]Ох уж эти Бородаторы, правят свои посты и следов не оставляют :D [/p.s.]


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 29.05.2019, 15:20
 
Ответить
Сообщение
Код
=INDEX(D4:F9;MATCH(C13;B4:B9);MATCH(B13;D2:F2))


[p.s.]Ох уж эти Бородаторы, правят свои посты и следов не оставляют :D [/p.s.]

Автор - bmv98rus
Дата добавления - 29.05.2019 в 13:41
Gesper Дата: Среда, 29.05.2019, 13:53 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое! Все рассчитывает правильно!
 
Ответить
СообщениеСпасибо большое! Все рассчитывает правильно!

Автор - Gesper
Дата добавления - 29.05.2019 в 13:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить значение массива, если X и Y попадают в диапазон (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!