Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти позицию с минимальным количеством за промежуток времен - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти позицию с минимальным количеством за промежуток времен (Формулы/Formulas)
Найти позицию с минимальным количеством за промежуток времен
Frozen1 Дата: Воскресенье, 02.06.2019, 18:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!

Необходимо найти номер магазина, у которого в период с 01.03.2015 по 30.06.2016 было минимальное количество телевизоров и четное количество холодильников.
У меня решение получается при переносе нужного промежутка времени на отдельный лист и определении номера магазина вручную.
Подскажите, пожалуйста, с помощью какой формулы можно избежать данных действий?
К сообщению приложен файл: 6299774.xlsx(65.8 Kb)
 
Ответить
СообщениеДобрый день!

Необходимо найти номер магазина, у которого в период с 01.03.2015 по 30.06.2016 было минимальное количество телевизоров и четное количество холодильников.
У меня решение получается при переносе нужного промежутка времени на отдельный лист и определении номера магазина вручную.
Подскажите, пожалуйста, с помощью какой формулы можно избежать данных действий?

Автор - Frozen1
Дата добавления - 02.06.2019 в 18:06
bmv98rus Дата: Воскресенье, 02.06.2019, 18:55 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеКРОСС

Автор - bmv98rus
Дата добавления - 02.06.2019 в 18:55
Pelena Дата: Воскресенье, 02.06.2019, 19:12 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D2:D1122;A2:A1122;">=01.03.2015";A2:A1122;"<=30.06.2016";B2:B1122;СТРОКА(1:15)));СУММЕСЛИМН(C2:C1122;A2:A1122;">=01.03.2015";A2:A1122;"<=30.06.2016";B2:B1122;СТРОКА(1:15))));СУММЕСЛИМН(C2:C1122;A2:A1122;">=01.03.2015";A2:A1122;"<=30.06.2016";B2:B1122;СТРОКА(1:15));0)
К сообщению приложен файл: 0008358.xlsx(62.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D2:D1122;A2:A1122;">=01.03.2015";A2:A1122;"<=30.06.2016";B2:B1122;СТРОКА(1:15)));СУММЕСЛИМН(C2:C1122;A2:A1122;">=01.03.2015";A2:A1122;"<=30.06.2016";B2:B1122;СТРОКА(1:15))));СУММЕСЛИМН(C2:C1122;A2:A1122;">=01.03.2015";A2:A1122;"<=30.06.2016";B2:B1122;СТРОКА(1:15));0)

Автор - Pelena
Дата добавления - 02.06.2019 в 19:12
_Boroda_ Дата: Воскресенье, 02.06.2019, 19:24 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня такой вариант
Код
=ИНДЕКС(B2:B1122;ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">="&G1;A:A;"<="&H1));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">="&G1;A:A;"<="&H1)));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">="&G1;A:A;"<="&H1);))

С датами в формуле
Код
=ИНДЕКС(B2:B1122;ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016")));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016");))
К сообщению приложен файл: 6299774_2.xlsx(67.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня такой вариант
Код
=ИНДЕКС(B2:B1122;ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">="&G1;A:A;"<="&H1));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">="&G1;A:A;"<="&H1)));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">="&G1;A:A;"<="&H1);))

С датами в формуле
Код
=ИНДЕКС(B2:B1122;ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016")));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016");))

Автор - _Boroda_
Дата добавления - 02.06.2019 в 19:24
bmv98rus Дата: Воскресенье, 02.06.2019, 19:39 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
_Boroda_, А если сумма совпадет, а четность не подойдет?


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение_Boroda_, А если сумма совпадет, а четность не подойдет?

Автор - bmv98rus
Дата добавления - 02.06.2019 в 19:39
_Boroda_ Дата: Воскресенье, 02.06.2019, 19:51 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Крайне маловероятный на таких числах вариант, но на всякий случай да
Код
=ИНДЕКС(B2:B1122;ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016")));ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));))


_Boroda_, А если

А почему ты только у меня "если" спрашиваешь? разве больше нигде их нет?
Ну там типа больше 15 магазинов с текстовым обозначением?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Воскресенье, 02.06.2019, 19:57
 
Ответить
СообщениеКрайне маловероятный на таких числах вариант, но на всякий случай да
Код
=ИНДЕКС(B2:B1122;ПОИСКПОЗ(МИН(ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016")));ЕСЛИ(ЕЧЁТН(СУММЕСЛИМН(D:D;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));СУММЕСЛИМН(C:C;B:B;B2:B1122;A:A;">=01.03.2015";A:A;"<=30.06.2016"));))


_Boroda_, А если

А почему ты только у меня "если" спрашиваешь? разве больше нигде их нет?
Ну там типа больше 15 магазинов с текстовым обозначением?

Автор - _Boroda_
Дата добавления - 02.06.2019 в 19:51
bmv98rus Дата: Воскресенье, 02.06.2019, 20:57 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 2275
Репутация: 399 ±
Замечаний: 20% ±

Excel 2013/2016
А почему ты только у меня

исключительно только по этому :-) . Я там диапазон ограничил спецом, помня о замедлении SUMIFS


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
А почему ты только у меня

исключительно только по этому :-) . Я там диапазон ограничил спецом, помня о замедлении SUMIFS

Автор - bmv98rus
Дата добавления - 02.06.2019 в 20:57
Frozen1 Дата: Воскресенье, 02.06.2019, 21:19 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем большое спасибо!
 
Ответить
СообщениеВсем большое спасибо!

Автор - Frozen1
Дата добавления - 02.06.2019 в 21:19
_Boroda_ Дата: Воскресенье, 02.06.2019, 21:22 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
исключительно только по этому

Возможно какая-то логика в этом и есть, но для меня она ускользает. Ну и ладно, переживу как-нибудь


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
исключительно только по этому

Возможно какая-то логика в этом и есть, но для меня она ускользает. Ну и ладно, переживу как-нибудь

Автор - _Boroda_
Дата добавления - 02.06.2019 в 21:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти позицию с минимальным количеством за промежуток времен (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!