Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/аналог COUNTIF при сравнении значений из разных столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » аналог COUNTIF при сравнении значений из разных столбцов (Формулы/Formulas)
аналог COUNTIF при сравнении значений из разных столбцов
julia31 Дата: Пятница, 07.06.2019, 12:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Помогите, пожалуйста, вспомнить название функции, которая позволяет задать сложное условие (не по одному столбцу).
Помню, что есть какой-то хитрый способ, нужно что-то типа [vba]
Код
COUNTIF(A1:A100,B1:B100<C1:C100)
[/vba]

* Формулу в теги VBA засунул я, судя по вопросу, нужно, чтобы англицкий вариант был
_Boroda_


Сообщение отредактировал _Boroda_ - Пятница, 07.06.2019, 12:56
 
Ответить
СообщениеЗдравствуйте. Помогите, пожалуйста, вспомнить название функции, которая позволяет задать сложное условие (не по одному столбцу).
Помню, что есть какой-то хитрый способ, нужно что-то типа [vba]
Код
COUNTIF(A1:A100,B1:B100<C1:C100)
[/vba]

* Формулу в теги VBA засунул я, судя по вопросу, нужно, чтобы англицкий вариант был
_Boroda_

Автор - julia31
Дата добавления - 07.06.2019 в 12:48
_Boroda_ Дата: Пятница, 07.06.2019, 12:53 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Это?
Код
=СЧЁТЕСЛИМН(E27:E28;E28;F27:F28;F28)(

CountIfs


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЭто?
Код
=СЧЁТЕСЛИМН(E27:E28;E28;F27:F28;F28)(

CountIfs

Автор - _Boroda_
Дата добавления - 07.06.2019 в 12:53
julia31 Дата: Суббота, 08.06.2019, 17:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Нет, нужно именно сравнение значений в двух столбцах между собой. Фукции COUNTIFS, SUMIFS позволяют задать условие для каждого столбца по-отдельности. Но есть какая-то функция, в которой можно задать одно условие по данным из разных столбцов. Может у нее другое назначение, но с "хитростью" все получается (насколько помню, связанной с тем, что из выражения со значением TRUE можно получить числовое значение 1, если умножить выражение на 1 - тип преобразуется и получается 1)


Сообщение отредактировал julia31 - Суббота, 08.06.2019, 18:00
 
Ответить
СообщениеНет, нужно именно сравнение значений в двух столбцах между собой. Фукции COUNTIFS, SUMIFS позволяют задать условие для каждого столбца по-отдельности. Но есть какая-то функция, в которой можно задать одно условие по данным из разных столбцов. Может у нее другое назначение, но с "хитростью" все получается (насколько помню, связанной с тем, что из выражения со значением TRUE можно получить числовое значение 1, если умножить выражение на 1 - тип преобразуется и получается 1)

Автор - julia31
Дата добавления - 08.06.2019 в 17:46
Pelena Дата: Суббота, 08.06.2019, 18:05 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ(A1:A100*(B1:B100<C1:C100))

Если не угадала, приложите файл с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(A1:A100*(B1:B100<C1:C100))

Если не угадала, приложите файл с примером

Автор - Pelena
Дата добавления - 08.06.2019 в 18:05
julia31 Дата: Суббота, 08.06.2019, 19:24 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, да, спасибо!
 
Ответить
СообщениеPelena, да, спасибо!

Автор - julia31
Дата добавления - 08.06.2019 в 19:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » аналог COUNTIF при сравнении значений из разных столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!