Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сложить продолжительность телефонного разговора - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сложить продолжительность телефонного разговора (Формулы/Formulas)
Как сложить продолжительность телефонного разговора
Наумчик Дата: Понедельник, 10.06.2019, 22:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Подскажите, пожалуйста, как быстро сложить продолжительность телефонного разговора вот в таком формате?
1 мин, 27 сек
10 сек
6 мин, 35 сек
27 сек
18 мин, 48 сек
и т.д.

Строк очень много, желательно всю сумму результата вывести в одну строку


Сообщение отредактировал Наумчик - Вторник, 11.06.2019, 10:03
 
Ответить
СообщениеДобрый день. Подскажите, пожалуйста, как быстро сложить продолжительность телефонного разговора вот в таком формате?
1 мин, 27 сек
10 сек
6 мин, 35 сек
27 сек
18 мин, 48 сек
и т.д.

Строк очень много, желательно всю сумму результата вывести в одну строку

Автор - Наумчик
Дата добавления - 10.06.2019 в 22:03
bmv98rus Дата: Понедельник, 10.06.2019, 22:25 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Наумчик, А кроме как продолжительность, можно как то слогаемые обозвать в теме? Файл пример с всевозможными вариантами тоже не повредил бы. Могут ли быть часы например ….


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеНаумчик, А кроме как продолжительность, можно как то слогаемые обозвать в теме? Файл пример с всевозможными вариантами тоже не повредил бы. Могут ли быть часы например ….

Автор - bmv98rus
Дата добавления - 10.06.2019 в 22:25
Наумчик Дата: Вторник, 11.06.2019, 09:50 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus,
К сообщению приложен файл: 7760085.xlsx(9.9 Kb)
 
Ответить
Сообщениеbmv98rus,

Автор - Наумчик
Дата добавления - 11.06.2019 в 09:50
китин Дата: Вторник, 11.06.2019, 09:51 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5753
Репутация: 904 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Наумчик, назовите тему как то поконкретнее. как сложить продолжительность уж больно неинформативно
[moder]исправлено[/moder]


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеНаумчик, назовите тему как то поконкретнее. как сложить продолжительность уж больно неинформативно
[moder]исправлено[/moder]

Автор - китин
Дата добавления - 11.06.2019 в 09:51
китин Дата: Вторник, 11.06.2019, 10:26 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5753
Репутация: 904 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
дык что складывать? весь столбец В ?
ну ладно. как понял
Код
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("мин";B2:B135));"00:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;"мин,";":");"сек";"");" ";"");"00:00:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;"сек";"");" ";"")))

формула массива.
К сообщению приложен файл: 555_333.xlsx(12.2 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениедык что складывать? весь столбец В ?
ну ладно. как понял
Код
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("мин";B2:B135));"00:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;"мин,";":");"сек";"");" ";"");"00:00:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;"сек";"");" ";"")))

формула массива.

Автор - китин
Дата добавления - 11.06.2019 в 10:26
Nic70y Дата: Вторник, 11.06.2019, 10:27 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5527
Репутация: 1204 ±
Замечаний: 0% ±

ru13;10;03
.


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Вторник, 11.06.2019, 10:28
 
Ответить
Сообщение.

Автор - Nic70y
Дата добавления - 11.06.2019 в 10:27
Светлый Дата: Вторник, 11.06.2019, 11:28 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1207
Репутация: 310 ±
Замечаний: 0% ±

Excel 2010
У меня такой вариант получился:
Код
=СУММПРОИЗВ(--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;",";);"мин";":");"сек";",0")))
*Или для любых регионов:
Код
=СУММПРОИЗВ(--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;",";);"мин";":");"сек";ПСТР(1%;2;2))))
**Во второй формуле наврал. Исправил.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 11.06.2019, 11:53
 
Ответить
СообщениеУ меня такой вариант получился:
Код
=СУММПРОИЗВ(--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;",";);"мин";":");"сек";",0")))
*Или для любых регионов:
Код
=СУММПРОИЗВ(--("0:"&ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(B2:B135;",";);"мин";":");"сек";ПСТР(1%;2;2))))
**Во второй формуле наврал. Исправил.

Автор - Светлый
Дата добавления - 11.06.2019 в 11:28
bmv98rus Дата: Вторник, 11.06.2019, 11:52 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUM(IFERROR(--MID(" "&B2:B132;FIND({"м"\"с"};" "&B2:B132)-3;2);)/{1\60}/1440)

ну или не массивная
Код
=SUMPRODUCT(IFERROR(--MID(" "&B2:B132;FIND({"м"\"с"};" "&B2:B132)-3;2);)/{1\60}/1440)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Вторник, 11.06.2019, 12:17
 
Ответить
Сообщение
Код
=SUM(IFERROR(--MID(" "&B2:B132;FIND({"м"\"с"};" "&B2:B132)-3;2);)/{1\60}/1440)

ну или не массивная
Код
=SUMPRODUCT(IFERROR(--MID(" "&B2:B132;FIND({"м"\"с"};" "&B2:B132)-3;2);)/{1\60}/1440)

Автор - bmv98rus
Дата добавления - 11.06.2019 в 11:52
Светлый Дата: Вторник, 11.06.2019, 14:13 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1207
Репутация: 310 ±
Замечаний: 0% ±

Excel 2010
{1\60}...{"м"\"с"}
Непонятно. {1;60}...{"м";"с"} работает, но массивная.
И " "& можно заменить на 0&


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
{1\60}...{"м"\"с"}
Непонятно. {1;60}...{"м";"с"} работает, но массивная.
И " "& можно заменить на 0&

Автор - Светлый
Дата добавления - 11.06.2019 в 14:13
bmv98rus Дата: Вторник, 11.06.2019, 14:26 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Цитата Светлый, 11.06.2019 в 14:13, в сообщении № 9 ()
Непонятно. {1;60}...{"м";"с"} работает, но массивная.

Не понял. :(
Цитата Светлый, 11.06.2019 в 14:13, в сообщении № 9 ()
заменить на 0&

Понял yes


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Цитата Светлый, 11.06.2019 в 14:13, в сообщении № 9 ()
Непонятно. {1;60}...{"м";"с"} работает, но массивная.

Не понял. :(
Цитата Светлый, 11.06.2019 в 14:13, в сообщении № 9 ()
заменить на 0&

Понял yes

Автор - bmv98rus
Дата добавления - 11.06.2019 в 14:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сложить продолжительность телефонного разговора (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!