Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет суммы в зависимости от условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет суммы в зависимости от условия (Формулы/Formulas)
Подсчет суммы в зависимости от условия
AleksandrR Дата: Вторник, 11.06.2019, 10:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Суть вроде простая, но не могу построить формулу.
Есть таблица в таком виде - ссылка удалена администрацией форума: нарушение п. 5к Правил форума(прикрепил к сообщению скриншот).
Т.е. первая и третья строка - значение, вторая и четвертая - условие. Соотносятся первые две и 3-4 строки между собой.
Нужно подсчитать сумму чисел, в условиях которых ниже указано ТН, и сумму в условиях которых указано Р - по отдельности.
Грубо говоря - если в ячейке С2 - указано "ТН" - учитываем число в С1, если указано другое, то не учитываем число и не суммируем его.
К сообщению приложен файл: example.xls(6.5 Kb) · 8374445.jpg(16.9 Kb)
 
Ответить
СообщениеДобрый день!
Суть вроде простая, но не могу построить формулу.
Есть таблица в таком виде - ссылка удалена администрацией форума: нарушение п. 5к Правил форума(прикрепил к сообщению скриншот).
Т.е. первая и третья строка - значение, вторая и четвертая - условие. Соотносятся первые две и 3-4 строки между собой.
Нужно подсчитать сумму чисел, в условиях которых ниже указано ТН, и сумму в условиях которых указано Р - по отдельности.
Грубо говоря - если в ячейке С2 - указано "ТН" - учитываем число в С1, если указано другое, то не учитываем число и не суммируем его.

Автор - AleksandrR
Дата добавления - 11.06.2019 в 10:06
китин Дата: Вторник, 11.06.2019, 10:38 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5596
Репутация: 891 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как понял. формула массива
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА($A$1:$P$1*($A$2:$P$2="ТН")*($A$1:$P$1<>"-");0))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак понял. формула массива
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА($A$1:$P$1*($A$2:$P$2="ТН")*($A$1:$P$1<>"-");0))

Автор - китин
Дата добавления - 11.06.2019 в 10:38
_Boroda_ Дата: Вторник, 11.06.2019, 10:44 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15195
Репутация: 5972 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Немассивный
Код
=СУММПРОИЗВ(Ч(+A1:P1)*(A2:P2="ТН"))
К сообщению приложен файл: example-2-1.xls(27.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Немассивный
Код
=СУММПРОИЗВ(Ч(+A1:P1)*(A2:P2="ТН"))

Автор - _Boroda_
Дата добавления - 11.06.2019 в 10:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет суммы в зависимости от условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!