Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка часового пояса по адресу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка часового пояса по адресу (Формулы/Formulas)
Подстановка часового пояса по адресу
Teem Дата: Среда, 12.06.2019, 13:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Форумчане, приветсвую!

поиск ничего не дал, поэтому прошу помощи в решении задачи.
Необходимо адресу сопоставить часовой пояс. В адресе указан или регион, или столица региона, или и то и другое.
Есть таблица соответствия столицы региона, названия региона и часового пояса.

Приммер во вложении
К сообщению приложен файл: 2592318.xlsx(14.5 Kb)
 
Ответить
СообщениеФорумчане, приветсвую!

поиск ничего не дал, поэтому прошу помощи в решении задачи.
Необходимо адресу сопоставить часовой пояс. В адресе указан или регион, или столица региона, или и то и другое.
Есть таблица соответствия столицы региона, названия региона и часового пояса.

Приммер во вложении

Автор - Teem
Дата добавления - 12.06.2019 в 13:04
AlexM Дата: Среда, 12.06.2019, 13:37 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4242
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
Код
=ПРОСМОТР(;-ПОИСК(Справочник!A$1:A$83;A2);Справочник!C$1:C$83)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ПРОСМОТР(;-ПОИСК(Справочник!A$1:A$83;A2);Справочник!C$1:C$83)

Автор - AlexM
Дата добавления - 12.06.2019 в 13:37
bmv98rus Дата: Среда, 12.06.2019, 13:58 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 3094
Репутация: 535 ±
Замечаний: 0% ±

Excel 2013/2016
AlexM, Search на Find лучше заменить, дабы с Томском и Омском проблем не было. Хотя возьмет последний конечно и будет +7. Наверно можно и не трогать


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 12.06.2019, 14:02
 
Ответить
СообщениеAlexM, Search на Find лучше заменить, дабы с Томском и Омском проблем не было. Хотя возьмет последний конечно и будет +7. Наверно можно и не трогать

Автор - bmv98rus
Дата добавления - 12.06.2019 в 13:58
Teem Дата: Среда, 12.06.2019, 14:20 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо за оперативность, но отрабатывает не идеально. С тверской областью не проходит.

Пример с ней прикладываю
К сообщению приложен файл: 2567795.xlsx(15.7 Kb)
 
Ответить
СообщениеСпасибо за оперативность, но отрабатывает не идеально. С тверской областью не проходит.

Пример с ней прикладываю

Автор - Teem
Дата добавления - 12.06.2019 в 14:20
Pelena Дата: Среда, 12.06.2019, 15:20 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16245
Репутация: 3519 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Попробуйте так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-НАЙТИ(Справочник!A$1:A$83;A2);Справочник!C$1:C$83);ПРОСМОТР(;-НАЙТИ(Справочник!B$1:B$83;A2);Справочник!C$1:C$83))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПопробуйте так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-НАЙТИ(Справочник!A$1:A$83;A2);Справочник!C$1:C$83);ПРОСМОТР(;-НАЙТИ(Справочник!B$1:B$83;A2);Справочник!C$1:C$83))

Автор - Pelena
Дата добавления - 12.06.2019 в 15:20
bmv98rus Дата: Среда, 12.06.2019, 15:33 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 3094
Репутация: 535 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=INDEX(Справочник!C:C;MIN(IF(ISNUMBER(FIND(Справочник!$A$1:$B$83;Адреса!A2));ROW($A$1:$A$83))))

Но массивная.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 12.06.2019, 15:33
 
Ответить
Сообщение
Код
=INDEX(Справочник!C:C;MIN(IF(ISNUMBER(FIND(Справочник!$A$1:$B$83;Адреса!A2));ROW($A$1:$A$83))))

Но массивная.

Автор - bmv98rus
Дата добавления - 12.06.2019 в 15:33
Teem Дата: Среда, 12.06.2019, 16:30 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Попробуйте так
=ЕСЛИОШИБКА(ПРОСМОТР(;-НАЙТИ(Справочник!A$1:A$83;A2);Справочник!C$1:C$83);ПРОСМОТР(;-НАЙТИ(Справочник!B$1:B$83;A2);Справочник!C$1:C$83))

Спасибо! Работает!


=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ЕЧИСЛО(НАЙТИ(Справочник!$A$1:$B$83;Адреса!A2));СТРОКА($A$1:$A$83))))
Но массивная.

Эта формула почему-то берёт пояс не из той строки. Для Абакана подставляет часовой пояс Анадыря, для Твери - пояс Томска и т.д.
 
Ответить
Сообщение
Попробуйте так
=ЕСЛИОШИБКА(ПРОСМОТР(;-НАЙТИ(Справочник!A$1:A$83;A2);Справочник!C$1:C$83);ПРОСМОТР(;-НАЙТИ(Справочник!B$1:B$83;A2);Справочник!C$1:C$83))

Спасибо! Работает!


=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ЕЧИСЛО(НАЙТИ(Справочник!$A$1:$B$83;Адреса!A2));СТРОКА($A$1:$A$83))))
Но массивная.

Эта формула почему-то берёт пояс не из той строки. Для Абакана подставляет часовой пояс Анадыря, для Твери - пояс Томска и т.д.

Автор - Teem
Дата добавления - 12.06.2019 в 16:30
bmv98rus Дата: Среда, 12.06.2019, 17:53 | Сообщение № 8
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 3094
Репутация: 535 ±
Замечаний: 0% ±

Excel 2013/2016
Думаю вы не обратили внимание на то что она массивная, вводится Ctrl+Shift+Enter


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеДумаю вы не обратили внимание на то что она массивная, вводится Ctrl+Shift+Enter

Автор - bmv98rus
Дата добавления - 12.06.2019 в 17:53
AlexM Дата: Среда, 12.06.2019, 19:47 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4242
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
Код
=ПРОСМОТР(2;1/МУМНОЖ(--ЕЧИСЛО(НАЙТИ(Справочник!A$1:B$83;A2));{1:1});Справочник!C$1:C$83)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ПРОСМОТР(2;1/МУМНОЖ(--ЕЧИСЛО(НАЙТИ(Справочник!A$1:B$83;A2));{1:1});Справочник!C$1:C$83)

Автор - AlexM
Дата добавления - 12.06.2019 в 19:47
Светлый Дата: Четверг, 13.06.2019, 09:08 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1464
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Мой вариант массивный:
Код
=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;Справочник!A$1:A$83;);Справочник!B$1:B$83;));СТРОКА($1:$83))))
*Даже так:
Код
=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;Справочник!A$1:B$83;));СТРОКА($1:$83))))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 13.06.2019, 09:11
 
Ответить
СообщениеМой вариант массивный:
Код
=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;Справочник!A$1:A$83;);Справочник!B$1:B$83;));СТРОКА($1:$83))))
*Даже так:
Код
=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;Справочник!A$1:B$83;));СТРОКА($1:$83))))

Автор - Светлый
Дата добавления - 13.06.2019 в 09:08
Светлый Дата: Четверг, 13.06.2019, 09:22 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 1464
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
bmv98rus, Добавил две строки Омск и Томск, формула не сработала.
AlexM, у меня формула вообще не работает.


Программировать проще, чем писать стихи.
 
Ответить
Сообщениеbmv98rus, Добавил две строки Омск и Томск, формула не сработала.
AlexM, у меня формула вообще не работает.

Автор - Светлый
Дата добавления - 13.06.2019 в 09:22
AlexM Дата: Четверг, 13.06.2019, 10:02 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4242
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
Цитата Светлый, 13.06.2019 в 09:22, в сообщении № 11 ()
AlexM, у меня формула вообще не работает
Странно
К сообщению приложен файл: 2567795_01.xlsx(15.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Цитата Светлый, 13.06.2019 в 09:22, в сообщении № 11 ()
AlexM, у меня формула вообще не работает
Странно

Автор - AlexM
Дата добавления - 13.06.2019 в 10:02
Светлый Дата: Четверг, 13.06.2019, 10:23 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1464
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Странно
Пока полностью лист Справочник не скопировал, формула не работала.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Странно
Пока полностью лист Справочник не скопировал, формула не работала.

Автор - Светлый
Дата добавления - 13.06.2019 в 10:23
bmv98rus Дата: Четверг, 13.06.2019, 11:33 | Сообщение № 14
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 3094
Репутация: 535 ±
Замечаний: 0% ±

Excel 2013/2016
Вот и моя работает
К сообщению приложен файл: 2968946.jpg(96.0 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеВот и моя работает

Автор - bmv98rus
Дата добавления - 13.06.2019 в 11:33
Светлый Дата: Четверг, 13.06.2019, 12:28 | Сообщение № 15
Группа: Друзья
Ранг: Старожил
Сообщений: 1464
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Вот и моя работает
Действительно.Даже в таком виде:
Код
=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ЕЧИСЛО(НАЙТИ(Справочник!A$1:B84;A2));СТРОКА($1:84))))
Прошу прощения. Наверно, не туда посмотрел.
*Сейчас правильно работает, потому что я в справочнике во все пустые ячейки записал 1. Если есть пустые ячейки, то не работает.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 13.06.2019, 12:39
 
Ответить
Сообщение
Вот и моя работает
Действительно.Даже в таком виде:
Код
=ИНДЕКС(Справочник!C:C;МИН(ЕСЛИ(ЕЧИСЛО(НАЙТИ(Справочник!A$1:B84;A2));СТРОКА($1:84))))
Прошу прощения. Наверно, не туда посмотрел.
*Сейчас правильно работает, потому что я в справочнике во все пустые ячейки записал 1. Если есть пустые ячейки, то не работает.

Автор - Светлый
Дата добавления - 13.06.2019 в 12:28
Teem Дата: Пятница, 14.06.2019, 11:11 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем огромне спасибо за участие! Даже не думал, что столько решений у данной задачи :)
 
Ответить
СообщениеВсем огромне спасибо за участие! Даже не думал, что столько решений у данной задачи :)

Автор - Teem
Дата добавления - 14.06.2019 в 11:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка часового пояса по адресу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!