Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разделение таблицы на другие листы с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделение таблицы на другие листы с условием (Формулы/Formulas)
Разделение таблицы на другие листы с условием
ZIKzaz Дата: Понедельник, 24.06.2019, 14:21 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер!
Столкнулся с след. проблемой:
Необходимо таблицу с листа 1 разделить и перенести на другие листы без пустых строк
В Excel не понимаю, по этому пришел за помощью сюда
Пример работы во вложении
К сообщению приложен файл: 154373.xls(20.0 Kb)
 
Ответить
СообщениеДобрый вечер!
Столкнулся с след. проблемой:
Необходимо таблицу с листа 1 разделить и перенести на другие листы без пустых строк
В Excel не понимаю, по этому пришел за помощью сюда
Пример работы во вложении

Автор - ZIKzaz
Дата добавления - 24.06.2019 в 14:21
_Boroda_ Дата: Понедельник, 24.06.2019, 14:59 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Для общего случая с произвольными названиями
Для А
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Лист1!$B$2:$D$99;;ПОИСКПОЗ($B$1;Лист1!$B$1:$D$1;));СТРОКА(Лист1!$2:$99));СТРОКА(A1)));"")

Для В
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$D;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Лист1!$B$2:$D$99;;ПОИСКПОЗ($B$1;Лист1!$B$1:$D$1;));СТРОКА(Лист1!$2:$99));СТРОКА(B1));ПОИСКПОЗ($B$1;Лист1!$B$1:$D$1;));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 154373_1.xls(50.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Для общего случая с произвольными названиями
Для А
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A:A;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Лист1!$B$2:$D$99;;ПОИСКПОЗ($B$1;Лист1!$B$1:$D$1;));СТРОКА(Лист1!$2:$99));СТРОКА(A1)));"")

Для В
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B:$D;НАИМЕНЬШИЙ(ЕСЛИ(ИНДЕКС(Лист1!$B$2:$D$99;;ПОИСКПОЗ($B$1;Лист1!$B$1:$D$1;));СТРОКА(Лист1!$2:$99));СТРОКА(B1));ПОИСКПОЗ($B$1;Лист1!$B$1:$D$1;));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 24.06.2019 в 14:59
ZIKzaz Дата: Понедельник, 24.06.2019, 16:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да, это то, что нужно, благодарю :)

P.S. Находил в интернете нечто подобное, но не знал про Ctrl+Shift+Enter, везде показывало только 1 строку и не мог понять в чем дело.


Сообщение отредактировал ZIKzaz - Понедельник, 24.06.2019, 16:14
 
Ответить
СообщениеДа, это то, что нужно, благодарю :)

P.S. Находил в интернете нечто подобное, но не знал про Ctrl+Shift+Enter, везде показывало только 1 строку и не мог понять в чем дело.

Автор - ZIKzaz
Дата добавления - 24.06.2019 в 16:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделение таблицы на другие листы с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!