Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по значению и вывод суммы результатов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по значению и вывод суммы результатов (Формулы/Formulas)
Поиск по значению и вывод суммы результатов
PavlinMavlin Дата: Четверг, 27.06.2019, 11:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Подскажите, пожалуйста, возможно ли в ячейку прописать формулу, которая будет заключаться в следующем.
На листе 1 есть таблица с массивом данных, стоящая из N количества строк. В каждой строке и в определенных двух столбцах каждой строки указывается эксклюзивное обозначение товара (x, y, z и т.д.) и его кол-во.
Ежедневно таблица пополняется новыми строками.
Итог: в ячейке должна быть высчитана сумма всех значений из диапазона 2 столбцов, удовлетворяющая условию поиска по эксклюзивному обозначению товара и его количеству при условии постоянного добавления новых данных.
Таблица с примером в приложении.

или в данном случае легче написать макрос?

Спасибо!
 
Ответить
СообщениеДобрый день!

Подскажите, пожалуйста, возможно ли в ячейку прописать формулу, которая будет заключаться в следующем.
На листе 1 есть таблица с массивом данных, стоящая из N количества строк. В каждой строке и в определенных двух столбцах каждой строки указывается эксклюзивное обозначение товара (x, y, z и т.д.) и его кол-во.
Ежедневно таблица пополняется новыми строками.
Итог: в ячейке должна быть высчитана сумма всех значений из диапазона 2 столбцов, удовлетворяющая условию поиска по эксклюзивному обозначению товара и его количеству при условии постоянного добавления новых данных.
Таблица с примером в приложении.

или в данном случае легче написать макрос?

Спасибо!

Автор - PavlinMavlin
Дата добавления - 27.06.2019 в 11:23
китин Дата: Четверг, 27.06.2019, 11:31 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Таблица с примером в приложении.

нехорошо обманывать :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Таблица с примером в приложении.

нехорошо обманывать :D

Автор - китин
Дата добавления - 27.06.2019 в 11:31
PavlinMavlin Дата: Четверг, 27.06.2019, 11:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, упс
К сообщению приложен файл: 9455824.xlsx(9.9 Kb)
 
Ответить
Сообщениекитин, упс

Автор - PavlinMavlin
Дата добавления - 27.06.2019 в 11:46
_Boroda_ Дата: Четверг, 27.06.2019, 11:53 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(A:A;D2;B:B)


Сводной таблицей еще можно
К сообщению приложен файл: 9455824_1.xlsx(13.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(A:A;D2;B:B)


Сводной таблицей еще можно

Автор - _Boroda_
Дата добавления - 27.06.2019 в 11:53
PavlinMavlin Дата: Четверг, 27.06.2019, 19:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,

Спасибо большое!
 
Ответить
Сообщение_Boroda_,

Спасибо большое!

Автор - PavlinMavlin
Дата добавления - 27.06.2019 в 19:54
PavlinMavlin Дата: Пятница, 28.06.2019, 10:18 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем доброе утро!

В продолжение предыдущего вопроса столкнулся со следующей проблемой. Вернее пытаюcь совместить две функции (Поиск по значению и СУММЕСЛИ), но что-то ничего не выходит.

Если в предыдущей таблице необходимо было посчитать количество товара удовлетворяющих заданному эксклюзивному значению, то в данном случае нужно посчитать общее количество товара удовлетворяющее условию содержания в каждой ячейке "определенной части" заданного значения. Насколько я понял, функция СУММЕСЛИ срабатывает только если значения совпадают полностью.
К примеру, исходные значения 111-EUR-111 и 111-USD-111, формула должна вычленить все ячейки из диапазона содержащие "EUR" и посчитать сумму товара.

Продолжение таблицы в приложении.

П.С. Модератору, не стал создавать новую тему, т.к. новый вопрос производная от старого и название темы удовлетворяет условию второго вопроса.
К сообщению приложен файл: 9455824_1-1-.xlsx(14.5 Kb)
 
Ответить
СообщениеВсем доброе утро!

В продолжение предыдущего вопроса столкнулся со следующей проблемой. Вернее пытаюcь совместить две функции (Поиск по значению и СУММЕСЛИ), но что-то ничего не выходит.

Если в предыдущей таблице необходимо было посчитать количество товара удовлетворяющих заданному эксклюзивному значению, то в данном случае нужно посчитать общее количество товара удовлетворяющее условию содержания в каждой ячейке "определенной части" заданного значения. Насколько я понял, функция СУММЕСЛИ срабатывает только если значения совпадают полностью.
К примеру, исходные значения 111-EUR-111 и 111-USD-111, формула должна вычленить все ячейки из диапазона содержащие "EUR" и посчитать сумму товара.

Продолжение таблицы в приложении.

П.С. Модератору, не стал создавать новую тему, т.к. новый вопрос производная от старого и название темы удовлетворяет условию второго вопроса.

Автор - PavlinMavlin
Дата добавления - 28.06.2019 в 10:18
_Boroda_ Дата: Пятница, 28.06.2019, 10:21 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Насколько я понял, функция СУММЕСЛИ срабатывает только если значения совпадают полностью.

Вы б почитали справку-то, там много чего интересного написано
Код
=СУММЕСЛИ(A:A;"*"&D19;B:B)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Насколько я понял, функция СУММЕСЛИ срабатывает только если значения совпадают полностью.

Вы б почитали справку-то, там много чего интересного написано
Код
=СУММЕСЛИ(A:A;"*"&D19;B:B)

Автор - _Boroda_
Дата добавления - 28.06.2019 в 10:21
PavlinMavlin Дата: Пятница, 28.06.2019, 10:27 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,

Еще раз спасибо!

Вот планирую, полностью погрузиться в изучение Excel, но никак руки не дойдут.
 
Ответить
Сообщение_Boroda_,

Еще раз спасибо!

Вот планирую, полностью погрузиться в изучение Excel, но никак руки не дойдут.

Автор - PavlinMavlin
Дата добавления - 28.06.2019 в 10:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по значению и вывод суммы результатов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!