Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как разложить число на цифры? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разложить число на цифры? (Формулы/Formulas)
Как разложить число на цифры?
djon2012 Дата: Четверг, 27.06.2019, 23:37 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Подскажите пожалуйста, как разложить число на составляющие его цифры (пример прилагается). Как проще и лучше это реализовать, макросом или формулой. Спасибо!
К сообщению приложен файл: 6666825.xlsb(10.9 Kb)
 
Ответить
СообщениеЗдравствуйте! Подскажите пожалуйста, как разложить число на составляющие его цифры (пример прилагается). Как проще и лучше это реализовать, макросом или формулой. Спасибо!

Автор - djon2012
Дата добавления - 27.06.2019 в 23:37
_Igor_61 Дата: Четверг, 27.06.2019, 23:52 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 337
Репутация: 69 ±
Замечаний: 0% ±

Excel 2007
Код
=--ПСТР($A1;СТОЛБЕЦ()-1;1)


Сообщение отредактировал _Igor_61 - Четверг, 27.06.2019, 23:55
 
Ответить
Сообщение
Код
=--ПСТР($A1;СТОЛБЕЦ()-1;1)

Автор - _Igor_61
Дата добавления - 27.06.2019 в 23:52
djon2012 Дата: Пятница, 28.06.2019, 06:28 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Igor_61 огромное Вам СПАСИБО. Как всегда, все гениальное - просто.
 
Ответить
Сообщение_Igor_61 огромное Вам СПАСИБО. Как всегда, все гениальное - просто.

Автор - djon2012
Дата добавления - 28.06.2019 в 06:28
DrMini Дата: Понедельник, 01.07.2019, 06:38 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 387
Репутация: 4 ±
Замечаний: 0% ±

Excel 2010, 2013
_Igor_61, Спасибо. Как нельзя кстати пригодилось.
 
Ответить
Сообщение_Igor_61, Спасибо. Как нельзя кстати пригодилось.

Автор - DrMini
Дата добавления - 01.07.2019 в 06:38
_Boroda_ Дата: Понедельник, 01.07.2019, 09:10 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда чуть более универсально. Эта формула
=--ПСТР($A1;СТОЛБЕЦ()-1;1)
для написания в столбце В и протягивании от него вправо. Если формула не в В, а, например, в Е, то -1 нужно заменить на -4, что не очень удобно
Можно написать так
Код
=--ПСТР($A1;СТОЛБЕЦ(A1);1)
, тогда формулу можно писать в любом столбце
Ну и убрать ошибки, когда цифры заканчиваются
Код
=ЕСЛИОШИБКА(--ПСТР($A1;СТОЛБЕЦ(A1);1);"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда чуть более универсально. Эта формула
=--ПСТР($A1;СТОЛБЕЦ()-1;1)
для написания в столбце В и протягивании от него вправо. Если формула не в В, а, например, в Е, то -1 нужно заменить на -4, что не очень удобно
Можно написать так
Код
=--ПСТР($A1;СТОЛБЕЦ(A1);1)
, тогда формулу можно писать в любом столбце
Ну и убрать ошибки, когда цифры заканчиваются
Код
=ЕСЛИОШИБКА(--ПСТР($A1;СТОЛБЕЦ(A1);1);"")

Автор - _Boroda_
Дата добавления - 01.07.2019 в 09:10
djon2012 Дата: Пятница, 05.07.2019, 07:20 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Boroda спасибо Вам большое, не один раз выручали! :)
 
Ответить
СообщениеBoroda спасибо Вам большое, не один раз выручали! :)

Автор - djon2012
Дата добавления - 05.07.2019 в 07:20
djon2012 Дата: Пятница, 05.07.2019, 09:19 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Подскажите пожалуйста, почему в прикрепленном файле число в ячейке А2 неправильно разлагается на цифры. Спасибо!
К сообщению приложен файл: 7042111.xlsb(9.7 Kb)
 
Ответить
СообщениеПодскажите пожалуйста, почему в прикрепленном файле число в ячейке А2 неправильно разлагается на цифры. Спасибо!

Автор - djon2012
Дата добавления - 05.07.2019 в 09:19
_Boroda_ Дата: Пятница, 05.07.2019, 09:22 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Потому, что Excel умный слишком. Он автоматически преобразовал большое число в
7,45636353444355E+30
Вот так попробуйте
Код
=--ПСТР(ТЕКСТ($A2;0);СТОЛБЕЦ()-1;1)

Но только учтите, что в Excel выводится 15 значащих цифр, (остальное заполняется нулями) и Ваше произведение на самом деле может быть вовсе не таким, как посчитал его Excel


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПотому, что Excel умный слишком. Он автоматически преобразовал большое число в
7,45636353444355E+30
Вот так попробуйте
Код
=--ПСТР(ТЕКСТ($A2;0);СТОЛБЕЦ()-1;1)

Но только учтите, что в Excel выводится 15 значащих цифр, (остальное заполняется нулями) и Ваше произведение на самом деле может быть вовсе не таким, как посчитал его Excel

Автор - _Boroda_
Дата добавления - 05.07.2019 в 09:22
djon2012 Дата: Пятница, 05.07.2019, 09:33 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 106
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо Boroda за совет, а то я пробовал изменять числовой формат в ячейке но увы безрезультатно.
 
Ответить
СообщениеСпасибо Boroda за совет, а то я пробовал изменять числовой формат в ячейке но увы безрезультатно.

Автор - djon2012
Дата добавления - 05.07.2019 в 09:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разложить число на цифры? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!