Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Зависящие списки и присвоение значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Зависящие списки и присвоение значений (Формулы/Formulas)
Зависящие списки и присвоение значений
Ivlev_Nikita Дата: Понедельник, 01.07.2019, 13:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Привет! Помогите решить поставленную задачу.
Что мне нужно?
Создать таблицу для автоматического расчета стоимости оборудования с помощью выпадающих списков.
Итак, на примере овощей:
Есть 1 столбец (Категории), в данной ячейке должен содержаться список с выбором категории продуктов (фрукты, овощи, ягоды), например Фрукты
Есть 2 столбец (Какой именно продукт), в данных ячейках должен содержаться список продуктов исходя из выбранного в первом столбце. (например, если выбрали "фрукты" то здесь появляется список из продуктов ТОЛЬКО фруктов: "Яблоко","Банан","Апельсин", например Яблоко
Есть 3 столбец (Цена продукта), данная ячейка Автоматически указывает цену выбранного продукта (из заранее готовой таблицы с ценами), например, стоимость 30 рублей

Итого получается цепь: Выбираем "Фрукты" - выбираем "Яблоко" - автоматически указывается "30 рублей"
К сообщению приложен файл: 9536512.xlsx(10.6 Kb)
 
Ответить
СообщениеПривет! Помогите решить поставленную задачу.
Что мне нужно?
Создать таблицу для автоматического расчета стоимости оборудования с помощью выпадающих списков.
Итак, на примере овощей:
Есть 1 столбец (Категории), в данной ячейке должен содержаться список с выбором категории продуктов (фрукты, овощи, ягоды), например Фрукты
Есть 2 столбец (Какой именно продукт), в данных ячейках должен содержаться список продуктов исходя из выбранного в первом столбце. (например, если выбрали "фрукты" то здесь появляется список из продуктов ТОЛЬКО фруктов: "Яблоко","Банан","Апельсин", например Яблоко
Есть 3 столбец (Цена продукта), данная ячейка Автоматически указывает цену выбранного продукта (из заранее готовой таблицы с ценами), например, стоимость 30 рублей

Итого получается цепь: Выбираем "Фрукты" - выбираем "Яблоко" - автоматически указывается "30 рублей"

Автор - Ivlev_Nikita
Дата добавления - 01.07.2019 в 13:12
_Boroda_ Дата: Понедельник, 01.07.2019, 13:29 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Чуть переместил таблицу данных и в ней столбцы тоже
См. именованные диапазоны (Контрл F3)
Для бренда формула
Код
=СМЕЩ(ИНДЕКС(Лист1!$L$2:$N$2;ПОИСКПОЗ(Лист1!$B5;Кат;));;;СЧЁТЗ(ИНДЕКС(Лист1!$L:$N;;ПОИСКПОЗ(Лист1!$B5;Кат;)))-1)

Для Коэф
Код
=СУММПРОИЗВ((L$1:N$1=B5)*(C5=L$2:N$9)*O$2:Q$9)
К сообщению приложен файл: 9536512_1.xlsx(11.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Чуть переместил таблицу данных и в ней столбцы тоже
См. именованные диапазоны (Контрл F3)
Для бренда формула
Код
=СМЕЩ(ИНДЕКС(Лист1!$L$2:$N$2;ПОИСКПОЗ(Лист1!$B5;Кат;));;;СЧЁТЗ(ИНДЕКС(Лист1!$L:$N;;ПОИСКПОЗ(Лист1!$B5;Кат;)))-1)

Для Коэф
Код
=СУММПРОИЗВ((L$1:N$1=B5)*(C5=L$2:N$9)*O$2:Q$9)

Автор - _Boroda_
Дата добавления - 01.07.2019 в 13:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Зависящие списки и присвоение значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!