Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск максимального в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск максимального в столбце (Формулы/Formulas)
Поиск максимального в столбце
ZDik Дата: Понедельник, 01.07.2019, 15:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Как сделать Поиск максимального в столбце
Предлагаются решения в таблице, но у меня постоянно таблица растет и есть пустые строки, надо обрабатывать весь столбец B и С из второго листа, и перелагаемые решения яндексом у меня не хотят работать
Что-то я запутался
Вроде просто, но что-то предлагаемые решения не работают
Подскажите, пожалуйста
К сообщению приложен файл: 2211156.xlsx(12.8 Kb)
 
Ответить
СообщениеКак сделать Поиск максимального в столбце
Предлагаются решения в таблице, но у меня постоянно таблица растет и есть пустые строки, надо обрабатывать весь столбец B и С из второго листа, и перелагаемые решения яндексом у меня не хотят работать
Что-то я запутался
Вроде просто, но что-то предлагаемые решения не работают
Подскажите, пожалуйста

Автор - ZDik
Дата добавления - 01.07.2019 в 15:00
Nic70y Дата: Понедельник, 01.07.2019, 15:09 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5402
Репутация: 1182 ±
Замечаний: 0% ±

ru13;10;03
формула
Код
=СУММПРОИЗВ(МАКС((Лист2!B$2:B$237=B2)*Лист2!C$2:C$237))
или сводная (на 2м листе)
К сообщению приложен файл: 9309673.xlsx(21.1 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеформула
Код
=СУММПРОИЗВ(МАКС((Лист2!B$2:B$237=B2)*Лист2!C$2:C$237))
или сводная (на 2м листе)

Автор - Nic70y
Дата добавления - 01.07.2019 в 15:09
ZDik Дата: Понедельник, 01.07.2019, 15:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
нельзя весь столбец обрабатывать?
 
Ответить
Сообщениенельзя весь столбец обрабатывать?

Автор - ZDik
Дата добавления - 01.07.2019 в 15:15
Nic70y Дата: Понедельник, 01.07.2019, 15:26 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5402
Репутация: 1182 ±
Замечаний: 0% ±

ru13;10;03
нельзя
попробуйте
(если тормозить не будет, то можно)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
нельзя
попробуйте
(если тормозить не будет, то можно)

Автор - Nic70y
Дата добавления - 01.07.2019 в 15:26
_Boroda_ Дата: Понедельник, 01.07.2019, 15:28 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Там в С1 текст, поэтому совсем как у Николая не получится
Вот так можно
Код
=МАКС((Лист2!B:B=B2)*Ч(+Лист2!C:C))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
А лучше используйте формулу Николая, но вместо 237 напишите 9999 (число, заведомо большее максимально возможного количества заполненных строк)
И формат ячеек можно так
ДД.ММ.ГГГГ ч:мм;;
или так
ДД.ММ.ГГГГ ч:мм;;0
К сообщению приложен файл: 2211156_2.xlsx(15.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТам в С1 текст, поэтому совсем как у Николая не получится
Вот так можно
Код
=МАКС((Лист2!B:B=B2)*Ч(+Лист2!C:C))
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
А лучше используйте формулу Николая, но вместо 237 напишите 9999 (число, заведомо большее максимально возможного количества заполненных строк)
И формат ячеек можно так
ДД.ММ.ГГГГ ч:мм;;
или так
ДД.ММ.ГГГГ ч:мм;;0

Автор - _Boroda_
Дата добавления - 01.07.2019 в 15:28
ZDik Дата: Понедельник, 01.07.2019, 15:30 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ок, буду старые строки в архив оптравлять, спасибо
 
Ответить
СообщениеОк, буду старые строки в архив оптравлять, спасибо

Автор - ZDik
Дата добавления - 01.07.2019 в 15:30
_Boroda_ Дата: Понедельник, 01.07.2019, 15:36 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А лучше используйте формулу Николая, но вместо 237 напишите 9999 (число, заведомо большее максимально возможного количества заполненных строк)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
А лучше используйте формулу Николая, но вместо 237 напишите 9999 (число, заведомо большее максимально возможного количества заполненных строк)

Автор - _Boroda_
Дата добавления - 01.07.2019 в 15:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск максимального в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!