Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск наложения временных интервалов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наложения временных интервалов (Формулы/Formulas)
Поиск наложения временных интервалов
Ohtnik77 Дата: Среда, 03.07.2019, 14:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго всем дня! Прошу помочь с поиском решения.
Есть формула, которая учитывая дополнительный критерий показывает когда два периода накладываются друг на друга.
Прошу подсказать как можно, не меняя уже существующий "алгоритм" добавить в эту формулу ещё один критерий.
Более подробное описание в файле Примера.
deal
К сообщению приложен файл: 2733084.xlsx(11.2 Kb)
 
Ответить
СообщениеДоброго всем дня! Прошу помочь с поиском решения.
Есть формула, которая учитывая дополнительный критерий показывает когда два периода накладываются друг на друга.
Прошу подсказать как можно, не меняя уже существующий "алгоритм" добавить в эту формулу ещё один критерий.
Более подробное описание в файле Примера.
deal

Автор - Ohtnik77
Дата добавления - 03.07.2019 в 14:23
Nic70y Дата: Среда, 03.07.2019, 14:48 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5397
Репутация: 1175 ±
Замечаний: 0% ±

ru13;10;03
добавить *(A$2:A$4=A2)
Код
=ЕСЛИ(И(СУММПРОИЗВ((C2<=$D$2:$D$4)*(D2>$C$2:$C$4)*($B$2:$B$4=B2)*(A$2:A$4=A2))>1;И(B2>=--"10:00:00";B2<=--"12:00:00"));"Есть наложение";"")


ЯД(poison) 41001841029809
 
Ответить
Сообщениедобавить *(A$2:A$4=A2)
Код
=ЕСЛИ(И(СУММПРОИЗВ((C2<=$D$2:$D$4)*(D2>$C$2:$C$4)*($B$2:$B$4=B2)*(A$2:A$4=A2))>1;И(B2>=--"10:00:00";B2<=--"12:00:00"));"Есть наложение";"")

Автор - Nic70y
Дата добавления - 03.07.2019 в 14:48
_Boroda_ Дата: Среда, 03.07.2019, 14:56 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15394
Репутация: 6028 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИ((СУММПРОИЗВ((C2<=D$2:D$4)*(D2>C$2:C$4)*(B$2:B$4=B2)*(A$2:A$4=A2))>1)*(B2>=--"10:")*(B2<=--"12:");"Есть наложение";"")

Код
=ЕСЛИ((СУММПРОИЗВ((C2<=D$2:D$4)*(D2>C$2:C$4)*(B$2:B$4+A$2:A$4=A2+B2))>1)*(B2>=--"10:")*(B2<=--"12:");"Есть наложение";"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИ((СУММПРОИЗВ((C2<=D$2:D$4)*(D2>C$2:C$4)*(B$2:B$4=B2)*(A$2:A$4=A2))>1)*(B2>=--"10:")*(B2<=--"12:");"Есть наложение";"")

Код
=ЕСЛИ((СУММПРОИЗВ((C2<=D$2:D$4)*(D2>C$2:C$4)*(B$2:B$4+A$2:A$4=A2+B2))>1)*(B2>=--"10:")*(B2<=--"12:");"Есть наложение";"")

Автор - _Boroda_
Дата добавления - 03.07.2019 в 14:56
Ohtnik77 Дата: Среда, 03.07.2019, 15:03 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Кажись работает! Благодарю за быструю помощь! hands hands hands
 
Ответить
СообщениеКажись работает! Благодарю за быструю помощь! hands hands hands

Автор - Ohtnik77
Дата добавления - 03.07.2019 в 15:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наложения временных интервалов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!