Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка стоимости в зависимости от направления - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка стоимости в зависимости от направления (Формулы/Formulas)
Вставка стоимости в зависимости от направления
rubikf Дата: Четверг, 04.07.2019, 14:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть 3 таблицы:
в одну нужно вводить данные вылет/прилет и тогда должна появляться стоимость направления;
вторая с исходными данными, здесь указана стоимость для каждого направления;
необходимость третьей под вопросом, она содержит названия городов из второй таблицы, но без дубликатов, чтобы проще было выбирать их из списка в таблице 1

Нужно чтобы при выборе или вводе названия двух городов появлялась стоимость перевозки.

Подозреваю что нужны ИНДЕКС и ПОИСКПОЗ, но не пойму как их применить. Или ошибаюсь.
К сообщению приложен файл: 3516034.xlsx(12.2 Kb)
 
Ответить
СообщениеЕсть 3 таблицы:
в одну нужно вводить данные вылет/прилет и тогда должна появляться стоимость направления;
вторая с исходными данными, здесь указана стоимость для каждого направления;
необходимость третьей под вопросом, она содержит названия городов из второй таблицы, но без дубликатов, чтобы проще было выбирать их из списка в таблице 1

Нужно чтобы при выборе или вводе названия двух городов появлялась стоимость перевозки.

Подозреваю что нужны ИНДЕКС и ПОИСКПОЗ, но не пойму как их применить. Или ошибаюсь.

Автор - rubikf
Дата добавления - 04.07.2019 в 14:29
Nic70y Дата: Четверг, 04.07.2019, 14:33 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММЕСЛИМН(Расценки!C$2:C$6;Расценки!A$2:A$6;A2;Расценки!B$2:B$6;B2)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(Расценки!C$2:C$6;Расценки!A$2:A$6;A2;Расценки!B$2:B$6;B2)

Автор - Nic70y
Дата добавления - 04.07.2019 в 14:33
rubikf Дата: Четверг, 04.07.2019, 14:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, спасибо!!! Так все просто оказывается :)
 
Ответить
СообщениеNic70y, спасибо!!! Так все просто оказывается :)

Автор - rubikf
Дата добавления - 04.07.2019 в 14:46
rubikf Дата: Четверг, 04.07.2019, 18:55 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Решил сам добавить колонку со временем, но ничего не выходит.
Изначально время было в десятичном формате, формулой преобразовал в нормальный вид времени, затем в отдельную колонку перенес только результат такого преобразования. А сделать подсчет с помощью =СУММЕСЛИМН не получается. Уже и формат ячейки с временем изменил на часовой, результат нулевой. Помогите пожалуйста.
К сообщению приложен файл: 4046583.xlsx(13.0 Kb)
 
Ответить
СообщениеРешил сам добавить колонку со временем, но ничего не выходит.
Изначально время было в десятичном формате, формулой преобразовал в нормальный вид времени, затем в отдельную колонку перенес только результат такого преобразования. А сделать подсчет с помощью =СУММЕСЛИМН не получается. Уже и формат ячейки с временем изменил на часовой, результат нулевой. Помогите пожалуйста.

Автор - rubikf
Дата добавления - 04.07.2019 в 18:55
Светлый Дата: Четверг, 04.07.2019, 19:19 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1299
Репутация: 325 ±
Замечаний: 0% ±

Excel 2010
В столбце E или F должна быть формула:
Код
=D2/24
и формат времени, тогда функция будет работать.
*Или основную формулу сделать:
Код
=СУММЕСЛИМН(Расценки!D$2:D$6;Расценки!A$2:A$6;A2;Расценки!B$2:B$6;B2)/24


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 04.07.2019, 19:23
 
Ответить
СообщениеВ столбце E или F должна быть формула:
Код
=D2/24
и формат времени, тогда функция будет работать.
*Или основную формулу сделать:
Код
=СУММЕСЛИМН(Расценки!D$2:D$6;Расценки!A$2:A$6;A2;Расценки!B$2:B$6;B2)/24

Автор - Светлый
Дата добавления - 04.07.2019 в 19:19
rubikf Дата: Четверг, 04.07.2019, 19:52 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, спасибо! hands
 
Ответить
СообщениеСветлый, спасибо! hands

Автор - rubikf
Дата добавления - 04.07.2019 в 19:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка стоимости в зависимости от направления (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!