Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция "ЕСЛИ" со множеством разный условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция "ЕСЛИ" со множеством разный условий (Формулы/Formulas)
Функция "ЕСЛИ" со множеством разный условий
KIMVSR Дата: Среда, 10.07.2019, 14:40 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте,

Помогите, пожалуйста, решить следующую головоломку:

Есть сводная таблица данных, в которой хранятся данные об умениях работников в разных отделах (так называемый multiskilling).

Есть 5 отделов (Department_01 - Department_05) и по 3 умения в каждом отделе.

Есть дополнительные столбцы (x/o), которые указывает на принадлежность каждого работника к отделу:
- Если это умения из своего отдела - ставится "о", если же это умения из чужого (соседнего) отдела - ставится "х".
- В случае своего собственного отдела всегда ставится "о", даже если умения не прописаны.
- В случае чужого отдела "х" ставится только в случае, если хотя бы одно из умений больше "1".
- Если же все умения в чужом отделе оценены на "1", тогда "х" не ставится, т.е. умения в последствии не идут в учёт.



Верхняя таблица показывает, как должность быть. Нижняя таблица - с формулами в столбцах х/о, выделенными жирной пунктирной линией.

Я смог прописать формулу для каждого столбца отдельно, например:

Код
=IF(B15=$D$14;"o";IF(OR(D15>=2;E15>=2;F15>=2);"x";""))

Проблема в том, что этих отделов на самом деле около 30-ти и работников около 300-т человек.

Возможно ли как-то одной универсальной формулой решить эту задачу сразу во всех столбцах, выделенными пунктиром?

Например, формула смотрит ячейку B15 и видит "Department_01", затем прописывает "о" в одну из С15/G15/K15/O15/S15 ячеек соответственно.
С умениями также.

Если это очень сложно, тогда не надо заморачиваться, ребят :)

Заранее большое спасибо!
К сообщению приложен файл: kimvsr.xlsx(11.8 Kb)
 
Ответить
СообщениеЗдравствуйте,

Помогите, пожалуйста, решить следующую головоломку:

Есть сводная таблица данных, в которой хранятся данные об умениях работников в разных отделах (так называемый multiskilling).

Есть 5 отделов (Department_01 - Department_05) и по 3 умения в каждом отделе.

Есть дополнительные столбцы (x/o), которые указывает на принадлежность каждого работника к отделу:
- Если это умения из своего отдела - ставится "о", если же это умения из чужого (соседнего) отдела - ставится "х".
- В случае своего собственного отдела всегда ставится "о", даже если умения не прописаны.
- В случае чужого отдела "х" ставится только в случае, если хотя бы одно из умений больше "1".
- Если же все умения в чужом отделе оценены на "1", тогда "х" не ставится, т.е. умения в последствии не идут в учёт.



Верхняя таблица показывает, как должность быть. Нижняя таблица - с формулами в столбцах х/о, выделенными жирной пунктирной линией.

Я смог прописать формулу для каждого столбца отдельно, например:

Код
=IF(B15=$D$14;"o";IF(OR(D15>=2;E15>=2;F15>=2);"x";""))

Проблема в том, что этих отделов на самом деле около 30-ти и работников около 300-т человек.

Возможно ли как-то одной универсальной формулой решить эту задачу сразу во всех столбцах, выделенными пунктиром?

Например, формула смотрит ячейку B15 и видит "Department_01", затем прописывает "о" в одну из С15/G15/K15/O15/S15 ячеек соответственно.
С умениями также.

Если это очень сложно, тогда не надо заморачиваться, ребят :)

Заранее большое спасибо!

Автор - KIMVSR
Дата добавления - 10.07.2019 в 14:40
_Boroda_ Дата: Среда, 10.07.2019, 14:52 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15394
Репутация: 6028 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не совсем понял вопрос. Может, так?
Код
=ЕСЛИ($B7=D$6;"o";ЕСЛИ(ИЛИ(D7>=2;E7>=2;F7>=2);"x";""))

Не, 30 отделов... Так?
Код
=ЕСЛИ($B7=D$6;"o";ЕСЛИ(СЧЁТ(ИНДЕКС(1/(D7:F7>1);));"x";""))
К сообщению приложен файл: kimvsr_1.xlsx(11.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе совсем понял вопрос. Может, так?
Код
=ЕСЛИ($B7=D$6;"o";ЕСЛИ(ИЛИ(D7>=2;E7>=2;F7>=2);"x";""))

Не, 30 отделов... Так?
Код
=ЕСЛИ($B7=D$6;"o";ЕСЛИ(СЧЁТ(ИНДЕКС(1/(D7:F7>1);));"x";""))

Автор - _Boroda_
Дата добавления - 10.07.2019 в 14:52
KIMVSR Дата: Четверг, 11.07.2019, 15:36 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, спасибо тебе большое, Саш, эта формула помогла мне сэкономить кучу времени!

Код
=ЕСЛИ($B7=D$6;"o";ЕСЛИ(СЧЁТ(ИНДЕКС(1/(D7:F7>1);));"x";""))
 
Ответить
Сообщение_Boroda_, спасибо тебе большое, Саш, эта формула помогла мне сэкономить кучу времени!

Код
=ЕСЛИ($B7=D$6;"o";ЕСЛИ(СЧЁТ(ИНДЕКС(1/(D7:F7>1);));"x";""))

Автор - KIMVSR
Дата добавления - 11.07.2019 в 15:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция "ЕСЛИ" со множеством разный условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!