Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по диапазону имён. Пытаюсь сделать чудо ВПР. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по диапазону имён. Пытаюсь сделать чудо ВПР. (Формулы/Formulas)
Выборка по диапазону имён. Пытаюсь сделать чудо ВПР.
Shambala Дата: Четверг, 11.07.2019, 16:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот такая задачка нелёгкая упала сверху))
Из короткого списка, нужно выбрать из таблицы все совпадающие имена и их значения в отдельную таблицу. ВПР не подходит, так как ищет только первое наименование.
Решение крутиться в районе
Код
=ИНДЕКС($U$3:$U$41;АГРЕГАТ(15;6;(СТРОКА($U$3:$U$41)-СТРОКА($U$3)+1)/($U$3:$U$41=$Q$3:$Q$12);СТРОКА()-СТРОКА($AA$3)+1))

Но почему то находит только два наименования из всего списка и дальше что-то идёт не так. Чувствую что решение близко, но что-то сильно упускаю и уже второй день никак. %)
К сообщению приложен файл: 3497726.xlsx(13.3 Kb)


Сообщение отредактировал Shambala - Четверг, 11.07.2019, 20:53
 
Ответить
СообщениеВот такая задачка нелёгкая упала сверху))
Из короткого списка, нужно выбрать из таблицы все совпадающие имена и их значения в отдельную таблицу. ВПР не подходит, так как ищет только первое наименование.
Решение крутиться в районе
Код
=ИНДЕКС($U$3:$U$41;АГРЕГАТ(15;6;(СТРОКА($U$3:$U$41)-СТРОКА($U$3)+1)/($U$3:$U$41=$Q$3:$Q$12);СТРОКА()-СТРОКА($AA$3)+1))

Но почему то находит только два наименования из всего списка и дальше что-то идёт не так. Чувствую что решение близко, но что-то сильно упускаю и уже второй день никак. %)

Автор - Shambala
Дата добавления - 11.07.2019 в 16:53
Nic70y Дата: Четверг, 11.07.2019, 17:08 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
1.Непонятно как должен выглядеть результат,
если так, как думаю я, то ответ готов.
2.Но я его Вам не дам,
т.к. у Вас формула в посте не оформлена тегами (почти как у п-на Печкина)
(Модераторы побьют - они очень злые у нас)


ЯД(poison) 41001841029809
 
Ответить
Сообщение1.Непонятно как должен выглядеть результат,
если так, как думаю я, то ответ готов.
2.Но я его Вам не дам,
т.к. у Вас формула в посте не оформлена тегами (почти как у п-на Печкина)
(Модераторы побьют - они очень злые у нас)

Автор - Nic70y
Дата добавления - 11.07.2019 в 17:08
Shambala Дата: Четверг, 11.07.2019, 21:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

A!!! Дорогой Уважаемый Любимый Nic70y respect
Надеюсь формула теперь правильно исправлена тегами, больше не повториться подобных упущений, всё случилось по незнанию=) :fool:
Прошу помочь моей душе в царстве тьмы отыскать правильные символы для решения)
Думаю, что вы правильно поняли. Если же нет, то я тогда сделаю схематичное фото) Но моя интуиция говорит, что правильно.


Сообщение отредактировал китин - Пятница, 12.07.2019, 12:01
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

A!!! Дорогой Уважаемый Любимый Nic70y respect
Надеюсь формула теперь правильно исправлена тегами, больше не повториться подобных упущений, всё случилось по незнанию=) :fool:
Прошу помочь моей душе в царстве тьмы отыскать правильные символы для решения)
Думаю, что вы правильно поняли. Если же нет, то я тогда сделаю схематичное фото) Но моя интуиция говорит, что правильно.

Автор - Shambala
Дата добавления - 11.07.2019 в 21:11
Nic70y Дата: Пятница, 12.07.2019, 08:03 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
формула массива
Код
=ИНДЕКС(E$1:E$41;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($E$3:$E$41;$A$3:$A$12;));СТРОКА(E$3:E$41));СТРОКА(K1)))
К сообщению приложен файл: 3084420.xlsx(16.3 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ИНДЕКС(E$1:E$41;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($E$3:$E$41;$A$3:$A$12;));СТРОКА(E$3:E$41));СТРОКА(K1)))

Автор - Nic70y
Дата добавления - 12.07.2019 в 08:03
Shambala Дата: Пятница, 12.07.2019, 09:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Скачала пример, безмерно благодарна! Это именно то, что я хотела! Спасибо огромное!!! Вы чудо! :holiday:
Тему можно закрывать подскажите?


Сообщение отредактировал китин - Пятница, 12.07.2019, 12:02
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Скачала пример, безмерно благодарна! Это именно то, что я хотела! Спасибо огромное!!! Вы чудо! :holiday:
Тему можно закрывать подскажите?

Автор - Shambala
Дата добавления - 12.07.2019 в 09:23
Nic70y Дата: Пятница, 12.07.2019, 11:46 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Тему можно закрывать подскажите?
нет!
это запрещено,
закрыть могут только модераторы / администраторы
и то только из-за нарушений правил.
на пример за оверквотинг


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Тему можно закрывать подскажите?
нет!
это запрещено,
закрыть могут только модераторы / администраторы
и то только из-за нарушений правил.
на пример за оверквотинг

Автор - Nic70y
Дата добавления - 12.07.2019 в 11:46
Shambala Дата: Суббота, 13.07.2019, 09:29 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добавлена ЕСЛИОШИБКА, чтобы скрыть области с ошибками.
Код
=ЕСЛИОШИБКА(ИНДЕКС(E$1:E$41;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($E$3:$E$41;$A$3:$A$12;));СТРОКА(E$3:E$41));СТРОКА(K1)));"")

Все работает идеально и красиво. Спасибо Nic70y.

Но возникает следующий вопрос, при создании диаграммы и различной выборке — пустая область диаграммы постоянно гуляет, то больше то меньше и хотелось бы, чтобы она скрывалась автоматически.
К сообщению приложен файл: 1724974.jpg(95.5 Kb)


Сообщение отредактировал Shambala - Суббота, 13.07.2019, 09:31
 
Ответить
СообщениеДобавлена ЕСЛИОШИБКА, чтобы скрыть области с ошибками.
Код
=ЕСЛИОШИБКА(ИНДЕКС(E$1:E$41;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($E$3:$E$41;$A$3:$A$12;));СТРОКА(E$3:E$41));СТРОКА(K1)));"")

Все работает идеально и красиво. Спасибо Nic70y.

Но возникает следующий вопрос, при создании диаграммы и различной выборке — пустая область диаграммы постоянно гуляет, то больше то меньше и хотелось бы, чтобы она скрывалась автоматически.

Автор - Shambala
Дата добавления - 13.07.2019 в 09:29
Nic70y Дата: Суббота, 13.07.2019, 09:32 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
О диаграмме нужно создать новую тему.


ЯД(poison) 41001841029809
 
Ответить
СообщениеО диаграмме нужно создать новую тему.

Автор - Nic70y
Дата добавления - 13.07.2019 в 09:32
Shambala Дата: Пятница, 26.07.2019, 15:15 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Тему новую не создаю, так как вопрос по той же задаче - выборка диапазону имён и возможно решение связано с тем, что было написано выше. Спасибо огромное всем форумчанам, которые помогли мне продвинуться невероятно далеко по этой теме и теме с визуализацией данных.
Задача та же самая, два диапазона с именами для выборки A и C. Но теперь два столбца имён E и F из которых будет выборка. В любом соотношении между А и С. Надеюсь скрин и пример поможет объяснить лучше, чем мой костный язык :p

К сообщению приложен файл: 546456454.xlsx(15.2 Kb)
 
Ответить
СообщениеТему новую не создаю, так как вопрос по той же задаче - выборка диапазону имён и возможно решение связано с тем, что было написано выше. Спасибо огромное всем форумчанам, которые помогли мне продвинуться невероятно далеко по этой теме и теме с визуализацией данных.
Задача та же самая, два диапазона с именами для выборки A и C. Но теперь два столбца имён E и F из которых будет выборка. В любом соотношении между А и С. Надеюсь скрин и пример поможет объяснить лучше, чем мой костный язык :p


Автор - Shambala
Дата добавления - 26.07.2019 в 15:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по диапазону имён. Пытаюсь сделать чудо ВПР. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!