Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по двум критериям из разных таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по двум критериям из разных таблиц (Формулы/Formulas)
Суммирование по двум критериям из разных таблиц
OlegKor Дата: Четверг, 11.07.2019, 21:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите составить формулу для нахождения суммы всех участков (ячейка со знаком "?"), которые относятся к задаваемому лицевому счёту (в примере - это лицевой счёт номер 5). Сложность в том, что связь лицевых счетов с номерами участков в одной таблице, а площади участков - в другой (объединять таблицы нельзя). Спасибо)
К сообщению приложен файл: __.xls(28.0 Kb)
 
Ответить
СообщениеПомогите составить формулу для нахождения суммы всех участков (ячейка со знаком "?"), которые относятся к задаваемому лицевому счёту (в примере - это лицевой счёт номер 5). Сложность в том, что связь лицевых счетов с номерами участков в одной таблице, а площади участков - в другой (объединять таблицы нельзя). Спасибо)

Автор - OlegKor
Дата добавления - 11.07.2019 в 21:22
Pelena Дата: Четверг, 11.07.2019, 22:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14216
Репутация: 3106 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант
Код
=СУММПРОИЗВ(H2:H11*ЕЧИСЛО(ПОИСКПОЗ(G2:G11;(D2:D11=A2)*(E2:E11);0)))
К сообщению приложен файл: -2-.xls(28.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант
Код
=СУММПРОИЗВ(H2:H11*ЕЧИСЛО(ПОИСКПОЗ(G2:G11;(D2:D11=A2)*(E2:E11);0)))

Автор - Pelena
Дата добавления - 11.07.2019 в 22:14
OlegKor Дата: Четверг, 11.07.2019, 22:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Фантастика! Спасибо! %) hands
 
Ответить
СообщениеPelena, Фантастика! Спасибо! %) hands

Автор - OlegKor
Дата добавления - 11.07.2019 в 22:36
_Boroda_ Дата: Пятница, 12.07.2019, 10:18 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15401
Репутация: 6031 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(СУММЕСЛИ(G2:G11;(D2:D11=A2)*E2:E11;H2:H11))

Ну и с некоторой натяжкой
Код
=СУММЕСЛИ(D2:D11;A2;H2:H11)
К сообщению приложен файл: -16-1.xls(28.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(СУММЕСЛИ(G2:G11;(D2:D11=A2)*E2:E11;H2:H11))

Ну и с некоторой натяжкой
Код
=СУММЕСЛИ(D2:D11;A2;H2:H11)

Автор - _Boroda_
Дата добавления - 12.07.2019 в 10:18
OlegKor Дата: Пятница, 12.07.2019, 11:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, эта формула наиболее корректно работает
Код
=СУММПРОИЗВ(СУММЕСЛИ(G2:G11;(D2:D11=A2)*E2:E11;H2:H11))

Спасибо!


Сообщение отредактировал OlegKor - Пятница, 12.07.2019, 13:00
 
Ответить
Сообщение_Boroda_, эта формула наиболее корректно работает
Код
=СУММПРОИЗВ(СУММЕСЛИ(G2:G11;(D2:D11=A2)*E2:E11;H2:H11))

Спасибо!

Автор - OlegKor
Дата добавления - 12.07.2019 в 11:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по двум критериям из разных таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!