Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Способы отображения в денежной форме - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Способы отображения в денежной форме (Формулы/Formulas)
Способы отображения в денежной форме
Elhust Дата: Пятница, 12.07.2019, 08:15 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 184
Репутация: -1 ±
Замечаний: 0% ±

Excel 2010
Есть число полученное с помощью формулы например 123,6667
Необходимо чтобы оно отображалось в виде 123 руб. 66 коп.
формула в файле ячейка J23
К сообщению приложен файл: 6072813.xlsx(11.9 Kb)


Каждый сам выбирает правила игры

Сообщение отредактировал Elhust - Пятница, 12.07.2019, 08:16
 
Ответить
СообщениеЕсть число полученное с помощью формулы например 123,6667
Необходимо чтобы оно отображалось в виде 123 руб. 66 коп.
формула в файле ячейка J23

Автор - Elhust
Дата добавления - 12.07.2019 в 08:15
Pelena Дата: Пятница, 12.07.2019, 08:33 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14584
Репутация: 3193 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если немного переделать Вашу формулу, можно так
Код
=ЕСЛИ((I23-ВПР(H23;$D$3:$F$12;2;0))>0;ГПР(H23;$A$16:$K$17;2;0)&" должен тратить по "&ОТБР(ВПР(H23;$D$3:$F$12;3;0)/(I23-ВПР(H23;$D$3:$F$12;2;0)))&" руб. "&ОТБР(ОСТАТ(ВПР(H23;$D$3:$F$12;3;0)/(I23-ВПР(H23;$D$3:$F$12;2;0));1)*100)&" коп. в день";"Дата отъезда не может быть ранее даты заезда")
К сообщению приложен файл: 9739594.xlsx(12.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли немного переделать Вашу формулу, можно так
Код
=ЕСЛИ((I23-ВПР(H23;$D$3:$F$12;2;0))>0;ГПР(H23;$A$16:$K$17;2;0)&" должен тратить по "&ОТБР(ВПР(H23;$D$3:$F$12;3;0)/(I23-ВПР(H23;$D$3:$F$12;2;0)))&" руб. "&ОТБР(ОСТАТ(ВПР(H23;$D$3:$F$12;3;0)/(I23-ВПР(H23;$D$3:$F$12;2;0));1)*100)&" коп. в день";"Дата отъезда не может быть ранее даты заезда")

Автор - Pelena
Дата добавления - 12.07.2019 в 08:33
Elhust Дата: Пятница, 12.07.2019, 09:21 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 184
Репутация: -1 ±
Замечаний: 0% ±

Excel 2010
Pelena, Дааа это на много лаконичней ! Благодарю ! ^_^
Правда я тут заметил еще один вопрос там в зависимости от имени стоит Должен или Должна ...
А и еще то что где 0 копеек отображается только один 0


Каждый сам выбирает правила игры

Сообщение отредактировал Elhust - Пятница, 12.07.2019, 09:30
 
Ответить
СообщениеPelena, Дааа это на много лаконичней ! Благодарю ! ^_^
Правда я тут заметил еще один вопрос там в зависимости от имени стоит Должен или Должна ...
А и еще то что где 0 копеек отображается только один 0

Автор - Elhust
Дата добавления - 12.07.2019 в 09:21
_Boroda_ Дата: Пятница, 12.07.2019, 09:44 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ЕСЛИ(I23>ВПР(H23;$D$3:$F$12;2;);ГПР(H23;$A$16:$K$17;2;)&" долж"&ЕСЛИ(ПРАВБ(ГПР(H23;$A$16:$K$18;3;))="а";"на";"ен")&" тратить по "&ПОДСТАВИТЬ(ТЕКСТ(ВПР(H23;$D$3:$F$12;3;)/(I23-ВПР(H23;$D$3:$F$12;2;));"0руб\. ,00");",";)&" коп. в день";"Дата отъезда не может быть ранее даты заезда")

Кстати, почему у Вас копейки округляются в меньшую сторону? 0,3898 как 0,38
И да, текст немного не соответствует условию. Думаю, что правильнее было бы примерно так
"Дата отъезда должна быть больше даты заезда"
К сообщению приложен файл: 6072813_1.xlsx(12.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ЕСЛИ(I23>ВПР(H23;$D$3:$F$12;2;);ГПР(H23;$A$16:$K$17;2;)&" долж"&ЕСЛИ(ПРАВБ(ГПР(H23;$A$16:$K$18;3;))="а";"на";"ен")&" тратить по "&ПОДСТАВИТЬ(ТЕКСТ(ВПР(H23;$D$3:$F$12;3;)/(I23-ВПР(H23;$D$3:$F$12;2;));"0руб\. ,00");",";)&" коп. в день";"Дата отъезда не может быть ранее даты заезда")

Кстати, почему у Вас копейки округляются в меньшую сторону? 0,3898 как 0,38
И да, текст немного не соответствует условию. Думаю, что правильнее было бы примерно так
"Дата отъезда должна быть больше даты заезда"

Автор - _Boroda_
Дата добавления - 12.07.2019 в 09:44
Elhust Дата: Пятница, 12.07.2019, 10:30 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 184
Репутация: -1 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Как всегда ларчик просто открывался ! ^_^ Благодарю !! и да вы очень точно подметили !! и по поводу копеек и по поводу записи с датой !! буду предельно внимателен ! еще раз Благодарю ! ^_^


Каждый сам выбирает правила игры
 
Ответить
Сообщение_Boroda_, Как всегда ларчик просто открывался ! ^_^ Благодарю !! и да вы очень точно подметили !! и по поводу копеек и по поводу записи с датой !! буду предельно внимателен ! еще раз Благодарю ! ^_^

Автор - Elhust
Дата добавления - 12.07.2019 в 10:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Способы отображения в денежной форме (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!