Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Обработка списка адресов с использованием API Yandex - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обработка списка адресов с использованием API Yandex (Формулы/Formulas)
Обработка списка адресов с использованием API Yandex
zzbear Дата: Понедельник, 15.07.2019, 10:43 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.

Есть массив адресов торговых точек. (54000 строк)
Часть адресов повторяются по несколько раз, но отличаются в написании от простых (лишний пробел, точка с запятой вместо запятой и.т.д) до более значимых различий.

Обрабатывать это все руками нереально.

Можно ли использовать сервисы API Yandex Maps или Google Maps для обработки подобных массивов или посоветуете другой способ обработки?

К сообщению приложен файл: __-.xlsx(10.0 Kb)
 
Ответить
СообщениеДобрый день.

Есть массив адресов торговых точек. (54000 строк)
Часть адресов повторяются по несколько раз, но отличаются в написании от простых (лишний пробел, точка с запятой вместо запятой и.т.д) до более значимых различий.

Обрабатывать это все руками нереально.

Можно ли использовать сервисы API Yandex Maps или Google Maps для обработки подобных массивов или посоветуете другой способ обработки?


Автор - zzbear
Дата добавления - 15.07.2019 в 10:43
_Boroda_ Дата: Понедельник, 15.07.2019, 11:02 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15650
Репутация: 6115 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно сначала все ненужное поубирать
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;",";);".";);";";);":";);" ";);"""";)

А потом найти первое вхождение
Код
=ИНДЕКС([Адрес нп. ул. (необработан)];ПОИСКПОЗ([@Столбец1];[Столбец1];))

И проверить его на повторы
Код
=--ЕЧИСЛО(ПОИСКПОЗ([@Столбец2];D$1:D1;))

Отфильтровать единички и убить
Все это можно в одну формулу написать, но будет тормозить
К сообщению приложен файл: -4-1.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно сначала все ненужное поубирать
Код
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;",";);".";);";";);":";);" ";);"""";)

А потом найти первое вхождение
Код
=ИНДЕКС([Адрес нп. ул. (необработан)];ПОИСКПОЗ([@Столбец1];[Столбец1];))

И проверить его на повторы
Код
=--ЕЧИСЛО(ПОИСКПОЗ([@Столбец2];D$1:D1;))

Отфильтровать единички и убить
Все это можно в одну формулу написать, но будет тормозить

Автор - _Boroda_
Дата добавления - 15.07.2019 в 11:02
zzbear Дата: Понедельник, 15.07.2019, 11:10 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Можно сначала все ненужное поубирать


Спасибо.

Попробую.
 
Ответить
Сообщение
Можно сначала все ненужное поубирать


Спасибо.

Попробую.

Автор - zzbear
Дата добавления - 15.07.2019 в 11:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Обработка списка адресов с использованием API Yandex (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!