Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Превышение вложенности функции ЕСЛИ при сравнении чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Превышение вложенности функции ЕСЛИ при сравнении чисел (Формулы/Formulas)
Превышение вложенности функции ЕСЛИ при сравнении чисел
svetonosniy Дата: Понедельник, 15.07.2019, 15:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Доброго времени суток! Уверен, что тема замылена, но не смог найти нужного мне ответа, все рядом, но все не то. Что требуется - сравнить число (сумма заказа) с числами в табличке и подтянуть нужный коэффициент. В 2003 excel не хватает одного уровня вложенности, чтобы использовать ЕСЛИ. Было бы сравнение на предмет "равно", то использовал бы ВПР. Больше в голову ничего не приходит. Файл приложил, в нем табличка для сравнения, и ячейка, в которой должен показываться нужный коэффициент, подписал ячейку и диапазон, который не входит в формулу. Помогите кто чем может. Очень буду благодарен :)
К сообщению приложен файл: 8364708.xls(19.5 Kb)
 
Ответить
СообщениеДоброго времени суток! Уверен, что тема замылена, но не смог найти нужного мне ответа, все рядом, но все не то. Что требуется - сравнить число (сумма заказа) с числами в табличке и подтянуть нужный коэффициент. В 2003 excel не хватает одного уровня вложенности, чтобы использовать ЕСЛИ. Было бы сравнение на предмет "равно", то использовал бы ВПР. Больше в голову ничего не приходит. Файл приложил, в нем табличка для сравнения, и ячейка, в которой должен показываться нужный коэффициент, подписал ячейку и диапазон, который не входит в формулу. Помогите кто чем может. Очень буду благодарен :)

Автор - svetonosniy
Дата добавления - 15.07.2019 в 15:01
_Boroda_ Дата: Понедельник, 15.07.2019, 15:05 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15577
Репутация: 6078 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сместите данные в С на строку вниз и тогда
Код
=ИНДЕКС(A6:A14;ПОИСКПОЗ(C1;C6:C14))

Код
=ПРОСМОТР(C1;C6:C14;A6:A14)


*
Или сразу по данным
Код
=ПРОСМОТР(C1;--ЛЕВБ(B6:B14;ПОИСК(" ";ПОДСТАВИТЬ(B6:B14;"-";" "))-1);A6:A14)
К сообщению приложен файл: 8364708_3.xls(28.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСместите данные в С на строку вниз и тогда
Код
=ИНДЕКС(A6:A14;ПОИСКПОЗ(C1;C6:C14))

Код
=ПРОСМОТР(C1;C6:C14;A6:A14)


*
Или сразу по данным
Код
=ПРОСМОТР(C1;--ЛЕВБ(B6:B14;ПОИСК(" ";ПОДСТАВИТЬ(B6:B14;"-";" "))-1);A6:A14)

Автор - _Boroda_
Дата добавления - 15.07.2019 в 15:05
svetonosniy Дата: Понедельник, 15.07.2019, 15:14 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, большое спасибо! Очень быстро и в точку. Заработался я походу :)
 
Ответить
Сообщение_Boroda_, большое спасибо! Очень быстро и в точку. Заработался я походу :)

Автор - svetonosniy
Дата добавления - 15.07.2019 в 15:14
svetonosniy Дата: Понедельник, 15.07.2019, 15:21 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, извините, поторопился с выводами, получается не совсем то. В примере 25000 - должен быть коэффициент 1,55, попадающий в диапазон 24000-26999. А результат показывает 1,75
 
Ответить
Сообщение_Boroda_, извините, поторопился с выводами, получается не совсем то. В примере 25000 - должен быть коэффициент 1,55, попадающий в диапазон 24000-26999. А результат показывает 1,75

Автор - svetonosniy
Дата добавления - 15.07.2019 в 15:21
svetonosniy Дата: Понедельник, 15.07.2019, 15:25 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, нет, все же все верно, и правда заработался)) извините и еще раз спасибо
 
Ответить
Сообщение_Boroda_, нет, все же все верно, и правда заработался)) извините и еще раз спасибо

Автор - svetonosniy
Дата добавления - 15.07.2019 в 15:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Превышение вложенности функции ЕСЛИ при сравнении чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!