Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как расставить автосумму в в ячейках - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как расставить автосумму в в ячейках (Формулы/Formulas)
Как расставить автосумму в в ячейках
Fireglow Дата: Четверг, 18.07.2019, 11:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Дана таблица со сгруппированными данными. Жирным выделена сумма нижестоящих цифр. Как вместо статической суммы вставить автоматом формулу во всей таблице, которая будет высчитывать сумму нижестоящих цифр? Так как в табилце необходимо удалять строки с данными и нужно чтобы все автоматом пересчитывалось. таблица большая (представлена часть для примера) и руками каждую строчку менять очень долго. формула типа
Код
СУММ(G10:ИНДЕКС(G10:G4115;ПОИСКПОЗ(1=1;ЕОШ(ПОИСК("??.";D10:D4115));)-1))
не подходит, так как при удалении цифры под жирной суммой формула сбивается.
К сообщению приложен файл: 111111.xls(22.5 Kb)
 
Ответить
СообщениеДана таблица со сгруппированными данными. Жирным выделена сумма нижестоящих цифр. Как вместо статической суммы вставить автоматом формулу во всей таблице, которая будет высчитывать сумму нижестоящих цифр? Так как в табилце необходимо удалять строки с данными и нужно чтобы все автоматом пересчитывалось. таблица большая (представлена часть для примера) и руками каждую строчку менять очень долго. формула типа
Код
СУММ(G10:ИНДЕКС(G10:G4115;ПОИСКПОЗ(1=1;ЕОШ(ПОИСК("??.";D10:D4115));)-1))
не подходит, так как при удалении цифры под жирной суммой формула сбивается.

Автор - Fireglow
Дата добавления - 18.07.2019 в 11:50
Nic70y Дата: Четверг, 18.07.2019, 12:07 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5504
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
я же уже Вам говорил, что таких формул не бывает!
Код
=СУММ(ИНДЕКС(B:B;СТРОКА()+1):ИНДЕКС(B:B;ЕСЛИОШИБКА(ПОИСКПОЗ("*";ИНДЕКС(B:B;СТРОКА()+1):B$65536;)+СТРОКА();65536)))&""
Код
=ТЕКСТ(СУММ(ИНДЕКС(B:B;СТРОКА()+1):ИНДЕКС(B:B;ЕСЛИОШИБКА(ПОИСКПОЗ("*";ИНДЕКС(B:B;СТРОКА()+1):B$65536;)+СТРОКА();65536)));",00")
К сообщению приложен файл: 9711700.xls(37.0 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 18.07.2019, 12:15
 
Ответить
Сообщениея же уже Вам говорил, что таких формул не бывает!
Код
=СУММ(ИНДЕКС(B:B;СТРОКА()+1):ИНДЕКС(B:B;ЕСЛИОШИБКА(ПОИСКПОЗ("*";ИНДЕКС(B:B;СТРОКА()+1):B$65536;)+СТРОКА();65536)))&""
Код
=ТЕКСТ(СУММ(ИНДЕКС(B:B;СТРОКА()+1):ИНДЕКС(B:B;ЕСЛИОШИБКА(ПОИСКПОЗ("*";ИНДЕКС(B:B;СТРОКА()+1):B$65536;)+СТРОКА();65536)));",00")

Автор - Nic70y
Дата добавления - 18.07.2019 в 12:07
bmv98rus Дата: Четверг, 18.07.2019, 12:10 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2453
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
Не нравится мне название темы, а решение есть и не сложное. Ну раз не мне придумывать
Код
=SUM(INDEX(B:B;ROW()+1):INDEX(B:B;ROW()+MATCH(1=1;""=A2:A2000;)-1))
правда массивная.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 18.07.2019, 12:12
 
Ответить
СообщениеНе нравится мне название темы, а решение есть и не сложное. Ну раз не мне придумывать
Код
=SUM(INDEX(B:B;ROW()+1):INDEX(B:B;ROW()+MATCH(1=1;""=A2:A2000;)-1))
правда массивная.

Автор - bmv98rus
Дата добавления - 18.07.2019 в 12:10
_Boroda_ Дата: Четверг, 18.07.2019, 12:45 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММ(ИНДЕКС(B:B;СТРОКА()+1):B9999)-2*СУММЕСЛИ(ИНДЕКС(A:A;СТРОКА()+1):A9999;"";ИНДЕКС(B:B;СТРОКА()+1):B9999)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММ(ИНДЕКС(B:B;СТРОКА()+1):B9999)-2*СУММЕСЛИ(ИНДЕКС(A:A;СТРОКА()+1):A9999;"";ИНДЕКС(B:B;СТРОКА()+1):B9999)

Автор - _Boroda_
Дата добавления - 18.07.2019 в 12:45
Nic70y Дата: Четверг, 18.07.2019, 12:46 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5504
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
не мне придумывать
т.е. медведь заметил...
таки да, Fireglow, переименуйте тему "Сумма до ячейки с жирным шрифтом"
и кстати есть инструмент Промежуточные итоги (Данные - структура)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
не мне придумывать
т.е. медведь заметил...
таки да, Fireglow, переименуйте тему "Сумма до ячейки с жирным шрифтом"
и кстати есть инструмент Промежуточные итоги (Данные - структура)

Автор - Nic70y
Дата добавления - 18.07.2019 в 12:46
bmv98rus Дата: Четверг, 18.07.2019, 13:01 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2453
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
[offtop]
т.е. медведь заметил...
Николай, процент замечаний и подпись обязывает :-) [/offtop]

Сумма до ячейки с жирным шрифтом"

а что с последней суммой делать, там жир пропадает :-)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Четверг, 18.07.2019, 13:02
 
Ответить
Сообщение[offtop]
т.е. медведь заметил...
Николай, процент замечаний и подпись обязывает :-) [/offtop]

Сумма до ячейки с жирным шрифтом"

а что с последней суммой делать, там жир пропадает :-)

Автор - bmv98rus
Дата добавления - 18.07.2019 в 13:01
Fireglow Дата: Четверг, 18.07.2019, 13:04 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
=СУММ(ИНДЕКС(B:B;СТРОКА()+1):ИНДЕКС(B:B;СТРОКА()+ПОИСКПОЗ(1=1;""=A2:A2000;)-1))


спасибо, то что надо
 
Ответить
Сообщение
=СУММ(ИНДЕКС(B:B;СТРОКА()+1):ИНДЕКС(B:B;СТРОКА()+ПОИСКПОЗ(1=1;""=A2:A2000;)-1))


спасибо, то что надо

Автор - Fireglow
Дата добавления - 18.07.2019 в 13:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как расставить автосумму в в ячейках (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!