Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перевод 20-ти значных двоичных чисел в десятичные - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перевод 20-ти значных двоичных чисел в десятичные (Формулы/Formulas)
Перевод 20-ти значных двоичных чисел в десятичные
KoJIbAsKa Дата: Суббота, 20.07.2019, 11:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Мне нужно перевести двоичное число (Например: 10011010011100110001) в десятичное.
 
Ответить
СообщениеМне нужно перевести двоичное число (Например: 10011010011100110001) в десятичное.

Автор - KoJIbAsKa
Дата добавления - 20.07.2019 в 11:25
Nic70y Дата: Суббота, 20.07.2019, 13:06 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5736
Репутация: 1259 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММПРОИЗВ(ПСТР(A1;СТРОКА(1:20);1)*2^(20-СТРОКА(1:20)))


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ПСТР(A1;СТРОКА(1:20);1)*2^(20-СТРОКА(1:20)))

Автор - Nic70y
Дата добавления - 20.07.2019 в 13:06
KoJIbAsKa Дата: Суббота, 20.07.2019, 21:10 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, Спасибо) Формула работает. Но хотел бы узнать можно ли её как нибудь растянуть на столбец?


Сообщение отредактировал KoJIbAsKa - Суббота, 20.07.2019, 21:10
 
Ответить
СообщениеNic70y, Спасибо) Формула работает. Но хотел бы узнать можно ли её как нибудь растянуть на столбец?

Автор - KoJIbAsKa
Дата добавления - 20.07.2019 в 21:10
KoJIbAsKa Дата: Суббота, 20.07.2019, 21:13 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, а хотя уже не нужно) 5 секунд гугла и нашел ответ)))
 
Ответить
СообщениеNic70y, а хотя уже не нужно) 5 секунд гугла и нашел ответ)))

Автор - KoJIbAsKa
Дата добавления - 20.07.2019 в 21:13
Светлый Дата: Воскресенье, 21.07.2019, 11:54 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1369
Репутация: 364 ±
Замечаний: 0% ±

Excel 2010, 2013
Если офис поновее, то можно:
Код
=ДЕС(A1;2)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕсли офис поновее, то можно:
Код
=ДЕС(A1;2)

Автор - Светлый
Дата добавления - 21.07.2019 в 11:54
Nic70y Дата: Воскресенье, 21.07.2019, 20:11 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5736
Репутация: 1259 ±
Замечаний: 0% ±

ru13;10;03
[offtop]точно.
на работе 2010, 2003 :)
2013 доиа,
с дома в последне времч почти не пишу :D [/offtop]


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Воскресенье, 21.07.2019, 20:16
 
Ответить
Сообщение[offtop]точно.
на работе 2010, 2003 :)
2013 доиа,
с дома в последне времч почти не пишу :D [/offtop]

Автор - Nic70y
Дата добавления - 21.07.2019 в 20:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перевод 20-ти значных двоичных чисел в десятичные (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!