Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соответствие ключевого слова из списка ключ слов - фразе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соответствие ключевого слова из списка ключ слов - фразе (Формулы/Formulas)
Соответствие ключевого слова из списка ключ слов - фразе
serg52 Дата: Понедельник, 22.07.2019, 12:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! Необходимо структурировать данные, для дальнейшей работы с ними.
Мой уровень работы в эксель не позволяет мне решить данную задачу, видимо слишком сложная логика, если такие задачи вообще решаемы!
Есть список типов помещений, необходимо сравнить 1 позицию из этого списка, со списком ключевых слов и при совпадении кл слова , вывести это ключевое слово, рядом с позицией 1, если не найдено: сообщение"НЕТ ТАКОГО", а при условии что найдется более одного ключ слова, сообщение типа "ДУБЛЬ".
В принципе, я буду счастлив, если есть возможность реализовать хотя бы вывод найденного ключевого слова.
Это делается для того, что бы можно было видеть правильно ли подобрано ключ слово и присутствует ли оно вообще в списке кл слов.
Пример прилагаю.
Помогите!!!
К сообщению приложен файл: _2.xls(35.5 Kb)
 
Ответить
СообщениеЗдравствуйте! Необходимо структурировать данные, для дальнейшей работы с ними.
Мой уровень работы в эксель не позволяет мне решить данную задачу, видимо слишком сложная логика, если такие задачи вообще решаемы!
Есть список типов помещений, необходимо сравнить 1 позицию из этого списка, со списком ключевых слов и при совпадении кл слова , вывести это ключевое слово, рядом с позицией 1, если не найдено: сообщение"НЕТ ТАКОГО", а при условии что найдется более одного ключ слова, сообщение типа "ДУБЛЬ".
В принципе, я буду счастлив, если есть возможность реализовать хотя бы вывод найденного ключевого слова.
Это делается для того, что бы можно было видеть правильно ли подобрано ключ слово и присутствует ли оно вообще в списке кл слов.
Пример прилагаю.
Помогите!!!

Автор - serg52
Дата добавления - 22.07.2019 в 12:41
_Boroda_ Дата: Понедельник, 22.07.2019, 13:56 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ТЕКСТ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))-2;"\ДУБЛЬ;"""&ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$57;B2);F$2:F$57);"НЕТ")&"""")

Или по-простому
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))>1;"ДУБЛЬ";ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$57;B2);F$2:F$57);"НЕТ"))
К сообщению приложен файл: _2-11-1.xls(42.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ТЕКСТ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))-2;"\ДУБЛЬ;"""&ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$57;B2);F$2:F$57);"НЕТ")&"""")

Или по-простому
Код
=ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))>1;"ДУБЛЬ";ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$57;B2);F$2:F$57);"НЕТ"))

Автор - _Boroda_
Дата добавления - 22.07.2019 в 13:56
serg52 Дата: Понедельник, 22.07.2019, 14:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, спасибо огромное! Прям камень с плеч = ) Просто круть! Правда появилась новая неувязка. Если я буду использовать слово со склонением или повторяющейся частью, то получаю "ДУБЛЬ". В общем сдублем я погорячился (
Не будете ли вы так любезны, скорректировать формулу так, что бы вместо надписи ДУБЛЬ, появлялось самое близкое по значению из найденных ключевых слов или ходя бы просто первое найденное, но скажем со звездочкой, что бы я понимал, что это дубль.
Плизззз......
 
Ответить
Сообщение_Boroda_, спасибо огромное! Прям камень с плеч = ) Просто круть! Правда появилась новая неувязка. Если я буду использовать слово со склонением или повторяющейся частью, то получаю "ДУБЛЬ". В общем сдублем я погорячился (
Не будете ли вы так любезны, скорректировать формулу так, что бы вместо надписи ДУБЛЬ, появлялось самое близкое по значению из найденных ключевых слов или ходя бы просто первое найденное, но скажем со звездочкой, что бы я понимал, что это дубль.
Плизззз......

Автор - serg52
Дата добавления - 22.07.2019 в 14:31
_Boroda_ Дата: Понедельник, 22.07.2019, 14:38 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$57;B2);F$2:F$57)&ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))>1;"*";"");"НЕТ")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(F$2:F$57;B2);F$2:F$57)&ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))>1;"*";"");"НЕТ")

Автор - _Boroda_
Дата добавления - 22.07.2019 в 14:38
serg52 Дата: Понедельник, 22.07.2019, 15:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, класс!!! Только я не пойму следующую картину. Если обратить внимание на блок операционных, с 12 по 17 строки, то выбор идет не по первому ключевому слову в списке "Опер", а по последующим. То есть позиции-"Операционная хирургическая", соответствует "хирург", а не "опер". Это как то решаемо или это уже особенность поиска эксель? Странно то, что во первых ОПЕР- первое слово и в списке и в фразе, да еще и в 17 строке "Операционная хирургическая" оно оказалось не в приоритете. ОПЕР явно где то между ХИРУРГ и ГИНЕКОЛОГ, ан нет....
Алгоритм поиска непонятен (
И еще такая картина: если я добавляю ОПЕРАЦ, в ключ слова, после ХИРУРГ и ГИНЕКОЛОГ, то оно становится приоритетным и все становится типа правильным, но если я напечатаю его в конце списка кл слов, то у меня все предоперационные определяются как операционные (
Это как то лечится или то , что Вы выше пишите - это самый лучший вариант решения данной задачи?
 
Ответить
Сообщение_Boroda_, класс!!! Только я не пойму следующую картину. Если обратить внимание на блок операционных, с 12 по 17 строки, то выбор идет не по первому ключевому слову в списке "Опер", а по последующим. То есть позиции-"Операционная хирургическая", соответствует "хирург", а не "опер". Это как то решаемо или это уже особенность поиска эксель? Странно то, что во первых ОПЕР- первое слово и в списке и в фразе, да еще и в 17 строке "Операционная хирургическая" оно оказалось не в приоритете. ОПЕР явно где то между ХИРУРГ и ГИНЕКОЛОГ, ан нет....
Алгоритм поиска непонятен (
И еще такая картина: если я добавляю ОПЕРАЦ, в ключ слова, после ХИРУРГ и ГИНЕКОЛОГ, то оно становится приоритетным и все становится типа правильным, но если я напечатаю его в конце списка кл слов, то у меня все предоперационные определяются как операционные (
Это как то лечится или то , что Вы выше пишите - это самый лучший вариант решения данной задачи?

Автор - serg52
Дата добавления - 22.07.2019 в 15:20
_Boroda_ Дата: Понедельник, 22.07.2019, 15:30 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Алгоритм как раз понятен - ПРОСМОТР выводит последнее совпадение
Код
=ЕСЛИОШИБКА(ИНДЕКС(F$2:F$57;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$2:F$57;B2));E$2:E$57)))&ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))>1;"*";"");"НЕТ")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: _2-11-2.xls(50.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАлгоритм как раз понятен - ПРОСМОТР выводит последнее совпадение
Код
=ЕСЛИОШИБКА(ИНДЕКС(F$2:F$57;МИН(ЕСЛИ(ЕЧИСЛО(ПОИСК(F$2:F$57;B2));E$2:E$57)))&ЕСЛИ(СУММПРОИЗВ(СЧЁТЕСЛИ(B2;"*"&F$2:F$57&"*"))>1;"*";"");"НЕТ")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 22.07.2019 в 15:30
serg52 Дата: Понедельник, 22.07.2019, 15:42 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, КРУТО!!!! Все работает! Это просто я валенок , не знал, что это формула массива!!!
 
Ответить
Сообщение_Boroda_, КРУТО!!!! Все работает! Это просто я валенок , не знал, что это формула массива!!!

Автор - serg52
Дата добавления - 22.07.2019 в 15:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соответствие ключевого слова из списка ключ слов - фразе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!