Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Собрать в 1 список все значения из таблицы ниже диагонали - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Собрать в 1 список все значения из таблицы ниже диагонали (Формулы/Formulas)
Собрать в 1 список все значения из таблицы ниже диагонали
Ирусик Дата: Пятница, 26.07.2019, 10:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Мне нужно собрать в 1 список все ячейки ниже диагонали в таблице. ТАблица представляет собой квадратный массив, по вертикали идут "диваны тип1, Диваны тип2, Диваны тип3 и т.д., по горизонтали Тип1, тип2, тип3 и т.д. Мне надо собрать варианты их комбинаций между собой. Сцепить я смогла, а вот теперь надо собрать неповторяющиеся вида ДИван Тип 1 + Тип 2 и т.д.. По диагонали стоят Диван Тип1 тип1 и т.д, выше диагонали повторы. Они с другим порядком вхождения, но это неважно.
Как можно собрать значения? Я попробовала искать по темам, не нашла, к сожалению. ТАблицу прилагаю.
К сообщению приложен файл: ___19.xlsx(36.1 Kb)
 
Ответить
СообщениеДобрый день! Мне нужно собрать в 1 список все ячейки ниже диагонали в таблице. ТАблица представляет собой квадратный массив, по вертикали идут "диваны тип1, Диваны тип2, Диваны тип3 и т.д., по горизонтали Тип1, тип2, тип3 и т.д. Мне надо собрать варианты их комбинаций между собой. Сцепить я смогла, а вот теперь надо собрать неповторяющиеся вида ДИван Тип 1 + Тип 2 и т.д.. По диагонали стоят Диван Тип1 тип1 и т.д, выше диагонали повторы. Они с другим порядком вхождения, но это неважно.
Как можно собрать значения? Я попробовала искать по темам, не нашла, к сожалению. ТАблицу прилагаю.

Автор - Ирусик
Дата добавления - 26.07.2019 в 10:48
Светлый Дата: Пятница, 26.07.2019, 11:09 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1197
Репутация: 307 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Как вариант, в A93 занести массивную формулу (Ctrl+Shift+Enter):
Код
=ИНДЕКС($1:$90;ПРАВБ(МИН(ЕСЛИ(СЧЁТЕСЛИ(A$92:A92;B$2:CL$90)=0;СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100));2);МИН(ЕСЛИ(СЧЁТЕСЛИ(A$92:A92;B$2:CL$90)=0;СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100))/100)
и протянуть её вниз. Повторений не будет.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 26.07.2019, 11:15
 
Ответить
СообщениеДобрый день!
Как вариант, в A93 занести массивную формулу (Ctrl+Shift+Enter):
Код
=ИНДЕКС($1:$90;ПРАВБ(МИН(ЕСЛИ(СЧЁТЕСЛИ(A$92:A92;B$2:CL$90)=0;СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100));2);МИН(ЕСЛИ(СЧЁТЕСЛИ(A$92:A92;B$2:CL$90)=0;СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100))/100)
и протянуть её вниз. Повторений не будет.

Автор - Светлый
Дата добавления - 26.07.2019 в 11:09
Ирусик Дата: Пятница, 26.07.2019, 11:17 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Извините за вопрос чайника, а в чем особенность "занести массивную формулу"? НАдо сначала нажать Ctrl+Shift+Enter, а потом вводить? или как-то по-другому?
простой ввод формулы в А93 и протягивание дает одно и то же значение в ячейках "диваны трансформеры трансформеры"
 
Ответить
СообщениеИзвините за вопрос чайника, а в чем особенность "занести массивную формулу"? НАдо сначала нажать Ctrl+Shift+Enter, а потом вводить? или как-то по-другому?
простой ввод формулы в А93 и протягивание дает одно и то же значение в ячейках "диваны трансформеры трансформеры"

Автор - Ирусик
Дата добавления - 26.07.2019 в 11:17
китин Дата: Пятница, 26.07.2019, 11:24 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5730
Репутация: 903 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ввести формулу и в режиме редактирования( или щелкнуть мышой в строке формул) нажать Ctrl+Shift+Enter


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеввести формулу и в режиме редактирования( или щелкнуть мышой в строке формул) нажать Ctrl+Shift+Enter

Автор - китин
Дата добавления - 26.07.2019 в 11:24
Светлый Дата: Пятница, 26.07.2019, 11:47 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1197
Репутация: 307 ±
Замечаний: 0% ±

Excel 2010
Можно в таблице записать формулу:
Код
=ЕСЛИ(СТОЛБЕЦ()<=СТРОКА();СЦЕПИТЬ($A2;B$1);"")
а в любой столбец с протяжкой вниз записать массивную формулу:
Код
=ИНДЕКС($1:$90;ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(B$2:CL$90>"";СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100);СТРОКА(B1));2);НАИМЕНЬШИЙ(ЕСЛИ(B$2:CL$90>"";СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100);СТРОКА(B1))/100)
*А можно вообще таблицу не заполнять, а использовать только заголовки таблицы:
Код
=ИНДЕКС(A:A;ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(СТОЛБЕЦ(B:CL)<=СТРОКА($2:$90);СТОЛБЕЦ(B:CL)*100+СТРОКА($2:$90));СТРОКА(B1));2))&ИНДЕКС($1:$1;;НАИМЕНЬШИЙ(ЕСЛИ(СТОЛБЕЦ(B:CL)<=СТРОКА($2:$90);СТОЛБЕЦ(B:CL)*100+СТРОКА($2:$90));СТРОКА(B1))/100)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 26.07.2019, 12:03
 
Ответить
СообщениеМожно в таблице записать формулу:
Код
=ЕСЛИ(СТОЛБЕЦ()<=СТРОКА();СЦЕПИТЬ($A2;B$1);"")
а в любой столбец с протяжкой вниз записать массивную формулу:
Код
=ИНДЕКС($1:$90;ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(B$2:CL$90>"";СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100);СТРОКА(B1));2);НАИМЕНЬШИЙ(ЕСЛИ(B$2:CL$90>"";СТРОКА($2:$90)+СТОЛБЕЦ(B:CL)*100);СТРОКА(B1))/100)
*А можно вообще таблицу не заполнять, а использовать только заголовки таблицы:
Код
=ИНДЕКС(A:A;ПРАВБ(НАИМЕНЬШИЙ(ЕСЛИ(СТОЛБЕЦ(B:CL)<=СТРОКА($2:$90);СТОЛБЕЦ(B:CL)*100+СТРОКА($2:$90));СТРОКА(B1));2))&ИНДЕКС($1:$1;;НАИМЕНЬШИЙ(ЕСЛИ(СТОЛБЕЦ(B:CL)<=СТРОКА($2:$90);СТОЛБЕЦ(B:CL)*100+СТРОКА($2:$90));СТРОКА(B1))/100)

Автор - Светлый
Дата добавления - 26.07.2019 в 11:47
Ирусик Дата: Пятница, 26.07.2019, 12:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Дааааа! По второму варианту все получилось сразу. Спасибо Вам огромное!!!
 
Ответить
СообщениеДааааа! По второму варианту все получилось сразу. Спасибо Вам огромное!!!

Автор - Ирусик
Дата добавления - 26.07.2019 в 12:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Собрать в 1 список все значения из таблицы ниже диагонали (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!