Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Список по порядку без пробелов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Список по порядку без пробелов (Формулы/Formulas)
Список по порядку без пробелов
Leem Дата: Понедельник, 29.07.2019, 07:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья.
Ситуация следующая: Имеется 2 списка: СМЕНА 1 и СМЕНА 2
в столбце промежуточный появляются те фамилии, что есть в двух первых списках.
НО появляются они в строках с пробелами а нужно чтобы они шли по порядку без пробелов.
Надеюсь, объяснил понятно (что вряд ли) файл вложил
Благодарю
К сообщению приложен файл: try.xlsx(10.8 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья.
Ситуация следующая: Имеется 2 списка: СМЕНА 1 и СМЕНА 2
в столбце промежуточный появляются те фамилии, что есть в двух первых списках.
НО появляются они в строках с пробелами а нужно чтобы они шли по порядку без пробелов.
Надеюсь, объяснил понятно (что вряд ли) файл вложил
Благодарю

Автор - Leem
Дата добавления - 29.07.2019 в 07:57
Светлый Дата: Понедельник, 29.07.2019, 08:46 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 309 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Формула массива (Ctrl+Shift+Enter):
Код
=ПОДСТАВИТЬ(ИНДЕКС(B:B;МИН(ЕСЛИ(СЧЁТЕСЛИ(C:C;B$2:B$10)*(СЧЁТЕСЛИ(A$1:A1;B$2:B$10)=0);СТРОКА($2:$10))));B$1;)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Формула массива (Ctrl+Shift+Enter):
Код
=ПОДСТАВИТЬ(ИНДЕКС(B:B;МИН(ЕСЛИ(СЧЁТЕСЛИ(C:C;B$2:B$10)*(СЧЁТЕСЛИ(A$1:A1;B$2:B$10)=0);СТРОКА($2:$10))));B$1;)

Автор - Светлый
Дата добавления - 29.07.2019 в 08:46
Nic70y Дата: Понедельник, 29.07.2019, 08:50 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5518
Репутация: 1202 ±
Замечаний: 0% ±

ru13;10;03
еще вариант
Цитата Светлый, 29.07.2019 в 08:46, в сообщении № 2 ()
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(B$2:B$50;C$2:C$50;));СТРОКА(B$2:B$50));СТРОКА(A1)));"")


ЯД(poison) 41001841029809
 
Ответить
Сообщениееще вариант
Цитата Светлый, 29.07.2019 в 08:46, в сообщении № 2 ()
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(B$2:B$50;C$2:C$50;));СТРОКА(B$2:B$50));СТРОКА(A1)));"")

Автор - Nic70y
Дата добавления - 29.07.2019 в 08:50
Светлый Дата: Понедельник, 29.07.2019, 13:34 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 309 ±
Замечаний: 0% ±

Excel 2010
еще вариант
Могут быть повторения, но в задании это не оговорено.
Вариант уникальных простой формулой, но в обратном порядке:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9;1/(СЧЁТЕСЛИ(A$1:A1;B$2:B$9)=0)/СЧЁТЕСЛИ(C:C;B$2:B$9);B$2:B$9);"")


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
еще вариант
Могут быть повторения, но в задании это не оговорено.
Вариант уникальных простой формулой, но в обратном порядке:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9;1/(СЧЁТЕСЛИ(A$1:A1;B$2:B$9)=0)/СЧЁТЕСЛИ(C:C;B$2:B$9);B$2:B$9);"")

Автор - Светлый
Дата добавления - 29.07.2019 в 13:34
Leem Дата: Вторник, 30.07.2019, 08:03 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 29.07.2019 в 13:34, в сообщении № 4 ()
Вариант уникальных простой формулой, но в обратном порядке:

Уважаемый, Светлый А что в этой формуле отвечает на обратный порядок? ЕЕ можно развернуть в другой?


Ктулху всех спасет
 
Ответить
Сообщение
Цитата Светлый, 29.07.2019 в 13:34, в сообщении № 4 ()
Вариант уникальных простой формулой, но в обратном порядке:

Уважаемый, Светлый А что в этой формуле отвечает на обратный порядок? ЕЕ можно развернуть в другой?

Автор - Leem
Дата добавления - 30.07.2019 в 08:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Список по порядку без пробелов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!