Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение массива даты и числа. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение массива даты и числа. (Формулы/Formulas)
Сложение массива даты и числа.
bondik Дата: Понедельник, 29.07.2019, 13:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго всем дня,
Вот такой пример:
31.07.2019
100 000
25.07.2019
50 000

Необходимо прописать Формулу автосложения чтобы вышло 150 000, у меня даты так же складываются, и выдают 211 518,89
для СУММАЕСЛИ не подберу Критерий

Может кто поделится опытом?

Спасибо!
 
Ответить
СообщениеДоброго всем дня,
Вот такой пример:
31.07.2019
100 000
25.07.2019
50 000

Необходимо прописать Формулу автосложения чтобы вышло 150 000, у меня даты так же складываются, и выдают 211 518,89
для СУММАЕСЛИ не подберу Критерий

Может кто поделится опытом?

Спасибо!

Автор - bondik
Дата добавления - 29.07.2019 в 13:20
Nic70y Дата: Понедельник, 29.07.2019, 13:34 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5734
Репутация: 1259 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММПРОИЗВ(ОСТАТ(СТРОКА(A1:A4)-1;2)*A1:A4)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ОСТАТ(СТРОКА(A1:A4)-1;2)*A1:A4)

Автор - Nic70y
Дата добавления - 29.07.2019 в 13:34
bmv98rus Дата: Понедельник, 29.07.2019, 13:39 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2790
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
bondik, Поумайте над названием темы, ну Вам же не сложить надо а наоборот отделить мух от котлет. Файл пример нужен, и описание всегда ли так идут строки.
Критерия для SUMIFS(s) не будет, точнее не будет такого, который гарантированно определит что нужно суммировать.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеbondik, Поумайте над названием темы, ну Вам же не сложить надо а наоборот отделить мух от котлет. Файл пример нужен, и описание всегда ли так идут строки.
Критерия для SUMIFS(s) не будет, точнее не будет такого, который гарантированно определит что нужно суммировать.

Автор - bmv98rus
Дата добавления - 29.07.2019 в 13:39
bondik Дата: Понедельник, 29.07.2019, 13:45 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Спасибо огромное
 
Ответить
СообщениеNic70y, Спасибо огромное

Автор - bondik
Дата добавления - 29.07.2019 в 13:45
Светлый Дата: Понедельник, 29.07.2019, 13:45 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1368
Репутация: 363 ±
Замечаний: 0% ±

Excel 2010, 2013
Ну и мой вариант до кучи:
Код
=СУММПРОИЗВ(ЕЧЁТН(СТРОКА(1:4))*A1:A4)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНу и мой вариант до кучи:
Код
=СУММПРОИЗВ(ЕЧЁТН(СТРОКА(1:4))*A1:A4)

Автор - Светлый
Дата добавления - 29.07.2019 в 13:45
bondik Дата: Понедельник, 29.07.2019, 13:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
bmv98rus, Добрый день, Да, Вы правы! Вот файл пример.
К сообщению приложен файл: 7332487.xlsx(9.2 Kb)
 
Ответить
Сообщениеbmv98rus, Добрый день, Да, Вы правы! Вот файл пример.

Автор - bondik
Дата добавления - 29.07.2019 в 13:47
bondik Дата: Понедельник, 29.07.2019, 13:50 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Светлый, Спасибо!
 
Ответить
СообщениеСветлый, Спасибо!

Автор - bondik
Дата добавления - 29.07.2019 в 13:50
bondik Дата: Понедельник, 29.07.2019, 14:04 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Получается что принцип не действует, по мимо значение:
31.07.2019
100 000
25.07.2019
50 000
данные могут идти и так:
31.07.2019
100 000
25.07.2019
50 000
20 000

10 000
25.07.2019
50 000
bmv98rus прав, тут нужно как то отделить хаотичные числовые ячейки от дата-ячеек в столбики, это вообще возможно?
 
Ответить
СообщениеПолучается что принцип не действует, по мимо значение:
31.07.2019
100 000
25.07.2019
50 000
данные могут идти и так:
31.07.2019
100 000
25.07.2019
50 000
20 000

10 000
25.07.2019
50 000
bmv98rus прав, тут нужно как то отделить хаотичные числовые ячейки от дата-ячеек в столбики, это вообще возможно?

Автор - bondik
Дата добавления - 29.07.2019 в 14:04
bmv98rus Дата: Понедельник, 29.07.2019, 14:21 | Сообщение № 9
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2790
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUM(SUMIF(B1:B9;{"<01.01.2019";">=01.01.2020"}))
при условии что не будет значений между 43 466 и 43 831


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=SUM(SUMIF(B1:B9;{"<01.01.2019";">=01.01.2020"}))
при условии что не будет значений между 43 466 и 43 831

Автор - bmv98rus
Дата добавления - 29.07.2019 в 14:21
Светлый Дата: Понедельник, 29.07.2019, 14:39 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1368
Репутация: 363 ±
Замечаний: 0% ±

Excel 2010, 2013
С некоторыми ограничениями:
Код
=СУММПРОИЗВ((ГОД(A1:A33)<>2019)*A1:A33)
, как и у bmv98rus


Программировать проще, чем писать стихи.
 
Ответить
СообщениеС некоторыми ограничениями:
Код
=СУММПРОИЗВ((ГОД(A1:A33)<>2019)*A1:A33)
, как и у bmv98rus

Автор - Светлый
Дата добавления - 29.07.2019 в 14:39
bondik Дата: Понедельник, 29.07.2019, 15:38 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо!, тестирую.
 
Ответить
СообщениеСпасибо!, тестирую.

Автор - bondik
Дата добавления - 29.07.2019 в 15:38
_Boroda_ Дата: Понедельник, 29.07.2019, 16:14 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15650
Репутация: 6115 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ((ЯЧЕЙКА("формат";СМЕЩ(A1;Ч(ИНДЕКС(СТРОКА(A1:A20)-1;));))<>"D1")*A1:A20)

Условие - даты типа "25.07.2019" должны быть в формате дат
К сообщению приложен файл: 89427865.xlsm(8.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ((ЯЧЕЙКА("формат";СМЕЩ(A1;Ч(ИНДЕКС(СТРОКА(A1:A20)-1;));))<>"D1")*A1:A20)

Условие - даты типа "25.07.2019" должны быть в формате дат

Автор - _Boroda_
Дата добавления - 29.07.2019 в 16:14
bmv98rus Дата: Понедельник, 29.07.2019, 16:43 | Сообщение № 13
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2790
Репутация: 479 ±
Замечаний: 0% ±

Excel 2013/2016
_Boroda_, Александр, думаю можно чуть универсальнее, если сравнивать с D и только первый символ.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение_Boroda_, Александр, думаю можно чуть универсальнее, если сравнивать с D и только первый символ.

Автор - bmv98rus
Дата добавления - 29.07.2019 в 16:43
_Boroda_ Дата: Понедельник, 29.07.2019, 17:00 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15650
Репутация: 6115 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно

Автор - _Boroda_
Дата добавления - 29.07.2019 в 17:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение массива даты и числа. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!