Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сцепить+ВПР (поиск по 1 критерию и сцепка данных) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить+ВПР (поиск по 1 критерию и сцепка данных) (Формулы/Formulas)
Сцепить+ВПР (поиск по 1 критерию и сцепка данных)
h1dex Дата: Вторник, 06.08.2019, 01:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
добрый день!

во вложении файл..в столбце C в 1 листе нужно ввести формулу которая будет искать фамилию со 2 листа т.е. нужно узнать какие люди брали гайку с номером 010-020 с таблицы 2 листа..обычная формула впр просто вытягивает 1 значения из списка..а нужно так чтобы указывались все кто брал т.е. в 1 листе в столбце C должно быть написано Иванов И.;Андреев Е.;Ионов О.

я нашёл формулу для суммирования количества..а как сделать с текстовыми данными?
К сообщению приложен файл: 3668672.xlsx(9.1 Kb)
 
Ответить
Сообщениедобрый день!

во вложении файл..в столбце C в 1 листе нужно ввести формулу которая будет искать фамилию со 2 листа т.е. нужно узнать какие люди брали гайку с номером 010-020 с таблицы 2 листа..обычная формула впр просто вытягивает 1 значения из списка..а нужно так чтобы указывались все кто брал т.е. в 1 листе в столбце C должно быть написано Иванов И.;Андреев Е.;Ионов О.

я нашёл формулу для суммирования количества..а как сделать с текстовыми данными?

Автор - h1dex
Дата добавления - 06.08.2019 в 01:06
Che79 Дата: Вторник, 06.08.2019, 01:39 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
Здравствуйте.
Вариант решения сводной таблицей (на листе 1). Вдруг подойдет?
К сообщению приложен файл: 3668672_1.xlsx(91.3 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Вариант решения сводной таблицей (на листе 1). Вдруг подойдет?

Автор - Che79
Дата добавления - 06.08.2019 в 01:39
h1dex Дата: Вторник, 06.08.2019, 01:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо..но это не то..мне нужно чтобы это было реализованно формулой..и вписывалось в 1 ячейку т.е. так:

номер описание фамилия
010-020 гайка Иванов И.;Андреев Е.;Ионов О.
 
Ответить
Сообщениеспасибо..но это не то..мне нужно чтобы это было реализованно формулой..и вписывалось в 1 ячейку т.е. так:

номер описание фамилия
010-020 гайка Иванов И.;Андреев Е.;Ионов О.

Автор - h1dex
Дата добавления - 06.08.2019 в 01:52
Che79 Дата: Вторник, 06.08.2019, 02:38 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
h1dex, тогда вот Вам функция, определенная пользователемСцепитьЕсли Автор - Дмитрий Щербаков. В Вашем случае
Код
=СцепитьЕсли(Лист2!B:B;B2;Лист2!C:C;", ";)
Желтые ячейки в приложенном файле. Макросы должны быть разрешены.
К сообщению приложен файл: 3668672_2.xlsm(21.3 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениеh1dex, тогда вот Вам функция, определенная пользователемСцепитьЕсли Автор - Дмитрий Щербаков. В Вашем случае
Код
=СцепитьЕсли(Лист2!B:B;B2;Лист2!C:C;", ";)
Желтые ячейки в приложенном файле. Макросы должны быть разрешены.

Автор - Che79
Дата добавления - 06.08.2019 в 02:38
h1dex Дата: Вторник, 06.08.2019, 02:49 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо большое..а без макросов это никак нельзя сделать?
 
Ответить
Сообщениеспасибо большое..а без макросов это никак нельзя сделать?

Автор - h1dex
Дата добавления - 06.08.2019 в 02:49
Nic70y Дата: Вторник, 06.08.2019, 08:18 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5505
Репутация: 1197 ±
Замечаний: 0% ±

ru13;10;03
без макросов
установить более свежую версию.
вариант с допами:
на листе2 в D
Код
=C2&ЕСЛИОШИБКА(", "&ВПР(A2;A3:D$18999;4;);"")
и "по нему"
Код
=ЕСЛИОШИБКА(ВПР(A2;Лист2!A:D;4;);"")
К сообщению приложен файл: 8545727.xlsx(9.9 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
без макросов
установить более свежую версию.
вариант с допами:
на листе2 в D
Код
=C2&ЕСЛИОШИБКА(", "&ВПР(A2;A3:D$18999;4;);"")
и "по нему"
Код
=ЕСЛИОШИБКА(ВПР(A2;Лист2!A:D;4;);"")

Автор - Nic70y
Дата добавления - 06.08.2019 в 08:18
bmv98rus Дата: Вторник, 06.08.2019, 09:51 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 2454
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
установить более свежую версию.
и не просто свежую, а последнюю :-(

А нужно ли все в оду ячейку? Может так пойдет?
К сообщению приложен файл: Copy_of_1071.xlsx(17.0 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
установить более свежую версию.
и не просто свежую, а последнюю :-(

А нужно ли все в оду ячейку? Может так пойдет?

Автор - bmv98rus
Дата добавления - 06.08.2019 в 09:51
h1dex Дата: Вторник, 06.08.2019, 22:36 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
А нужно ли все в оду ячейку? Может так пойдет?


спасибо..но нужно в 1 ячейку :)
 
Ответить
Сообщение
А нужно ли все в оду ячейку? Может так пойдет?


спасибо..но нужно в 1 ячейку :)

Автор - h1dex
Дата добавления - 06.08.2019 в 22:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить+ВПР (поиск по 1 критерию и сцепка данных) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!