Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как связать ID должности и формулу расчета премии? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как связать ID должности и формулу расчета премии? (Формулы/Formulas)
Как связать ID должности и формулу расчета премии?
Bor109 Дата: Среда, 07.08.2019, 18:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Прошу прощения, если подобный вопрос рассматривался. Поиском ничего не нашлось. Наверное, потому что особо не знаю, что конкретно искать.
Каждый месяц организация выплачивает премию. Расчет премии по формуле, в которой два переменных показателя - расчетная база (оклад по дням) и процент выполнения КПЭ. И два постоянных показателя - минимальный процент выполнения КПЭ и процент премии от расчетной базы. Переменные показатели в отдельных ячейках, постоянные вписаны в формулу, но они не одинаковые для всех сотрудников организации.
Каждый месяц список сотрудников (более 700 чел) изменяется. Сейчас я вручную правлю список, подставляя каждому новому сотруднику нужную формулу с условиями по его должности. Неудобно, долго, чревато ошибками.
Можно ли связать ID должности и формулу расчета премии? С учетом того, что список сотрудников по составу ежемесячно изменяется. ID соответствует должности(ставке). В течении месяца может быть несколько человек с одинаковым ID должности ( в случае приемов, переводов и т.д.)
Возможно ли подтянуть именно формулу через ВПР? или как-то по другому действовать нужно? В идеале, нужно минимальными усилиями из файла вида ID - ФИО - Расчетная база - Процент выполнения КПЭ получить файл вида ID - ФИО - Расчетная база - Процент выполнения КПЭ - Сумма премирования.
Спасибо за любую помощь или направление для поиска решения!
К сообщению приложен файл: 7248907.xlsx(9.7 Kb)


Сообщение отредактировал Bor109 - Среда, 07.08.2019, 18:12
 
Ответить
СообщениеДобрый день! Прошу прощения, если подобный вопрос рассматривался. Поиском ничего не нашлось. Наверное, потому что особо не знаю, что конкретно искать.
Каждый месяц организация выплачивает премию. Расчет премии по формуле, в которой два переменных показателя - расчетная база (оклад по дням) и процент выполнения КПЭ. И два постоянных показателя - минимальный процент выполнения КПЭ и процент премии от расчетной базы. Переменные показатели в отдельных ячейках, постоянные вписаны в формулу, но они не одинаковые для всех сотрудников организации.
Каждый месяц список сотрудников (более 700 чел) изменяется. Сейчас я вручную правлю список, подставляя каждому новому сотруднику нужную формулу с условиями по его должности. Неудобно, долго, чревато ошибками.
Можно ли связать ID должности и формулу расчета премии? С учетом того, что список сотрудников по составу ежемесячно изменяется. ID соответствует должности(ставке). В течении месяца может быть несколько человек с одинаковым ID должности ( в случае приемов, переводов и т.д.)
Возможно ли подтянуть именно формулу через ВПР? или как-то по другому действовать нужно? В идеале, нужно минимальными усилиями из файла вида ID - ФИО - Расчетная база - Процент выполнения КПЭ получить файл вида ID - ФИО - Расчетная база - Процент выполнения КПЭ - Сумма премирования.
Спасибо за любую помощь или направление для поиска решения!

Автор - Bor109
Дата добавления - 07.08.2019 в 18:11
Pelena Дата: Среда, 07.08.2019, 19:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14585
Репутация: 3196 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если правильно поняла
Код
=ЕСЛИ(D2>=ВПР(A2;$L$2:$N$4;2;0);C2*ВПР(A2;$L$2:$N$4;3;0)*D2;0)
К сообщению приложен файл: 0891851.xlsx(9.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=ЕСЛИ(D2>=ВПР(A2;$L$2:$N$4;2;0);C2*ВПР(A2;$L$2:$N$4;3;0)*D2;0)

Автор - Pelena
Дата добавления - 07.08.2019 в 19:08
Bor109 Дата: Среда, 07.08.2019, 20:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, спасибо большое , идеально то, что нужно!
 
Ответить
СообщениеPelena, спасибо большое , идеально то, что нужно!

Автор - Bor109
Дата добавления - 07.08.2019 в 20:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как связать ID должности и формулу расчета премии? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!