Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если дата попадает в интервал дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если дата попадает в интервал дат (Формулы/Formulas)
Если дата попадает в интервал дат
Chetvertkoff Дата: Четверг, 08.08.2019, 08:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
День добрый, нашел на форуме похожую тему но почему то не получается с теми формулами решить задачу. Суть проста. Есть Интервал дат, он же является сроком отпуска сотрудника. Условие: есть столбцы , каждый из них это месяц. Если интервал дат попадает в какой то месяц то пишется в отпуске, если интервал задевает и следующий месяц то и там пишет в отпуске. Да, именно такой грубы график мне нужен. Прикладываю файл, в нем были формулы которые считали по дням.
К сообщению приложен файл: 4736306.xlsx(15.6 Kb)
 
Ответить
СообщениеДень добрый, нашел на форуме похожую тему но почему то не получается с теми формулами решить задачу. Суть проста. Есть Интервал дат, он же является сроком отпуска сотрудника. Условие: есть столбцы , каждый из них это месяц. Если интервал дат попадает в какой то месяц то пишется в отпуске, если интервал задевает и следующий месяц то и там пишет в отпуске. Да, именно такой грубы график мне нужен. Прикладываю файл, в нем были формулы которые считали по дням.

Автор - Chetvertkoff
Дата добавления - 08.08.2019 в 08:30
китин Дата: Четверг, 08.08.2019, 08:41 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5743
Репутация: 904 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
такой вот монстрик
Код
=ЕСЛИ($B9="";"";ЕСЛИ(И($B9<>"";ИЛИ(ТЕКСТ($C9;"ММММ")=E$8;ТЕКСТ($B9;"ММММ")=E$8));"В отпуске";"На работе"))
К сообщению приложен файл: 2187300.xlsx(14.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетакой вот монстрик
Код
=ЕСЛИ($B9="";"";ЕСЛИ(И($B9<>"";ИЛИ(ТЕКСТ($C9;"ММММ")=E$8;ТЕКСТ($B9;"ММММ")=E$8));"В отпуске";"На работе"))

Автор - китин
Дата добавления - 08.08.2019 в 08:41
_Boroda_ Дата: Четверг, 08.08.2019, 08:44 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15572
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ(И($B9<=КОНМЕСЯЦА(E$7;0);$C9>КОНМЕСЯЦА(E$7;-1));"В отпуске";"На работе")

Код
=ЕСЛИ(И($B9<=КОНМЕСЯЦА(E$7;0);$C9>E$7-ДЕНЬ(E$7));"В отпуске";"На работе")


Так наверное лучше будет
Код
=ТЕКСТ(($B9<=КОНМЕСЯЦА(E$7;0))+($C9>E$7-ДЕНЬ(E$7))+($B9>0)-2;"В отпу\ске;;На работе")
К сообщению приложен файл: 4736306_1.xlsx(14.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(И($B9<=КОНМЕСЯЦА(E$7;0);$C9>КОНМЕСЯЦА(E$7;-1));"В отпуске";"На работе")

Код
=ЕСЛИ(И($B9<=КОНМЕСЯЦА(E$7;0);$C9>E$7-ДЕНЬ(E$7));"В отпуске";"На работе")


Так наверное лучше будет
Код
=ТЕКСТ(($B9<=КОНМЕСЯЦА(E$7;0))+($C9>E$7-ДЕНЬ(E$7))+($B9>0)-2;"В отпу\ске;;На работе")

Автор - _Boroda_
Дата добавления - 08.08.2019 в 08:44
Chetvertkoff Дата: Четверг, 08.08.2019, 08:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 40
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята вы боги!!!! Спасибо)))
 
Ответить
СообщениеРебята вы боги!!!! Спасибо)))

Автор - Chetvertkoff
Дата добавления - 08.08.2019 в 08:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если дата попадает в интервал дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!