Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Макрос для сравнения содержимого ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Макрос для сравнения содержимого ячеек (Формулы/Formulas)
Макрос для сравнения содержимого ячеек
dyhak Дата: Суббота, 10.08.2019, 11:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Прошу оказать помощь в решении возникшей задачи.
Уверен что что-то подобное уже решалось не единожды, ткните носом)

Дано:
Есть 2 файла эксель.
В первом файле: столбец (A) (порядка 40000 строк). Столбец (B) (количество строк совпадает). Данные присутствуют в 2 столбцах.
Все данные уникальны, повторов нет.

Во втором файле столбец (A) (порядка 40000 строк, чье содержимое соответствует столбцу (А) файла 1, но вперемешку. Количество строк отличается от количества строк в файле 1). Все данные уникальны, повторов нет.

Требуется: сравнить содержимое столбцов А первого и второго файла, и в случае полного совпадения ячеек сопоставить в ячейку (В) файла 2 данные из столбца (В) файла 1. Строки, в которых данные не совпали, подкрасить цветом.

Надеюсь более или менее понятно. Помогите пожалуйста.

Буду признателен за оказанную помощь. Спасибо!!!
К сообщению приложен файл: 6310629.xlsx(12.4 Kb)


Сообщение отредактировал dyhak - Суббота, 10.08.2019, 11:46
 
Ответить
СообщениеЗдравствуйте! Прошу оказать помощь в решении возникшей задачи.
Уверен что что-то подобное уже решалось не единожды, ткните носом)

Дано:
Есть 2 файла эксель.
В первом файле: столбец (A) (порядка 40000 строк). Столбец (B) (количество строк совпадает). Данные присутствуют в 2 столбцах.
Все данные уникальны, повторов нет.

Во втором файле столбец (A) (порядка 40000 строк, чье содержимое соответствует столбцу (А) файла 1, но вперемешку. Количество строк отличается от количества строк в файле 1). Все данные уникальны, повторов нет.

Требуется: сравнить содержимое столбцов А первого и второго файла, и в случае полного совпадения ячеек сопоставить в ячейку (В) файла 2 данные из столбца (В) файла 1. Строки, в которых данные не совпали, подкрасить цветом.

Надеюсь более или менее понятно. Помогите пожалуйста.

Буду признателен за оказанную помощь. Спасибо!!!

Автор - dyhak
Дата добавления - 10.08.2019 в 11:45
Светлый Дата: Суббота, 10.08.2019, 12:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 309 ±
Замечаний: 0% ±

Excel 2010
Обязательно макросом?
Код
=ЕСЛИОШИБКА(ВПР(H3;$A$3:$B$40000;2;);"")
такая формула плюс условное форматирование даст такое же решение.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеОбязательно макросом?
Код
=ЕСЛИОШИБКА(ВПР(H3;$A$3:$B$40000;2;);"")
такая формула плюс условное форматирование даст такое же решение.

Автор - Светлый
Дата добавления - 10.08.2019 в 12:34
dyhak Дата: Суббота, 10.08.2019, 16:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Цитата Светлый, 10.08.2019 в 12:34, в сообщении № 2 ()
Обязательно макросом?

Вовсе не обязательно. Но формулой у меня не получилось. Сейчас попробую, спасибо!
 
Ответить
Сообщение
Цитата Светлый, 10.08.2019 в 12:34, в сообщении № 2 ()
Обязательно макросом?

Вовсе не обязательно. Но формулой у меня не получилось. Сейчас попробую, спасибо!

Автор - dyhak
Дата добавления - 10.08.2019 в 16:23
dyhak Дата: Суббота, 10.08.2019, 16:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
На простом примере работает, завтра попробую все это в требуемую таблицу запихать. Если честно не ожидал, что так быстро ответят. Спасибо огромное!!!
 
Ответить
СообщениеНа простом примере работает, завтра попробую все это в требуемую таблицу запихать. Если честно не ожидал, что так быстро ответят. Спасибо огромное!!!

Автор - dyhak
Дата добавления - 10.08.2019 в 16:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Макрос для сравнения содержимого ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!