Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разбить одну ячейку на две - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбить одну ячейку на две (Формулы/Formulas)
Разбить одну ячейку на две
lenacia Дата: Среда, 14.08.2019, 12:17 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 102
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Подскажите, пожалуйста, если способ одну ячейку, где содержится информация по дате и времени, разбить на две?
Что бы была отдельно ячейка с датой и ячейка с временем
К сообщению приложен файл: 0865501.xls(25.5 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, пожалуйста, если способ одну ячейку, где содержится информация по дате и времени, разбить на две?
Что бы была отдельно ячейка с датой и ячейка с временем

Автор - lenacia
Дата добавления - 14.08.2019 в 12:17
_Boroda_ Дата: Среда, 14.08.2019, 12:19 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15572
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Функции ОТБР и ОСТАТ
Код
=ОТБР(A2)

Код
=ОСТАТ(A2;1)

или для времени
Код
=A2-E2
А для даты наоборот
К сообщению приложен файл: 0865501_1.xls(34.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФункции ОТБР и ОСТАТ
Код
=ОТБР(A2)

Код
=ОСТАТ(A2;1)

или для времени
Код
=A2-E2
А для даты наоборот

Автор - _Boroda_
Дата добавления - 14.08.2019 в 12:19
bigor Дата: Среда, 14.08.2019, 12:23 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Для даты
Код
=ROUND(A2)
формат ячейки дата
Для времени
Код
=MOD(A2;1)
формат ячейки время
 
Ответить
СообщениеДля даты
Код
=ROUND(A2)
формат ячейки дата
Для времени
Код
=MOD(A2;1)
формат ячейки время

Автор - bigor
Дата добавления - 14.08.2019 в 12:23
китин Дата: Среда, 14.08.2019, 12:25 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 5743
Репутация: 904 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или
Код
=ЦЕЛОЕ(A2)

и
Код
=A2-ЦЕЛОЕ(A2)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили
Код
=ЦЕЛОЕ(A2)

и
Код
=A2-ЦЕЛОЕ(A2)

Автор - китин
Дата добавления - 14.08.2019 в 12:25
_Boroda_ Дата: Среда, 14.08.2019, 12:28 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15572
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
=ОКРУГЛ(A2)

bigor, Вы проверяли?
1. В ОКРУГЛ второй аргумент обязателен
2. Если время >=12 часов, то какую дату даст?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
=ОКРУГЛ(A2)

bigor, Вы проверяли?
1. В ОКРУГЛ второй аргумент обязателен
2. Если время >=12 часов, то какую дату даст?

Автор - _Boroda_
Дата добавления - 14.08.2019 в 12:28
lenacia Дата: Среда, 14.08.2019, 12:31 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 102
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ОТлично! работает
спасибо!
 
Ответить
СообщениеОТлично! работает
спасибо!

Автор - lenacia
Дата добавления - 14.08.2019 в 12:31
китин Дата: Среда, 14.08.2019, 12:37 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5743
Репутация: 904 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и в PQ
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"Столбец1", type any}}),
    #"Повышенные заголовки" = Table.PromoteHeaders(#"Измененный тип", [PromoteAllScalars=true]),
    #"Измененный тип1" = Table.TransformColumnTypes(#"Повышенные заголовки",{{"Дата и время создания", type datetime}}),
    #"Дублированный столбец" = Table.DuplicateColumn(#"Измененный тип1", "Дата и время создания", "Копия Дата и время создания"),
    #"Измененный тип2" = Table.TransformColumnTypes(#"Дублированный столбец",{{"Дата и время создания", type date}}),
    #"Извлеченное время" = Table.TransformColumns(#"Измененный тип2",{{"Копия Дата и время создания", DateTime.Time, type time}})
in
    #"Извлеченное время"
[/vba]
К сообщению приложен файл: 0865501.xlsx(21.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи в PQ
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Измененный тип" = Table.TransformColumnTypes(Источник,{{"Столбец1", type any}}),
    #"Повышенные заголовки" = Table.PromoteHeaders(#"Измененный тип", [PromoteAllScalars=true]),
    #"Измененный тип1" = Table.TransformColumnTypes(#"Повышенные заголовки",{{"Дата и время создания", type datetime}}),
    #"Дублированный столбец" = Table.DuplicateColumn(#"Измененный тип1", "Дата и время создания", "Копия Дата и время создания"),
    #"Измененный тип2" = Table.TransformColumnTypes(#"Дублированный столбец",{{"Дата и время создания", type date}}),
    #"Извлеченное время" = Table.TransformColumns(#"Измененный тип2",{{"Копия Дата и время создания", DateTime.Time, type time}})
in
    #"Извлеченное время"
[/vba]

Автор - китин
Дата добавления - 14.08.2019 в 12:37
bigor Дата: Среда, 14.08.2019, 12:43 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, да, поторопился, вот так ошибок не нашел
Код
=ОКРУГЛ(A2;5)
 
Ответить
Сообщение_Boroda_, да, поторопился, вот так ошибок не нашел
Код
=ОКРУГЛ(A2;5)

Автор - bigor
Дата добавления - 14.08.2019 в 12:43
_Boroda_ Дата: Среда, 14.08.2019, 13:36 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15572
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
вот так ошибок не нашел

=ОКРУГЛ(A2;5)

Уверены? Дата - целое число, а Вы округляете до 5-го знака почему-то
Кстати, еще вариант
Код
=--ТЕКСТ(A2;"Д.М.Г")

Код
=--ТЕКСТ(A2;"ч:м:с")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
вот так ошибок не нашел

=ОКРУГЛ(A2;5)

Уверены? Дата - целое число, а Вы округляете до 5-го знака почему-то
Кстати, еще вариант
Код
=--ТЕКСТ(A2;"Д.М.Г")

Код
=--ТЕКСТ(A2;"ч:м:с")

Автор - _Boroda_
Дата добавления - 14.08.2019 в 13:36
bigor Дата: Среда, 14.08.2019, 14:06 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,
Уверены? Дата - целое число, а Вы округляете до 5-го знака почему-то

В общем отображает верно, но для отображения можно вообще =A2 и формат ячейки дата. А вот если с этими ячейками что-то дальше делать нужно, то мой вариант с округлением не подойдет.(или использовать окрвниз)


Сообщение отредактировал bigor - Среда, 14.08.2019, 14:10
 
Ответить
Сообщение_Boroda_,
Уверены? Дата - целое число, а Вы округляете до 5-го знака почему-то

В общем отображает верно, но для отображения можно вообще =A2 и формат ячейки дата. А вот если с этими ячейками что-то дальше делать нужно, то мой вариант с округлением не подойдет.(или использовать окрвниз)

Автор - bigor
Дата добавления - 14.08.2019 в 14:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбить одну ячейку на две (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!