Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос всей строки на другой лист при совпадении условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос всей строки на другой лист при совпадении условия (Формулы/Formulas)
Перенос всей строки на другой лист при совпадении условия
EvA80 Дата: Среда, 14.08.2019, 17:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Коллеги добрый день, помогите плжт, видимо, пришла куриная слепота, смотрю в книгу и не вижу проблему %)

Суть: При появлении в одном из столбцов (Получатель для одной части примера, Плательщик для другой) на листе заданного значения (здесь ЮТ) строка с этими данными должна переносится на другой лист
Вручную не вариант- строк сейчас уже около 10 000 и постоянно растут
Через макрос тоже, так как будет увеличиваться и количество значений. Обучать менять макросы при создании листа намного сложнее, чем написать инструкцию, что поменять в формуле.

Я нашла решение такой задачи на одном из форумов. 1 в 1 как мне надо, все перенесла к себе - не работает.
Никак не могу увидеть, где моя ошибка.
К сообщению приложен файл: 8305573.xlsm(77.4 Kb)
 
Ответить
СообщениеКоллеги добрый день, помогите плжт, видимо, пришла куриная слепота, смотрю в книгу и не вижу проблему %)

Суть: При появлении в одном из столбцов (Получатель для одной части примера, Плательщик для другой) на листе заданного значения (здесь ЮТ) строка с этими данными должна переносится на другой лист
Вручную не вариант- строк сейчас уже около 10 000 и постоянно растут
Через макрос тоже, так как будет увеличиваться и количество значений. Обучать менять макросы при создании листа намного сложнее, чем написать инструкцию, что поменять в формуле.

Я нашла решение такой задачи на одном из форумов. 1 в 1 как мне надо, все перенесла к себе - не работает.
Никак не могу увидеть, где моя ошибка.

Автор - EvA80
Дата добавления - 14.08.2019 в 17:02
_Boroda_ Дата: Среда, 14.08.2019, 17:13 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Нужно не "ЮТ ", а "ЮТ" и не в F, а в G
Код
=ЕСЛИОШИБКА(ИНДЕКС(Основной!$B$2:$B$25;НАИМЕНЬШИЙ(ЕСЛИ(Основной!$G$2:$G$25="ЮТ";СТРОКА(Основной!$B$2:$B$25)-1);СТРОКА(A1)));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Основной!$B:$B;НАИМЕНЬШИЙ(ЕСЛИ(Основной!$G$2:$G$25="ЮТ";СТРОКА(Основной!$2:$25));СТРОКА(A1)));"")

Можно еще так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(Основной!$G$2:$G$25="ЮТ";Основной!$B$2:$B$25);СТРОКА(A1));"")
К сообщению приложен файл: 8305573_1.xlsm(75.8 Kb) · 8305573_2.xlsm(75.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНужно не "ЮТ ", а "ЮТ" и не в F, а в G
Код
=ЕСЛИОШИБКА(ИНДЕКС(Основной!$B$2:$B$25;НАИМЕНЬШИЙ(ЕСЛИ(Основной!$G$2:$G$25="ЮТ";СТРОКА(Основной!$B$2:$B$25)-1);СТРОКА(A1)));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Основной!$B:$B;НАИМЕНЬШИЙ(ЕСЛИ(Основной!$G$2:$G$25="ЮТ";СТРОКА(Основной!$2:$25));СТРОКА(A1)));"")

Можно еще так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(Основной!$G$2:$G$25="ЮТ";Основной!$B$2:$B$25);СТРОКА(A1));"")

Автор - _Boroda_
Дата добавления - 14.08.2019 в 17:13
EvA80 Дата: Среда, 14.08.2019, 17:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Точно, вот что значит глаз замылен - знаю нужен Получатель и тупо указываю этот столбец.
Спасибо Вам большое, а то уперлась в стенку и простейшего косяка не вижу.
Дальше сама добью по верным столбцам
 
Ответить
СообщениеТочно, вот что значит глаз замылен - знаю нужен Получатель и тупо указываю этот столбец.
Спасибо Вам большое, а то уперлась в стенку и простейшего косяка не вижу.
Дальше сама добью по верным столбцам

Автор - EvA80
Дата добавления - 14.08.2019 в 17:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос всей строки на другой лист при совпадении условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!