Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Получить инициалы из полного ФИО, игнорируя порядковый номер - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить инициалы из полного ФИО, игнорируя порядковый номер (Формулы/Formulas)
Получить инициалы из полного ФИО, игнорируя порядковый номер
Leem Дата: Пятница, 16.08.2019, 11:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья. Закончился мой больничный и я с новыми силами, упрощаю себе/себя на работе.
Решив предыдущие задачи с вашей помощью, прошу решить еще один пример для упрощения.

Из ворда в эксель будет вставляться список людей по типу
1. Иванов Иван Иванович
2. Петров Петр Петрович.
27.Семенов Семен Семенович

Список будет разный по количеству, но одинаковый по форме.
Необходимо на выходе получить список:

Иванов И.И.
Петров П.П.
Семенов С.С.

т.е. убрать порядковый номер и получить фамилию и инициалы
файл приложил.
Это возможно?
К сообщению приложен файл: 4317426.xlsx(9.2 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья. Закончился мой больничный и я с новыми силами, упрощаю себе/себя на работе.
Решив предыдущие задачи с вашей помощью, прошу решить еще один пример для упрощения.

Из ворда в эксель будет вставляться список людей по типу
1. Иванов Иван Иванович
2. Петров Петр Петрович.
27.Семенов Семен Семенович

Список будет разный по количеству, но одинаковый по форме.
Необходимо на выходе получить список:

Иванов И.И.
Петров П.П.
Семенов С.С.

т.е. убрать порядковый номер и получить фамилию и инициалы
файл приложил.
Это возможно?

Автор - Leem
Дата добавления - 16.08.2019 в 11:19
Nic70y Дата: Пятница, 16.08.2019, 11:28 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";2))+1);СИМВОЛ(160);ПОВТОР(" ";97));97))&"."&ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";3))+1;1)&"."


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";2))+1);СИМВОЛ(160);ПОВТОР(" ";97));97))&"."&ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";3))+1;1)&"."

Автор - Nic70y
Дата добавления - 16.08.2019 в 11:28
китин Дата: Пятница, 16.08.2019, 11:39 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеЕсли у вас действительно офис 2013 то почитайте тут

Автор - китин
Дата добавления - 16.08.2019 в 11:39
Leem Дата: Пятница, 16.08.2019, 11:43 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";2))+1);СИМВОЛ(160);ПОВТОР(" ";97));97))&"."&ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";3))+1;1)&"."


Да. Подошло, но можно ли добавить, чтобы при ошибке выдавался пробел вместо #ЗНАЧ! ?

Все. Решил сам. Благодарю


Ктулху всех спасет

Сообщение отредактировал Leem - Пятница, 16.08.2019, 12:00
 
Ответить
Сообщение
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";2))+1);СИМВОЛ(160);ПОВТОР(" ";97));97))&"."&ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";3))+1;1)&"."


Да. Подошло, но можно ли добавить, чтобы при ошибке выдавался пробел вместо #ЗНАЧ! ?

Все. Решил сам. Благодарю

Автор - Leem
Дата добавления - 16.08.2019 в 11:43
Nic70y Дата: Пятница, 16.08.2019, 11:51 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
пробел
зачем?
лучше ничего
Код
=ЕСЛИОШИБКА(_тут_формула_;"")


ЯД(poison) 41001841029809
 
Ответить
Сообщение
пробел
зачем?
лучше ничего
Код
=ЕСЛИОШИБКА(_тут_формула_;"")

Автор - Nic70y
Дата добавления - 16.08.2019 в 11:51
Leem Дата: Пятница, 16.08.2019, 12:01 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
зачем?
лучше ничего

Да, благодарю. Сделал


Ктулху всех спасет
 
Ответить
Сообщение
зачем?
лучше ничего

Да, благодарю. Сделал

Автор - Leem
Дата добавления - 16.08.2019 в 12:01
Светлый Дата: Пятница, 16.08.2019, 13:47 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Ещё вариант:
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&"."&ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)+1;1)&".";ПОИСК(" ";A1)+1;99);"")
или без отчества:
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&"."&ЕСЛИОШИБКА(ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)+1;1)&".";"");ПОИСК(" ";A1)+1;99);"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕщё вариант:
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&"."&ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)+1;1)&".";ПОИСК(" ";A1)+1;99);"")
или без отчества:
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&"."&ЕСЛИОШИБКА(ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)+1;1)&".";"");ПОИСК(" ";A1)+1;99);"")

Автор - Светлый
Дата добавления - 16.08.2019 в 13:47
Никанор Дата: Вторник, 20.08.2019, 10:40 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 463
Репутация: 8 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые отвечающие!
Вопрос Leem, – Andrew решён разными вариантами.
Но Светлый, – Сергей пишет:
Цитата Светлый, 16.08.2019 в 13:47, в сообщении № 7 ()
или без отчества:

Но у меня формула
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&"."&ЕСЛИОШИБКА(ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)+1;1)&".";"");ПОИСК(" ";A1)+1;99);"")
даёт результат тоже фамилия и инициалы с отчеством.
Вопрос: как эту или другие варианты формул изменить что бы результат был как пишет Светлый, – Сергей без отчества?

У меня Excel 2007. Может в Excel 2010 или в Excel 2013 эта формула даёт результат без отчества?
 
Ответить
СообщениеЗдравствуйте уважаемые отвечающие!
Вопрос Leem, – Andrew решён разными вариантами.
Но Светлый, – Сергей пишет:
Цитата Светлый, 16.08.2019 в 13:47, в сообщении № 7 ()
или без отчества:

Но у меня формула
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&"."&ЕСЛИОШИБКА(ПСТР(A1;ПОИСК(" ";A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)+1;1)&".";"");ПОИСК(" ";A1)+1;99);"")
даёт результат тоже фамилия и инициалы с отчеством.
Вопрос: как эту или другие варианты формул изменить что бы результат был как пишет Светлый, – Сергей без отчества?

У меня Excel 2007. Может в Excel 2010 или в Excel 2013 эта формула даёт результат без отчества?

Автор - Никанор
Дата добавления - 20.08.2019 в 10:40
Nic70y Дата: Вторник, 20.08.2019, 10:59 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 5607
Репутация: 1227 ±
Замечаний: 0% ±

ru13;10;03
из формулы сооб. №2 выбросить
&ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";3))+1;1)&"."


ЯД(poison) 41001841029809
 
Ответить
Сообщениеиз формулы сооб. №2 выбросить
&ПСТР(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";3))+1;1)&"."

Автор - Nic70y
Дата добавления - 20.08.2019 в 10:59
Светлый Дата: Вторник, 20.08.2019, 11:06 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Цитата Никанор, 20.08.2019 в 10:40, в сообщении № 8 ()
тоже фамилия и инициалы с отчеством
Данная формула просто не выдаёт ошибку, если есть только фамилия и имя.
Если Вам не нужен инициал отчества:
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&".";ПОИСК(" ";A1)+1;99);"")


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Цитата Никанор, 20.08.2019 в 10:40, в сообщении № 8 ()
тоже фамилия и инициалы с отчеством
Данная формула просто не выдаёт ошибку, если есть только фамилия и имя.
Если Вам не нужен инициал отчества:
Код
=ЕСЛИОШИБКА(ПСТР(ЛЕВБ(A1;ПОИСК(" ";A1;ПОИСК(" ";A1)+1)+1)&".";ПОИСК(" ";A1)+1;99);"")

Автор - Светлый
Дата добавления - 20.08.2019 в 11:06
Никанор Дата: Вторник, 20.08.2019, 11:07 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 463
Репутация: 8 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемый Nic70y, – Николай!
Большое спасибо за правильный ответ на 19 (девятнадцатой) минуте после публикации моего вопроса.
Выбросил и получилась формула, которая даёт верный – требуемый результат.
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";2))+1);СИМВОЛ(160);ПОВТОР(" ";97));97))&"."


Сообщение отредактировал Никанор - Вторник, 20.08.2019, 11:12
 
Ответить
СообщениеЗдравствуйте уважаемый Nic70y, – Николай!
Большое спасибо за правильный ответ на 19 (девятнадцатой) минуте после публикации моего вопроса.
Выбросил и получилась формула, которая даёт верный – требуемый результат.
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(ЛЕВБ(A1;ПОИСК("\";ПОДСТАВИТЬ(A1;" ";"\";2))+1);СИМВОЛ(160);ПОВТОР(" ";97));97))&"."

Автор - Никанор
Дата добавления - 20.08.2019 в 11:07
Никанор Дата: Вторник, 20.08.2019, 11:17 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 463
Репутация: 8 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемый Светлый, – Сергей!
Большое спасибо за правильный ответ и объяснение на 26 (двадцать шестой) минуте после публикации моего вопроса.
 
Ответить
СообщениеЗдравствуйте уважаемый Светлый, – Сергей!
Большое спасибо за правильный ответ и объяснение на 26 (двадцать шестой) минуте после публикации моего вопроса.

Автор - Никанор
Дата добавления - 20.08.2019 в 11:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получить инициалы из полного ФИО, игнорируя порядковый номер (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!