Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать все данные в ячейках с определёнными значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать все данные в ячейках с определёнными значениям (Формулы/Formulas)
Как посчитать все данные в ячейках с определёнными значениям
byte32 Дата: Вторник, 20.08.2019, 13:41 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Друзья, помогите написать формулу. Задача:

В Строках A стоят даты. (в формате 20.07.18) В Строках B стоят цифры.

Как сделать формулу, чтобы она посчитала сумму всех чисел, но только за определённую дату, а именно за определённый месяц?

Во вложении пример
К сообщению приложен файл: ExcelWorld.xlsx(8.3 Kb)
 
Ответить
СообщениеДрузья, помогите написать формулу. Задача:

В Строках A стоят даты. (в формате 20.07.18) В Строках B стоят цифры.

Как сделать формулу, чтобы она посчитала сумму всех чисел, но только за определённую дату, а именно за определённый месяц?

Во вложении пример

Автор - byte32
Дата добавления - 20.08.2019 в 13:41
китин Дата: Вторник, 20.08.2019, 14:43 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=СУММПРОИЗВ($B$2:$B$7*(МЕСЯЦ($A$2:$A$7)=МЕСЯЦ($E1)))

в солбце Е стоят дады типа 01.07.2018 формат ячеек
"Общая сумма за " ММММ
К сообщению приложен файл: 6942108.xlsx(8.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо?
Код
=СУММПРОИЗВ($B$2:$B$7*(МЕСЯЦ($A$2:$A$7)=МЕСЯЦ($E1)))

в солбце Е стоят дады типа 01.07.2018 формат ячеек
"Общая сумма за " ММММ

Автор - китин
Дата добавления - 20.08.2019 в 14:43
_Boroda_ Дата: Вторник, 20.08.2019, 15:54 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты. Ничего не меняя в файле
Код
=СУММПРОИЗВ(B$2:B$9*(E1=ТЕКСТ(A$2:A$9;"Общая \су\м\ма за ММММ")))

Или
Код
=СУММПРОИЗВ(B$2:B$9*(ПСТР(E1;16;3)=ТЕКСТ(A$2:A$9;"МММ")))
К сообщению приложен файл: ExcelWorld55_1.xlsx(8.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты. Ничего не меняя в файле
Код
=СУММПРОИЗВ(B$2:B$9*(E1=ТЕКСТ(A$2:A$9;"Общая \су\м\ма за ММММ")))

Или
Код
=СУММПРОИЗВ(B$2:B$9*(ПСТР(E1;16;3)=ТЕКСТ(A$2:A$9;"МММ")))

Автор - _Boroda_
Дата добавления - 20.08.2019 в 15:54
bmv98rus Дата: Вторник, 20.08.2019, 17:22 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2527
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUMIFS(B:B;A:A;">="&--"1"&MID(E1;16;10)&YEAR($A$2);A:A;"<"&EDATE(--"1" & MID(E1;16;10)&YEAR($A$2);1))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=SUMIFS(B:B;A:A;">="&--"1"&MID(E1;16;10)&YEAR($A$2);A:A;"<"&EDATE(--"1" & MID(E1;16;10)&YEAR($A$2);1))

Автор - bmv98rus
Дата добавления - 20.08.2019 в 17:22
_Boroda_ Дата: Вторник, 20.08.2019, 18:03 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Там можно без дней и минусов, ну и в сентябре 8 букв
Код
=СУММЕСЛИМН(B:B;A:A;">="&ПСТР(E1;16;8)&ГОД(A$2);A:A;"<"&ДАТАМЕС(ПСТР(E1;16;9)&ГОД(A$2);1))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТам можно без дней и минусов, ну и в сентябре 8 букв
Код
=СУММЕСЛИМН(B:B;A:A;">="&ПСТР(E1;16;8)&ГОД(A$2);A:A;"<"&ДАТАМЕС(ПСТР(E1;16;9)&ГОД(A$2);1))

Автор - _Boroda_
Дата добавления - 20.08.2019 в 18:03
bmv98rus Дата: Вторник, 20.08.2019, 18:11 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2527
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
_Boroda_, 10 - чтоб не промахнуться :-). про остальное забыл. Честно говоря больше YEAR(A$2) бесит, но как без него.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение_Boroda_, 10 - чтоб не промахнуться :-). про остальное забыл. Честно говоря больше YEAR(A$2) бесит, но как без него.

Автор - bmv98rus
Дата добавления - 20.08.2019 в 18:11
Arti Дата: Среда, 21.08.2019, 15:30 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Оффтоп:
Доброго времени суток, Уважаемые форумчане!
Подскажите пожалуйста, где можно ознакомиться с информацией к применению символов "\" и не только в функции ТЕКСТ?
Постоянно вижу, как знатоки практически "наизнанку" используют этот инструмент, а поисковики умалчивают таинство древних знаний!

Заранее благодарю!


Я не я и суета не моя
 
Ответить
СообщениеОффтоп:
Доброго времени суток, Уважаемые форумчане!
Подскажите пожалуйста, где можно ознакомиться с информацией к применению символов "\" и не только в функции ТЕКСТ?
Постоянно вижу, как знатоки практически "наизнанку" используют этот инструмент, а поисковики умалчивают таинство древних знаний!

Заранее благодарю!

Автор - Arti
Дата добавления - 21.08.2019 в 15:30
_Boroda_ Дата: Среда, 21.08.2019, 15:59 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Функция ТЕКСТ - это примерно то же самое, что и формат ячейки (за небольшими исключениями типа звездочки и цветов). А про формат есть у нас Ленинская* статья
http://www.excelworld.ru/publ/hacks/formatting/format_user/63-1-0-141

Думаю, что понятнее будет, если Вы будете конкретные вопросы спрашивать. Например, про "/" - это как кавычки, но для одного символа, тот символ, что идет после /, пишется неизменяемым. То есть по-нормальному "м" означало бы минуты, а вот "/м" - это просто буква "м"

* автор Елена Pelena


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФункция ТЕКСТ - это примерно то же самое, что и формат ячейки (за небольшими исключениями типа звездочки и цветов). А про формат есть у нас Ленинская* статья
http://www.excelworld.ru/publ/hacks/formatting/format_user/63-1-0-141

Думаю, что понятнее будет, если Вы будете конкретные вопросы спрашивать. Например, про "/" - это как кавычки, но для одного символа, тот символ, что идет после /, пишется неизменяемым. То есть по-нормальному "м" означало бы минуты, а вот "/м" - это просто буква "м"

* автор Елена Pelena

Автор - _Boroda_
Дата добавления - 21.08.2019 в 15:59
Arti Дата: Среда, 21.08.2019, 16:09 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_,

Благодарю за отклик и ссылку!
Ваша часть формулы, а именно
Код
=ТЕКСТ(A$2:A$9;"Общая \су\м\ма за ММММ")
вызвала конфуз и уничтожила логические цепочки, которые я тщетно пытался выстроить!


Я не я и суета не моя
 
Ответить
Сообщение_Boroda_,

Благодарю за отклик и ссылку!
Ваша часть формулы, а именно
Код
=ТЕКСТ(A$2:A$9;"Общая \су\м\ма за ММММ")
вызвала конфуз и уничтожила логические цепочки, которые я тщетно пытался выстроить!

Автор - Arti
Дата добавления - 21.08.2019 в 16:09
_Boroda_ Дата: Среда, 21.08.2019, 16:36 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15576
Репутация: 6077 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А в чем конкретно вопрос?
Смотрите, есть несколько букв (сейчас про русскую версию Excel), которые функцией ТЕКСТ понимаются не как просто буквы. Это
Г(г) - год
М - месяц
Д(д) - день
Ч(ч) - час
м - минута
С(с) - секунда
Если эти буквы нужны именно буквами, то их, как и некоторые (какие - обычно определяется методом научного тыка) небуквенные символы, в формате ячейки и во втором аргументе функции ТЕКСТ нужно экранировать знаком "/"
Или заключать в дополнительные кавычки
Код
=ТЕКСТ(D1;"аа""м""бб")
Здесь второй аргумент вот такой - аа"м"бб, а результат такой - аамбб


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА в чем конкретно вопрос?
Смотрите, есть несколько букв (сейчас про русскую версию Excel), которые функцией ТЕКСТ понимаются не как просто буквы. Это
Г(г) - год
М - месяц
Д(д) - день
Ч(ч) - час
м - минута
С(с) - секунда
Если эти буквы нужны именно буквами, то их, как и некоторые (какие - обычно определяется методом научного тыка) небуквенные символы, в формате ячейки и во втором аргументе функции ТЕКСТ нужно экранировать знаком "/"
Или заключать в дополнительные кавычки
Код
=ТЕКСТ(D1;"аа""м""бб")
Здесь второй аргумент вот такой - аа"м"бб, а результат такой - аамбб

Автор - _Boroda_
Дата добавления - 21.08.2019 в 16:36
Arti Дата: Четверг, 22.08.2019, 07:35 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_,

Спасибо, что уделили время и внимание!
Хорошего дня :up:


Я не я и суета не моя
 
Ответить
Сообщение_Boroda_,

Спасибо, что уделили время и внимание!
Хорошего дня :up:

Автор - Arti
Дата добавления - 22.08.2019 в 07:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать все данные в ячейках с определёнными значениям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!