Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значения по двум критериям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения по двум критериям. (Формулы/Formulas)
поиск значения по двум критериям.
Chetvertkoff Дата: Четверг, 22.08.2019, 10:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
добрый, вродибы почти все сделал, но почему то не работает как надо. Точнее причину я знаю, в массиве попадаются одинаковые значения и это сбивает формулу. Вобщем суть такая - я ввожу диаметр трубы и толщину стенки и он мне должен вывести ее вес. Формула уже есть, но что то пошло не так) помогите пожалуйста, и если можно обьясните почему значение выводимое по двум критериям берется именно из среднего столбца?
К сообщению приложен файл: 2644686.xlsx(13.0 Kb)
 
Ответить
Сообщениедобрый, вродибы почти все сделал, но почему то не работает как надо. Точнее причину я знаю, в массиве попадаются одинаковые значения и это сбивает формулу. Вобщем суть такая - я ввожу диаметр трубы и толщину стенки и он мне должен вывести ее вес. Формула уже есть, но что то пошло не так) помогите пожалуйста, и если можно обьясните почему значение выводимое по двум критериям берется именно из среднего столбца?

Автор - Chetvertkoff
Дата добавления - 22.08.2019 в 10:05
китин Дата: Четверг, 22.08.2019, 10:27 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Доброго и вам!!!
1) Почитайте ВНИМАТЕЛЬНО справку по ИНДЕКС
2) объединенные ячейки это зло!!!
Код
=ЕСЛИОШИБКА(ИНДЕКС($B:$B;ПОИСКПОЗ($G3&$H3;$C:$C&$A:$A;0));"Нет такого")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 1602059.xlsx(13.1 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДоброго и вам!!!
1) Почитайте ВНИМАТЕЛЬНО справку по ИНДЕКС
2) объединенные ячейки это зло!!!
Код
=ЕСЛИОШИБКА(ИНДЕКС($B:$B;ПОИСКПОЗ($G3&$H3;$C:$C&$A:$A;0));"Нет такого")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 22.08.2019 в 10:27
Chetvertkoff Дата: Четверг, 22.08.2019, 11:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 43
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Точно, я вообще про это забыл и сижу смотрю на другое и уже был уверен что из-за повторяющихся значений. Спасибо большое
 
Ответить
СообщениеТочно, я вообще про это забыл и сижу смотрю на другое и уже был уверен что из-за повторяющихся значений. Спасибо большое

Автор - Chetvertkoff
Дата добавления - 22.08.2019 в 11:21
Arti Дата: Четверг, 22.08.2019, 11:37 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Как вариант, волатильная!

Код
=ИНДЕКС(СМЕЩ($B$1;ПОИСКПОЗ($H$3;$A$2:$A$80;);;4);ПОИСКПОЗ($G$3;ИНДЕКС(СМЕЩ($C$1;ПОИСКПОЗ($H$3;$A$2:$A$80;);;4););))


Я не я и суета не моя
 
Ответить
СообщениеКак вариант, волатильная!

Код
=ИНДЕКС(СМЕЩ($B$1;ПОИСКПОЗ($H$3;$A$2:$A$80;);;4);ПОИСКПОЗ($G$3;ИНДЕКС(СМЕЩ($C$1;ПОИСКПОЗ($H$3;$A$2:$A$80;);;4););))

Автор - Arti
Дата добавления - 22.08.2019 в 11:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения по двум критериям. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!