Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества человек по условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества человек по условиям (Формулы/Formulas)
Подсчет количества человек по условиям
Romzay84 Дата: Пятница, 30.08.2019, 00:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер форумчане. Несколько дней бьюсь над задачей посчитать сколько человек получат аванс по 1500 и 1000 рублей - это зависит от кол-ва смен (столбец B на листе Август 2019). После этого аванс получат те кто отработал на определенную дату (столбец А) больше 5 смен. Если на определенную дату у человека нет 5 отработанных смен, то надо проверить столбец С на листе Август 2019. Если там отражено, что человек отработал больше 5 смен, то аванс получает.
Пробовал СЧЁТЕСЛИ и СУММПРОИЗВ, но что-то не выходит. Очень нужна формула.
Пример во вложении
К сообщению приложен файл: 3159712.xls(29.5 Kb)
 
Ответить
СообщениеДобрый вечер форумчане. Несколько дней бьюсь над задачей посчитать сколько человек получат аванс по 1500 и 1000 рублей - это зависит от кол-ва смен (столбец B на листе Август 2019). После этого аванс получат те кто отработал на определенную дату (столбец А) больше 5 смен. Если на определенную дату у человека нет 5 отработанных смен, то надо проверить столбец С на листе Август 2019. Если там отражено, что человек отработал больше 5 смен, то аванс получает.
Пробовал СЧЁТЕСЛИ и СУММПРОИЗВ, но что-то не выходит. Очень нужна формула.
Пример во вложении

Автор - Romzay84
Дата добавления - 30.08.2019 в 00:31
Светлый Дата: Пятница, 30.08.2019, 09:36 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Массивная формула (вводится одновременным нажатием Ctrl+Shift+Enter):
Код
=СУММ(Ч('Август 2019'!C2:C11+МУМНОЖ(('Август 2019'!F1:AJ1<=A1)*(Ч(+'Август 2019'!F2:AJ11)>0);ТРАНСП('Август 2019'!F1:AJ1)^0)>5))
*А для >=55 формула:
Код
=СУММ(('Август 2019'!$C2:$C11+МУМНОЖ(('Август 2019'!$F1:$AJ1<=$A1)*(Ч(+'Август 2019'!$F2:$AJ11)>0);ТРАНСП('Август 2019'!$F1:$AJ1)^0)>5)*(1-СТОЛБЕЦ(A4)=-('Август 2019'!$B2:$B11<55)))
и скопировать во вторую жёлтую ячейку.
**Файл заменил.
К сообщению приложен файл: 3159712-1.xls(31.5 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 30.08.2019, 11:10
 
Ответить
СообщениеДобрый день!
Массивная формула (вводится одновременным нажатием Ctrl+Shift+Enter):
Код
=СУММ(Ч('Август 2019'!C2:C11+МУМНОЖ(('Август 2019'!F1:AJ1<=A1)*(Ч(+'Август 2019'!F2:AJ11)>0);ТРАНСП('Август 2019'!F1:AJ1)^0)>5))
*А для >=55 формула:
Код
=СУММ(('Август 2019'!$C2:$C11+МУМНОЖ(('Август 2019'!$F1:$AJ1<=$A1)*(Ч(+'Август 2019'!$F2:$AJ11)>0);ТРАНСП('Август 2019'!$F1:$AJ1)^0)>5)*(1-СТОЛБЕЦ(A4)=-('Август 2019'!$B2:$B11<55)))
и скопировать во вторую жёлтую ячейку.
**Файл заменил.

Автор - Светлый
Дата добавления - 30.08.2019 в 09:36
Romzay84 Дата: Понедельник, 02.09.2019, 01:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Светлый, спасибо огромное. Всё работает. Вообще с формулами неправильно думал. Мне ещё учиться и учиться)
 
Ответить
СообщениеСветлый, спасибо огромное. Всё работает. Вообще с формулами неправильно думал. Мне ещё учиться и учиться)

Автор - Romzay84
Дата добавления - 02.09.2019 в 01:31
bmv98rus Дата: Понедельник, 02.09.2019, 10:07 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2527
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013/2016
Светлый, MMULT короче можно
Код
=MMULT(-(N(+'Август 2019'!$F2:$AJ11)>0);TRANSPOSE(-('Август 2019'!$F1:$AJ1<=$A1)))  


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 02.09.2019, 10:10
 
Ответить
СообщениеСветлый, MMULT короче можно
Код
=MMULT(-(N(+'Август 2019'!$F2:$AJ11)>0);TRANSPOSE(-('Август 2019'!$F1:$AJ1<=$A1)))  

Автор - bmv98rus
Дата добавления - 02.09.2019 в 10:07
Светлый Дата: Вторник, 03.09.2019, 09:58 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
bmv98rus, точно. Не додумался.
Тогда формула будет выглядеть так:
Код
=СУММ(('Август 2019'!$C2:$C11+МУМНОЖ(-(Ч(+'Август 2019'!$F2:$AJ11)>0);ТРАНСП(-('Август 2019'!$F1:$AJ1<=$A1))) >5)*(1-СТОЛБЕЦ(A4)=-('Август 2019'!$B2:$B11<55)))
*Немного ещё сократил
Код
=СУММ(('Август 2019'!$C2:$C11+МУМНОЖ(Ч('Август 2019'!$F2:$AJ11<"");ТРАНСП(Ч('Август 2019'!$F1:$AJ1<=$A1))) >5)*(2-СТОЛБЕЦ()=-('Август 2019'!$B2:$B11<55)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 03.09.2019, 20:04
 
Ответить
Сообщениеbmv98rus, точно. Не додумался.
Тогда формула будет выглядеть так:
Код
=СУММ(('Август 2019'!$C2:$C11+МУМНОЖ(-(Ч(+'Август 2019'!$F2:$AJ11)>0);ТРАНСП(-('Август 2019'!$F1:$AJ1<=$A1))) >5)*(1-СТОЛБЕЦ(A4)=-('Август 2019'!$B2:$B11<55)))
*Немного ещё сократил
Код
=СУММ(('Август 2019'!$C2:$C11+МУМНОЖ(Ч('Август 2019'!$F2:$AJ11<"");ТРАНСП(Ч('Август 2019'!$F1:$AJ1<=$A1))) >5)*(2-СТОЛБЕЦ()=-('Август 2019'!$B2:$B11<55)))

Автор - Светлый
Дата добавления - 03.09.2019 в 09:58
Romzay84 Дата: Среда, 04.09.2019, 00:19 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Светлый, спасибо большое. bmv98rus и вам спасибо за подсказку.
 
Ответить
СообщениеСветлый, спасибо большое. bmv98rus и вам спасибо за подсказку.

Автор - Romzay84
Дата добавления - 04.09.2019 в 00:19
Romzay84 Дата: Вторник, 10.09.2019, 01:53 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
В продолжение темы. Пытался сам сделать, но никак не получается. Как возможно сделать, чтобы вместо количества человек был пофамильный список с суммой аванса напротив каждой фамилии по условиям, которые были ранее + если на дату формирования списка или ранее у сотрудника в табеле уже стояло ОВ, то он не попадает в список.
К сообщению приложен файл: 3159712-1-1-.xls(33.5 Kb)
 
Ответить
СообщениеВ продолжение темы. Пытался сам сделать, но никак не получается. Как возможно сделать, чтобы вместо количества человек был пофамильный список с суммой аванса напротив каждой фамилии по условиям, которые были ранее + если на дату формирования списка или ранее у сотрудника в табеле уже стояло ОВ, то он не попадает в список.

Автор - Romzay84
Дата добавления - 10.09.2019 в 01:53
Светлый Дата: Вторник, 10.09.2019, 07:08 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1272
Репутация: 322 ±
Замечаний: 0% ±

Excel 2010
А это уже другой вопрос. Создайте новую тему.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеА это уже другой вопрос. Создайте новую тему.

Автор - Светлый
Дата добавления - 10.09.2019 в 07:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества человек по условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!